summaryrefslogtreecommitdiffstats
path: root/php-phpdocumentor-reflection-common2.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-13 08:23:37 +0200
committerRemi Collet <remi@remirepo.net>2019-09-13 08:23:37 +0200
commita687321e9ef5a5b9cc1b69df76da98571818b8de (patch)
treec6f5ce0b983994b4ecc8678ba26a9fcc8988a5a1 /php-phpdocumentor-reflection-common2.spec
parent8adc96990d15332963f10d50ba0a4be1e58a8735 (diff)
- update to 2.0.0
- rename to php-phpdocumentor-reflection-common2 - move to /usr/share/php/phpDocumentor/Reflection2 - raise dependency on PHP 7.1 - use phpunit6
Diffstat (limited to 'php-phpdocumentor-reflection-common2.spec')
-rw-r--r--php-phpdocumentor-reflection-common2.spec59
1 files changed, 33 insertions, 26 deletions
diff --git a/php-phpdocumentor-reflection-common2.spec b/php-phpdocumentor-reflection-common2.spec
index 4264e4f..8762ee2 100644
--- a/php-phpdocumentor-reflection-common2.spec
+++ b/php-phpdocumentor-reflection-common2.spec
@@ -1,8 +1,6 @@
-# remirepo spec file for php-phpdocumentor-reflection-common, from:
+# remirepo/fedora spec file for php-phpdocumentor-reflection-common2
#
-# Fedora spec file for php-phpdocumentor-reflection-common
-#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Remi Collet, Shawn Iwinski
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,21 +10,23 @@
%global github_owner phpDocumentor
%global github_name ReflectionCommon
-%global github_version 1.0.1
-%global github_commit 21bdeb5f65d7ebf9f43b1b25d404f87deab5bfb6
+%global github_version 2.0.0
+%global github_commit 63a995caa1ca9e5590304cd845c15ad6d482a62a
%global composer_vendor phpdocumentor
%global composer_project reflection-common
-# "php": ">=5.5"
-%global php_min_ver 5.5
+%global major 2
+
+# "php": ">=7.1"
+%global php_min_ver 7.1
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
%{!?phpdir: %global phpdir %{_datadir}/php}
-Name: php-%{composer_vendor}-%{composer_project}
+Name: php-%{composer_vendor}-%{composer_project}%{major}
Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Common reflection classes used by phpdocumentor
@@ -35,17 +35,17 @@ Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
# GitHub export does not include tests.
-# Run php-phpdocumentor-type-resolver-get-source.sh to create full source.
+# Run makesrc.sh to create full source.
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
-Source1: %{name}-get-source.sh
+Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 1.0)
+BuildRequires: phpunit6
+## phpcompatinfo (computed from version 2.0.0)
BuildRequires: php-pcre
BuildRequires: php-spl
## Autoloader
@@ -54,7 +54,7 @@ BuildRequires: php-fedora-autoloader-devel
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.0)
+# phpcompatinfo (computed from version 2.0.0)
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -80,19 +80,19 @@ Autoloader: %{phpdir}/phpDocumentor/Reflection/autoload-common.php
%install
mkdir -p %{buildroot}%{phpdir}/phpDocumentor
-cp -rp src %{buildroot}%{phpdir}/phpDocumentor/Reflection
+cp -rp src %{buildroot}%{phpdir}/phpDocumentor/Reflection%{major}
%check
%if %{with_tests}
-BOOTSTRAP=%{buildroot}%{phpdir}/phpDocumentor/Reflection/autoload-common.php
+BOOTSTRAP=%{buildroot}%{phpdir}/phpDocumentor/Reflection%{major}/autoload-common.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php56 php70 php71 php72; do
+for PHP_EXEC in php php71 php72 php73 php74; do
if which $PHP_EXEC; then
$PHP_EXEC -d auto_prepend_file=$BOOTSTRAP \
- %{_bindir}/phpunit --verbose || RETURN_CODE=1
+ %{_bindir}/phpunit6 --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -107,17 +107,24 @@ exit $RETURN_CODE
%doc *.md
%doc composer.json
%dir %{phpdir}/phpDocumentor
-%dir %{phpdir}/phpDocumentor/Reflection
- %{phpdir}/phpDocumentor/Reflection/autoload-common.php
- %{phpdir}/phpDocumentor/Reflection/Element.php
- %{phpdir}/phpDocumentor/Reflection/File.php
- %{phpdir}/phpDocumentor/Reflection/Fqsen.php
- %{phpdir}/phpDocumentor/Reflection/Location.php
- %{phpdir}/phpDocumentor/Reflection/Project.php
- %{phpdir}/phpDocumentor/Reflection/ProjectFactory.php
+%dir %{phpdir}/phpDocumentor/Reflection%{major}
+ %{phpdir}/phpDocumentor/Reflection%{major}/autoload-common.php
+ %{phpdir}/phpDocumentor/Reflection%{major}/Element.php
+ %{phpdir}/phpDocumentor/Reflection%{major}/File.php
+ %{phpdir}/phpDocumentor/Reflection%{major}/Fqsen.php
+ %{phpdir}/phpDocumentor/Reflection%{major}/Location.php
+ %{phpdir}/phpDocumentor/Reflection%{major}/Project.php
+ %{phpdir}/phpDocumentor/Reflection%{major}/ProjectFactory.php
%changelog
+* Fri Sep 13 2019 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+- rename to php-phpdocumentor-reflection-common2
+- move to /usr/share/php/phpDocumentor/Reflection2
+- raise dependency on PHP 7.1
+- use phpunit6
+
* Sat Nov 18 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
- Update to 1.0.1
- ensure current version is used during the test