summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-07 09:39:18 +0200
committerRemi Collet <remi@remirepo.net>2020-09-07 09:39:18 +0200
commit81efba1f6d90f853cdfaa7c4f71d9e1069a44dd3 (patch)
tree8fcce7c5450c7b653453bd8b62d596d2d28452bf
parent0924855544088c795a49be069196222ea4959e32 (diff)
update to 2.9.1
fix zend-cache autoloader
-rw-r--r--phpdoc-php-warning-count-fix.patch13
-rw-r--r--phpdoc.spec77
2 files changed, 39 insertions, 51 deletions
diff --git a/phpdoc-php-warning-count-fix.patch b/phpdoc-php-warning-count-fix.patch
deleted file mode 100644
index a307863..0000000
--- a/phpdoc-php-warning-count-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/phpDocumentor/Plugin/Core/Descriptor/Validator/Constraints/Functions/IsArgumentInDocBlockValidator.php b/src/phpDocumentor/Plugin/Core/Descriptor/Validator/Constraints/Functions/IsArgumentInDocBlockValidator.php
-index 1e31c932..4baf2fb4 100644
---- a/src/phpDocumentor/Plugin/Core/Descriptor/Validator/Constraints/Functions/IsArgumentInDocBlockValidator.php
-+++ b/src/phpDocumentor/Plugin/Core/Descriptor/Validator/Constraints/Functions/IsArgumentInDocBlockValidator.php
-@@ -30,7 +30,7 @@ class IsArgumentInDocBlockValidator extends ConstraintValidator
- */
- public function validate($value, Constraint $constraint)
- {
-- if ($value instanceof ValidationValueObject && count($value->argument) > 0) {
-+ if ($value instanceof ValidationValueObject && $value->argument instanceof Countable && count($value->argument) > 0) {
- $argument = $value->argument;
- /* @var $params \phpDocumentor\Descriptor\Collection */
- $params = $value->parameters;
diff --git a/phpdoc.spec b/phpdoc.spec
index a5a5a26..2da513a 100644
--- a/phpdoc.spec
+++ b/phpdoc.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for phpdoc
#
-# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2020 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner phpDocumentor
%global github_name phpDocumentor2
-%global github_version 2.9.0
-%global github_commit be607da0eef9b9249c43c5b4820d25d631c73667
+%global github_version 2.9.1
+%global github_commit 2e4f981a55ebe6f5db592d7da892d13d5b3c7816
%global composer_vendor phpdocumentor
%global composer_project phpdocumentor
@@ -65,25 +65,20 @@
%global twig_min_ver 1.3
%global twig_max_ver 2.0
# "zendframework/zend-cache": "~2.1"
-# NOTE: Max version not 3.0 because tests pass
%global zendframework_cache_min_ver 2.1
-%global zendframework_cache_max_ver 4.0
+%global zendframework_cache_max_ver 3.0
# "zendframework/zend-config": "~2.1"
-# NOTE: Max version not 3.0 because tests pass
%global zendframework_config_min_ver 2.1
-%global zendframework_config_max_ver 4.0
+%global zendframework_config_max_ver 3.0
# "zendframework/zend-filter": "~2.1"
-# NOTE: Max version not 3.0 because tests pass
%global zendframework_filter_min_ver 2.1
-%global zendframework_filter_max_ver 4.0
+%global zendframework_filter_max_ver 3.0
# "zendframework/zend-i18n": "~2.1"
-# NOTE: Max version not 3.0 because tests pass
%global zendframework_i18n_min_ver 2.1
-%global zendframework_i18n_max_ver 4.0
+%global zendframework_i18n_max_ver 3.0
# "zendframework/zend-serializer": "~2.1"
-# NOTE: Max version not 3.0 because tests pass
%global zendframework_serializer_min_ver 2.1
-%global zendframework_serializer_max_ver 4.0
+%global zendframework_serializer_max_ver 3.0
# "zendframework/zend-servicemanager": "~2.1"
# NOTE: Max version not 3.0 because tests pass
%global zendframework_servicemanager_min_ver 2.1
@@ -100,11 +95,18 @@
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
+# Range dependencies supported?
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global with_range_dependencies 1
+%else
+%global with_range_dependencies 0
+%endif
+
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: phpdoc
Version: %{github_version}
-Release: 7%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Documentation generator for PHP
# License breakdown:
@@ -220,8 +222,6 @@ Source1: %{name}-get-source.sh
Patch0: %{name}-adjust-vendor-dir.patch
# Adjust templates dir
Patch1: %{name}-adjust-templates-dir.patch
-# Fix "PHP Warning: count(): Parameter must be an array or an object that implements Countable"
-Patch2: %{name}-php-warning-count-fix.patch
BuildArch: noarch
# Composer autoloader generation
@@ -232,7 +232,7 @@ BuildRequires: php-cli
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if %{with_range_dependencies}
BuildRequires: (php-composer(cilex/cilex) < %{cilex_max_ver} with php-composer(cilex/cilex) >= %{cilex_min_ver})
BuildRequires: (php-composer(erusev/parsedown) < %{erusev_parsedown_max_ver} with php-composer(erusev/parsedown) >= %{erusev_parsedown_min_ver})
BuildRequires: (php-composer(jms/serializer) < %{jms_serializer_max_ver} with php-composer(jms/serializer) >= %{jms_serializer_min_ver})
@@ -251,13 +251,13 @@ BuildRequires: (php-composer(symfony/process) < %{symfony_max_ver} with php-comp
BuildRequires: (php-composer(symfony/stopwatch) < %{symfony_max_ver} with php-composer(symfony/stopwatch) >= %{symfony_min_ver})
BuildRequires: (php-composer(symfony/validator) < %{symfony_max_ver} with php-composer(symfony/validator) >= %{symfony_min_ver})
BuildRequires: (php-composer(twig/twig) < %{twig_max_ver} with php-composer(twig/twig) >= %{twig_min_ver})
-BuildRequires: (php-composer(zendframework/zend-cache) < %{zendframework_cache_max_ver} with php-composer(zendframework/zend-cache) >= %{zendframework_cache_min_ver})
-BuildRequires: (php-composer(zendframework/zend-config) < %{zendframework_config_max_ver} with php-composer(zendframework/zend-config) >= %{zendframework_config_min_ver})
-BuildRequires: (php-composer(zendframework/zend-filter) < %{zendframework_filter_max_ver} with php-composer(zendframework/zend-filter) >= %{zendframework_filter_min_ver})
-BuildRequires: (php-composer(zendframework/zend-i18n) < %{zendframework_i18n_max_ver} with php-composer(zendframework/zend-i18n) >= %{zendframework_i18n_min_ver})
-BuildRequires: (php-composer(zendframework/zend-serializer) < %{zendframework_serializer_max_ver} with php-composer(zendframework/zend-serializer) >= %{zendframework_serializer_min_ver})
-BuildRequires: (php-composer(zendframework/zend-servicemanager) < %{zendframework_servicemanager_max_ver} with php-composer(zendframework/zend-servicemanager) >= %{zendframework_servicemanager_min_ver})
-BuildRequires: (php-composer(zendframework/zend-stdlib) < %{zendframework_stdlib_max_ver} with php-composer(zendframework/zend-stdlib) >= %{zendframework_stdlib_min_ver})
+BuildRequires: (php-autoloader(zendframework/zend-cache) < %{zendframework_cache_max_ver} with php-autoloader(zendframework/zend-cache) >= %{zendframework_cache_min_ver})
+BuildRequires: (php-autoloader(zendframework/zend-config) < %{zendframework_config_max_ver} with php-autoloader(zendframework/zend-config) >= %{zendframework_config_min_ver})
+BuildRequires: (php-autoloader(zendframework/zend-filter) < %{zendframework_filter_max_ver} with php-autoloader(zendframework/zend-filter) >= %{zendframework_filter_min_ver})
+BuildRequires: (php-autoloader(zendframework/zend-i18n) < %{zendframework_i18n_max_ver} with php-autoloader(zendframework/zend-i18n) >= %{zendframework_i18n_min_ver})
+BuildRequires: (php-autoloader(zendframework/zend-serializer) < %{zendframework_serializer_max_ver} with php-autoloader(zendframework/zend-serializer) >= %{zendframework_serializer_min_ver})
+BuildRequires: (php-autoloader(zendframework/zend-servicemanager) < %{zendframework_servicemanager_max_ver} with php-autoloader(zendframework/zend-servicemanager) >= %{zendframework_servicemanager_min_ver})
+BuildRequires: (php-autoloader(zendframework/zend-stdlib) < %{zendframework_stdlib_max_ver} with php-autoloader(zendframework/zend-stdlib) >= %{zendframework_stdlib_min_ver})
BuildRequires: (php-composer(zetacomponents/document) < %{zetacomponents_document_max_ver} with php-composer(zetacomponents/document) >= %{zetacomponents_document_min_ver})
%else
BuildRequires: php-composer(cilex/cilex) < %{cilex_max_ver}
@@ -305,9 +305,10 @@ BuildRequires: php-composer(zendframework/zend-stdlib) >= %{zendframework_stdlib
BuildRequires: php-composer(zetacomponents/document) < %{zetacomponents_document_max_ver}
BuildRequires: php-composer(zetacomponents/document) >= %{zetacomponents_document_min_ver}
%endif
-## phpcompatinfo (computed from version 2.9.0)
+## phpcompatinfo (computed from version 2.9.1)
BuildRequires: php-date
BuildRequires: php-dom
+BuildRequires: php-filter
BuildRequires: php-iconv
BuildRequires: php-igbinary
BuildRequires: php-json
@@ -325,7 +326,7 @@ BuildRequires: php-composer(fedora/autoloader)
Requires: php-cli
# composer.json
Requires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if %{with_range_dependencies}
Requires: (php-composer(cilex/cilex) < %{cilex_max_ver} with php-composer(cilex/cilex) >= %{cilex_min_ver})
Requires: (php-composer(erusev/parsedown) < %{erusev_parsedown_max_ver} with php-composer(erusev/parsedown) >= %{erusev_parsedown_min_ver})
Requires: (php-composer(jms/serializer) < %{jms_serializer_max_ver} with php-composer(jms/serializer) >= %{jms_serializer_min_ver})
@@ -341,13 +342,13 @@ Requires: (php-composer(symfony/process) < %{symfony_max_ver} with php-comp
Requires: (php-composer(symfony/stopwatch) < %{symfony_max_ver} with php-composer(symfony/stopwatch) >= %{symfony_min_ver})
Requires: (php-composer(symfony/validator) < %{symfony_max_ver} with php-composer(symfony/validator) >= %{symfony_min_ver})
Requires: (php-composer(twig/twig) < %{twig_max_ver} with php-composer(twig/twig) >= %{twig_min_ver})
-Requires: (php-composer(zendframework/zend-cache) < %{zendframework_cache_max_ver} with php-composer(zendframework/zend-cache) >= %{zendframework_cache_min_ver})
-Requires: (php-composer(zendframework/zend-config) < %{zendframework_config_max_ver} with php-composer(zendframework/zend-config) >= %{zendframework_config_min_ver})
-Requires: (php-composer(zendframework/zend-filter) < %{zendframework_filter_max_ver} with php-composer(zendframework/zend-filter) >= %{zendframework_filter_min_ver})
-Requires: (php-composer(zendframework/zend-i18n) < %{zendframework_i18n_max_ver} with php-composer(zendframework/zend-i18n) >= %{zendframework_i18n_min_ver})
-Requires: (php-composer(zendframework/zend-serializer) < %{zendframework_serializer_max_ver} with php-composer(zendframework/zend-serializer) >= %{zendframework_serializer_min_ver})
-Requires: (php-composer(zendframework/zend-servicemanager) < %{zendframework_servicemanager_max_ver} with php-composer(zendframework/zend-servicemanager) >= %{zendframework_servicemanager_min_ver})
-Requires: (php-composer(zendframework/zend-stdlib) < %{zendframework_stdlib_max_ver} with php-composer(zendframework/zend-stdlib) >= %{zendframework_stdlib_min_ver})
+Requires: (php-autoloader(zendframework/zend-cache) < %{zendframework_cache_max_ver} with php-autoloader(zendframework/zend-cache) >= %{zendframework_cache_min_ver})
+Requires: (php-autoloader(zendframework/zend-config) < %{zendframework_config_max_ver} with php-autoloader(zendframework/zend-config) >= %{zendframework_config_min_ver})
+Requires: (php-autoloader(zendframework/zend-filter) < %{zendframework_filter_max_ver} with php-autoloader(zendframework/zend-filter) >= %{zendframework_filter_min_ver})
+Requires: (php-autoloader(zendframework/zend-i18n) < %{zendframework_i18n_max_ver} with php-autoloader(zendframework/zend-i18n) >= %{zendframework_i18n_min_ver})
+Requires: (php-autoloader(zendframework/zend-serializer) < %{zendframework_serializer_max_ver} with php-autoloader(zendframework/zend-serializer) >= %{zendframework_serializer_min_ver})
+Requires: (php-autoloader(zendframework/zend-servicemanager) < %{zendframework_servicemanager_max_ver} with php-autoloader(zendframework/zend-servicemanager) >= %{zendframework_servicemanager_min_ver})
+Requires: (php-autoloader(zendframework/zend-stdlib) < %{zendframework_stdlib_max_ver} with php-autoloader(zendframework/zend-stdlib) >= %{zendframework_stdlib_min_ver})
Requires: (php-composer(zetacomponents/document) < %{zetacomponents_document_max_ver} with php-composer(zetacomponents/document) >= %{zetacomponents_document_min_ver})
%else
Requires: php-composer(cilex/cilex) < %{cilex_max_ver}
@@ -390,7 +391,7 @@ Requires: php-composer(zendframework/zend-stdlib) >= %{zendframework_stdlib
Requires: php-composer(zetacomponents/document) < %{zetacomponents_document_max_ver}
Requires: php-composer(zetacomponents/document) >= %{zetacomponents_document_min_ver}
%endif
-# phpcompatinfo (computed from version 2.9.0)
+# phpcompatinfo (computed from version 2.9.1)
Requires: php-date
Requires: php-dom
Requires: php-iconv
@@ -574,9 +575,6 @@ sed -i 's#__PHPDIR__#%{phpdir}#' \
: Adjust templates dir
%patch1 -p1
-: Fix "PHP Warning: count(): Parameter must be an array or an object that implements Countable"
-%patch2 -p1
-
: E: zero-length
find . -type f -size 0 -delete -print
@@ -752,7 +750,6 @@ exit $RETURN_CODE
%{phpdir}/phpDocumentor/Plugin
%{phpdir}/phpDocumentor/Transformer
%{phpdir}/phpDocumentor/Translator
-%exclude %{phpdir}/phpDocumentor/Plugin/Scrybe/tests
# Data
%{phpdir}/phpDocumentor/data
## Autoloaders
@@ -764,6 +761,10 @@ exit $RETURN_CODE
%changelog
+* Sat Aug 29 2020 Remi Collet <remi@remirepo.net> - 2.9.1
+- update to 2.9.1
+- fix zend-cache autoloader
+
* Sun Feb 24 2019 Shawn Iwinski <shawn@iwin.ski> - 2.9.0-7
- Use range dependencies
- Fix "PHP Warning: count(): Parameter must be an array or an object that