summaryrefslogtreecommitdiffstats
path: root/php-8.4.6-embed.patch
diff options
context:
space:
mode:
Diffstat (limited to 'php-8.4.6-embed.patch')
-rw-r--r--php-8.4.6-embed.patch17
1 files changed, 15 insertions, 2 deletions
diff --git a/php-8.4.6-embed.patch b/php-8.4.6-embed.patch
index 72b5e4c..b926b67 100644
--- a/php-8.4.6-embed.patch
+++ b/php-8.4.6-embed.patch
@@ -7,7 +7,7 @@ diff -up ./sapi/embed/config.m4.embed ./sapi/embed/config.m4
], [PHP_EMBED_TYPE=shared])
- INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(orig_libdir); \$(INSTALL) -m 0755 $SAPI_SHARED \$(INSTALL_ROOT)\$(orig_libdir)"
+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS -release \$(PHP_MAJOR_VERSION).\$(PHP_MINOR_VERSION)"
-+ INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(libdir); \$(LIBTOOL) --mode=install \$(INSTALL) -m 0755 \$(OVERALL_TARGET) \$(INSTALL_ROOT)\$(libdir)"
++ INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(orig_libdir); \$(LIBTOOL) --mode=install \$(INSTALL) -m 0755 \$(OVERALL_TARGET) \$(INSTALL_ROOT)\$(orig_libdir)"
],
[static], [
LIBPHP_CFLAGS="-static"
@@ -19,7 +19,20 @@ diff -up ./scripts/php-config.in.embed ./scripts/php-config.in
php_cgi_binary=NONE
configure_options="@CONFIGURE_OPTIONS@"
-php_sapis="@PHP_INSTALLED_SAPIS@"
-+php_sapis="apache2handler litespeed fpm phpdbg @PHP_INSTALLED_SAPIS@"
++php_sapis="apache2handler litespeed phpdbg @PHP_INSTALLED_SAPIS@"
ini_dir="@EXPANDED_PHP_CONFIG_FILE_SCAN_DIR@"
ini_path="@EXPANDED_PHP_CONFIG_FILE_PATH@"
php_embed_type="@PHP_EMBED_TYPE@"
+diff --git a/configure.ac b/configure.ac
+index 6dc1e45b34f..895c5153a2d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1306,7 +1306,7 @@ AS_VAR_IF([program_suffix], [NONE], [program_suffix=])
+
+ orig_libdir=$libdir
+ AS_CASE([$libdir],
+- ['${exec_prefix}/lib'], [libdir=$libdir/php])
++ [${prefix}/${PHP_LIBDIR}], [libdir=$libdir/php])
+
+ AS_CASE([$(eval echo $datadir)],
+ ['${prefix}/share'], [datadir=$datadir/php])