summaryrefslogtreecommitdiffstats
path: root/php83.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php83.spec')
-rw-r--r--php83.spec11
1 files changed, 6 insertions, 5 deletions
diff --git a/php83.spec b/php83.spec
index 71cbe2c..420f350 100644
--- a/php83.spec
+++ b/php83.spec
@@ -1399,6 +1399,7 @@ fi
# date, filter, libxml, reflection, spl: not supported
# hash: for PHAR_SIG_SHA256 and PHAR_SIG_SHA512
# session: dep on hash, used by soap
+# sockets: heavily used by FPM test suite
# pcre: used by filter, zip
# pcntl, readline: only used by CLI sapi
# openssl: for PHAR_SIG_OPENSSL
@@ -1440,6 +1441,7 @@ ln -sf ../configure
%if %{with debug}
--enable-debug \
%endif
+ --enable-sockets \
$*
if test $? != 0; then
tail -500 config.log
@@ -1488,7 +1490,6 @@ build --libdir=%{_libdir}/php \
--enable-ftp=shared \
--with-gettext=shared \
--with-iconv=shared \
- --enable-sockets=shared \
--enable-tokenizer=shared \
--with-ldap=shared --with-ldap-sasl \
--enable-mysqlnd=shared \
@@ -1548,7 +1549,7 @@ without_shared="--disable-gd \
--without-curl --disable-posix --disable-xml \
--disable-simplexml --disable-exif --without-gettext \
--without-iconv --disable-ftp --without-bz2 --disable-ctype \
- --disable-shmop --disable-sockets --disable-tokenizer \
+ --disable-shmop --disable-tokenizer \
--disable-sysvmsg --disable-sysvshm --disable-sysvsem"
# Build Apache module, and the CLI SAPI, /usr/bin/php
@@ -1625,7 +1626,6 @@ build --includedir=%{_includedir}/php-zts \
%endif
--with-gettext=shared \
--with-iconv=shared \
- --enable-sockets=shared \
--enable-tokenizer=shared \
--enable-exif=shared \
--enable-ftp=shared \
@@ -1857,7 +1857,7 @@ for mod in pgsql odbc ldap snmp \
mysqlnd mysqli \
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
- sockets tokenizer opcache \
+ tokenizer opcache \
pdo \
%if %{with zip}
zip \
@@ -1949,7 +1949,7 @@ cat files.sqlite3 >> files.pdo
# Package curl, phar and fileinfo in -common.
cat files.curl files.phar files.fileinfo \
files.exif files.gettext files.iconv files.calendar \
- files.ftp files.bz2 files.ctype files.sockets \
+ files.ftp files.bz2 files.ctype \
files.tokenizer > files.common
# The default Zend OPcache blacklist file
@@ -2216,6 +2216,7 @@ fi
- update to 8.3.0RC6
- use oracle client library version 21.12 on x86_64
- use ICU 73.2
+- build sockets extension statically
* Tue Oct 24 2023 Remi Collet <remi@remirepo.net> - 8.3.0~rc5-1
- update to 8.3.0RC5