summaryrefslogtreecommitdiffstats
path: root/php83.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php83.spec')
-rw-r--r--php83.spec97
1 files changed, 76 insertions, 21 deletions
diff --git a/php83.spec b/php83.spec
index aadf0e4..e91f73d 100644
--- a/php83.spec
+++ b/php83.spec
@@ -25,13 +25,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
%ifarch aarch64
-%global oraclever 19.22
+%global oraclever 19.24
+%global oraclemax 20
%global oraclelib 19.1
-%global oracledir 19.22
+%global oracledir 19.24
%else
-%global oraclever 21.13
-%global oraclelib 21.1
-%global oracledir 21
+%global oraclever 23.5
+%global oraclemax 24
+%global oraclelib 23.1
+%global oracledir 23
%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
@@ -92,6 +94,9 @@
%bcond_with tzdata
%endif
+# /usr/sbin/a# build with libiodbc instead of unixODBC
+%bcond_with iodbc
+
# /usr/sbin/apsx with httpd < 2.4 and defined as /usr/bin/apxs with httpd >= 2.4
%{!?_httpd_apxs: %{expand: %%global _httpd_apxs %%{_sbindir}/apxs}}
%{!?_httpd_mmn: %{expand: %%global _httpd_mmn %%(cat %{_includedir}/httpd/.mmn 2>/dev/null || echo 0-0)}}
@@ -120,14 +125,14 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.3.8
+%global upver 8.3.12
#global rcver RC1
# TODO set PHP_EXTRA_VERSION for EOL version
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -173,7 +178,7 @@ Patch10: php-8.2.0-curl.patch
# Use system nikic/php-parser
Patch41: php-8.3.3-parser.patch
# use system tzdata
-Patch42: php-8.3.0-systzdata-v24.patch
+Patch42: php-8.3.11-systzdata-v24.patch
# See http://bugs.php.net/53436
# + display PHP version backported from 8.4
Patch43: php-7.4.0-phpize.patch
@@ -187,12 +192,13 @@ Patch47: php-8.1.0-phpinfo.patch
# Always warn about missing curve_name
# Both Fedora and RHEL do not support arbitrary EC parameters
Patch48: php-8.3.0-openssl-ec-param.patch
+# Fix libidobc headers path
+Patch49: php-8.2.0-iodbc.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-gh14480.patch
# Security fixes (200+)
@@ -241,6 +247,9 @@ BuildRequires: libtool
BuildRequires: libtool-ltdl-devel
%if %{with dtrace}
BuildRequires: %{?dtsprefix}systemtap-sdt-devel
+%if 0%{?fedora} >= 41
+BuildRequires: %{?dtsprefix}systemtap-sdt-dtrace
+%endif
%endif
#BuildRequires: bison
#BuildRequires: re2c >= 1.0.3
@@ -698,8 +707,11 @@ License: PHP-3.01
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_odbc, php-pdo_odbc%{?_isa}
-# EL-7 version don't have pkgconfig
-BuildRequires: unixODBC-devel
+%if %{with iodbc}
+BuildRequires: pkgconfig(libiodbc)
+%else
+BuildRequires: pkgconfig(odbc)
+%endif
%if 0%{?rhel} == 7
Obsoletes: php53-odbc, php53u-odbc, php54-odbc, php54w-odbc, php55u-odbc, php55w-odbc, php56u-odbc, php56w-odbc
Obsoletes: php70u-odbc, php70w-odbc, php71u-odbc, php71w-odbc, php72u-odbc, php72w-odbc
@@ -716,6 +728,9 @@ data sources (which are often, but not always, databases). PHP is an
HTML-embeddable scripting language. If you need ODBC support for PHP
applications, you will need to install this package and the php
package.
+%if %{with iodbc}
+Package build using libiodbc (instead of unixODBC).
+%endif
%package soap
Summary: A module for PHP applications that use the SOAP protocol
@@ -768,7 +783,7 @@ BuildRequires: oracle-instantclient%{oraclever}-devel
Requires: libclntsh.so.%{oraclelib}
AutoReq: 0
%else
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
+BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
%endif
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
@@ -1049,9 +1064,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 73
-BuildRequires: pkgconfig(icu-io) >= 73
-BuildRequires: pkgconfig(icu-uc) >= 73
+BuildRequires: pkgconfig(icu-i18n) >= 74
+BuildRequires: pkgconfig(icu-io) >= 74
+BuildRequires: pkgconfig(icu-uc) >= 74
%if 0%{?rhel} == 7
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1209,11 +1224,11 @@ in pure PHP.
%patch -P46 -p1 -b .argon2
%patch -P47 -p1 -b .phpinfo
%patch -P48 -p1 -b .ec-param
+%patch -P49 -p1 -b .iodbc
%patch -P91 -p1 -b .remi-oci8
# upstream patches
-%patch -P100 -p1 -b .gh14480
# security patches
@@ -1462,7 +1477,7 @@ build --libdir=%{_libdir}/php \
--enable-opcache \
--enable-opcache-file \
--with-capstone \
- --enable-phpdbg \
+ --enable-phpdbg --enable-phpdbg-readline \
%if %{with imap}
--with-imap=shared --with-imap-ssl \
%endif
@@ -1486,7 +1501,7 @@ build --libdir=%{_libdir}/php \
--with-tcadb=%{_prefix} \
--with-lmdb=%{_prefix} \
%if %{with qdbm}
- --with-qdbm=%{_root_prefix} \
+ --with-qdbm=%{_prefix} \
%endif
--enable-exif=shared \
--enable-ftp=shared \
@@ -1514,7 +1529,13 @@ build --libdir=%{_libdir}/php \
--enable-xmlreader=shared --enable-xmlwriter=shared \
--with-curl=shared \
--enable-pdo=shared \
+%if %{with iodbc}
+ --with-iodbc=shared,%{_prefix} \
+ --with-pdo-odbc=shared,iodbc,%{_prefix} \
+%else
+ --with-unixODBC=shared,%{_prefix} \
--with-pdo-odbc=shared,unixODBC,%{_prefix} \
+%endif
--with-pdo-mysql=shared,mysqlnd \
--with-pdo-pgsql=shared,%{_prefix} \
--with-pdo-sqlite=shared \
@@ -1531,7 +1552,6 @@ build --libdir=%{_libdir}/php \
--enable-sysvmsg=shared --enable-sysvshm=shared --enable-sysvsem=shared \
--enable-shmop=shared \
--enable-posix=shared \
- --with-unixODBC=shared,%{_prefix} \
--enable-fileinfo=shared \
--with-ffi=shared \
--with-sodium=shared \
@@ -1624,7 +1644,7 @@ build --includedir=%{_includedir}/php-zts \
--with-tcadb=%{_prefix} \
--with-lmdb=%{_prefix} \
%if %{with qdbm}
- --with-qdbm=%{_root_prefix} \
+ --with-qdbm=%{_prefix} \
%endif
--with-gettext=shared \
--with-iconv=shared \
@@ -1653,7 +1673,13 @@ build --includedir=%{_includedir}/php-zts \
--enable-xmlreader=shared --enable-xmlwriter=shared \
--with-curl=shared \
--enable-pdo=shared \
+%if %{with iodbc}
+ --with-iodbc=shared,%{_prefix} \
+ --with-pdo-odbc=shared,iodbc,%{_prefix} \
+%else
+ --with-unixODBC=shared,%{_prefix} \
--with-pdo-odbc=shared,unixODBC,%{_prefix} \
+%endif
--with-pdo-mysql=shared,mysqlnd \
--with-pdo-pgsql=shared,%{_prefix} \
--with-pdo-sqlite=shared \
@@ -1670,7 +1696,6 @@ build --includedir=%{_includedir}/php-zts \
--enable-sysvmsg=shared --enable-sysvshm=shared --enable-sysvsem=shared \
--enable-shmop=shared \
--enable-posix=shared \
- --with-unixODBC=shared,%{_prefix} \
--enable-fileinfo=shared \
--with-ffi=shared \
--with-sodium=shared \
@@ -2214,6 +2239,36 @@ fi
%changelog
+* Wed Sep 25 2024 Remi Collet <remi@remirepo.net> - 8.3.12-1
+- Update to 8.3.12 - http://www.php.net/releases/8_3_12.php
+
+* Tue Sep 10 2024 Remi Collet <remi@remirepo.net> - 8.3.12~RC1-1
+- update to 8.3.12RC1
+- use ICU 74.2
+
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 8.3.11-1
+- Update to 8.3.11 - http://www.php.net/releases/8_3_11.php
+
+* Thu Aug 22 2024 Remi Collet <remi@remirepo.net> - 8.3.11~RC2-1
+- update to 8.3.11RC2
+
+* Wed Aug 14 2024 Remi Collet <remi@remirepo.net> - 8.3.11~RC1-2
+- allow to build using libiodbc instead of unixODBC (--with iodbc)
+
+* Wed Aug 14 2024 Remi Collet <remi@remirepo.net> - 8.3.11~RC1-1
+- update to 8.3.11RC1
+
+* Tue Jul 30 2024 Remi Collet <remi@remirepo.net> - 8.3.10-1
+- Update to 8.3.10 - http://www.php.net/releases/8_3_10.php
+- use oracle client library version 23.5 on x86_64
+
+* Tue Jul 16 2024 Remi Collet <remi@remirepo.net> - 8.3.10~RC1-1
+- update to 8.3.10RC1
+- use oracle client library version 23.4 on x86_64, 19.23 on aarch64
+
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 8.3.9-1
+- Update to 8.3.9 - http://www.php.net/releases/8_3_9.php
+
* Fri Jun 7 2024 Remi Collet <remi@remirepo.net> - 8.3.8-2
- Fix GH-14480 Method visibility issue introduced in version 8.3.8