summaryrefslogtreecommitdiffstats
path: root/php83.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-30 12:25:55 +0200
committerRemi Collet <remi@php.net>2023-08-30 12:25:55 +0200
commitd792d850dfb33c25e87dc02767ae34a07c7441d9 (patch)
treeaf551dc35e1b6decb9664e207483a41e99ca816e /php83.spec
parent627e1502d5206fc341ffb78824c46ac1dc6adb1e (diff)
update to 8.3.0RC1
bump to final API/ABI switch to nikic/php-parser version 5 openssl: always warn about missing curve_name
Diffstat (limited to 'php83.spec')
-rw-r--r--php83.spec41
1 files changed, 30 insertions, 11 deletions
diff --git a/php83.spec b/php83.spec
index 5ae8078..6f0f7c3 100644
--- a/php83.spec
+++ b/php83.spec
@@ -8,19 +8,19 @@
# Please preserve changelog entries
#
# API/ABI check
-%global apiver 20220829
-%global zendver 20220829
+%global apiver 20230831
+%global zendver 20230831
%global pdover 20170320
# Extension version
%global fileinfover 1.0.5
%global oci8ver 3.3.0
-%global zipver 1.21.1
+%global zipver 1.22.2
# Adds -z now to the linker flags
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 8.2
+%global embed_version 8.3
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
@@ -109,8 +109,9 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.2.10
-#global rcver RC1
+%global upver 8.3.0
+%global rcver RC1
+# TODO set PHP_EXTRA_VERSION for EOL version
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -159,7 +160,7 @@ Patch10: php-8.2.0-curl.patch
# Functional changes
# Use system nikic/php-parser
-Patch41: php-8.2.0-parser.patch
+Patch41: php-8.3.0-parser.patch
# use system tzdata
Patch42: php-8.1.0-systzdata-v23.patch
# See http://bugs.php.net/53436
@@ -171,6 +172,9 @@ Patch46: php-8.0.7-argon2.patch
# drop "Configure command" from phpinfo output
# and only use gcc (instead of full version)
Patch47: php-8.1.0-phpinfo.patch
+# Always warn about missing curve_name
+# Both Fedora and RHEL do not support arbitrary EC parameters
+Patch48: php-8.3.0-openssl-ec-param.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -184,6 +188,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.4.0-datetests.patch
# WIP
+Patch400: php-dtrace.patch
BuildRequires: gnupg2
BuildRequires: bzip2-devel
@@ -226,7 +231,7 @@ BuildRequires: libtool-ltdl-devel
BuildRequires: %{?dtsprefix}systemtap-sdt-devel
%endif
#BuildRequires: bison
-#BuildRequires: re2c
+#BuildRequires: re2c >= 1.0.3
# used for tests
BuildRequires: /bin/ps
%if %{with tzdata}
@@ -403,7 +408,7 @@ Provides: php-date, php-date%{?_isa}
Provides: bundled(timelib)
Provides: php-exif, php-exif%{?_isa}
Provides: php-fileinfo, php-fileinfo%{?_isa}
-Provides: bundled(libmagic) = 5.29
+Provides: bundled(libmagic) = 5.43
Provides: php-filter, php-filter%{?_isa}
Provides: php-ftp, php-ftp%{?_isa}
Provides: php-gettext, php-gettext%{?_isa}
@@ -500,6 +505,7 @@ need to install this package.
%package opcache
Summary: The Zend OPcache
License: PHP-3.01
+BuildRequires: pkgconfig(capstone) >= 3.0
Requires: php-common%{?_isa} = %{version}-%{release}
Obsoletes: php-pecl-zendopcache < 7.0.6
Provides: php-pecl-zendopcache = %{version}
@@ -1186,6 +1192,7 @@ in pure PHP.
%patch -P45 -p1 -b .ldap_r
%patch -P46 -p1 -b .argon2
%patch -P47 -p1 -b .phpinfo
+%patch -P48 -p1 -b .ec-param
%patch -P91 -p1 -b .remi-oci8
@@ -1199,6 +1206,7 @@ in pure PHP.
%endif
# WIP patch
+%patch -P400 -p1 -R -b .dtrace
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE ZEND_LICENSE
@@ -1206,7 +1214,7 @@ cp Zend/asm/LICENSE BOOST_LICENSE
cp TSRM/LICENSE TSRM_LICENSE
cp sapi/fpm/LICENSE fpm_LICENSE
cp ext/mbstring/libmbfl/LICENSE libmbfl_LICENSE
-cp ext/fileinfo/libmagic/LICENSE libmagic_LICENSE
+# cp ext/fileinfo/libmagic/LICENSE libmagic_LICENSE
cp ext/bcmath/libbcmath/LICENSE libbcmath_LICENSE
cp ext/date/lib/LICENSE.rst timelib_LICENSE
@@ -1240,6 +1248,9 @@ rm Zend/tests/bug68412.phpt
rm sapi/cli/tests/upload_2G.phpt
# tar issue
rm ext/zlib/tests/004-mb.phpt
+# Both Fedora and RHEL do not support arbitrary EC parameters
+# https://bugzilla.redhat.com/2223953
+rm ext/openssl/tests/ecc_custom_params.phpt
# avoid issue when 2 builds run simultaneously (keep 64321 for the SCL)
%ifarch x86_64
@@ -1432,6 +1443,7 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+ --with-capstone \
--enable-phpdbg \
%if %{with imap}
--with-imap=shared --with-imap-ssl \
@@ -1576,6 +1588,7 @@ build --includedir=%{_includedir}/php-zts \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+ --with-capstone \
%if %{with imap}
--with-imap=shared --with-imap-ssl \
%endif
@@ -2044,7 +2057,7 @@ fi
%files common -f files.common
%doc EXTENSIONS NEWS UPGRADING* README.REDIST.BINS *md docs
%license LICENSE TSRM_LICENSE ZEND_LICENSE BOOST_LICENSE
-%license libmagic_LICENSE
+#license libmagic_LICENSE
%license timelib_LICENSE
%doc php.ini-*
%config(noreplace) %{_sysconfdir}/php.ini
@@ -2195,6 +2208,12 @@ fi
%changelog
+* Tue Aug 29 2023 Remi Collet <remi@remirepo.net> - 8.3.0~rc1-1
+- update to 8.3.0RC1
+- bump to final API/ABI
+- switch to nikic/php-parser version 5
+- openssl: always warn about missing curve_name
+
* Tue Aug 29 2023 Remi Collet <remi@remirepo.net> - 8.2.10-1
- Update to 8.2.10 - http://www.php.net/releases/8_2_10.php