summaryrefslogtreecommitdiffstats
path: root/php82.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-02 10:37:14 +0200
committerRemi Collet <remi@php.net>2022-09-02 10:37:14 +0200
commitc275578ce46d661552e642c8f21dd68eabd427db (patch)
tree0bcd72776f7a8b86895d5f8a8194237b707a9d53 /php82.spec
parentb8a8e0dcae66482c106ba134f3f2a9fc2bc0b163 (diff)
update to 8.2.0RC1
bump API/ABI new random extension add dependency on libselinux
Diffstat (limited to 'php82.spec')
-rw-r--r--php82.spec33
1 files changed, 21 insertions, 12 deletions
diff --git a/php82.spec b/php82.spec
index e77ceaa..9cb36c2 100644
--- a/php82.spec
+++ b/php82.spec
@@ -8,19 +8,19 @@
# Please preserve changelog entries
#
# API/ABI check
-%global apiver 20210902
-%global zendver 20210902
+%global apiver 20220829
+%global zendver 20220829
%global pdover 20170320
# Extension version
%global fileinfover 1.0.5
-%global oci8ver 3.1.0
-%global zipver 1.19.5
+%global oci8ver 3.2.1
+%global zipver 1.21.0
# Adds -z now to the linker flags
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 8.1
+%global embed_version 8.2
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
@@ -107,9 +107,9 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.1.10
-#global rcver RC1
-#global lower RC1
+%global upver 8.2.0
+%global rcver RC1
+%global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -154,11 +154,11 @@ Patch5: php-7.2.0-includedir.patch
Patch6: php-8.0.0-embed.patch
Patch8: php-8.1.0-libdb.patch
# RHEL backports
-Patch10: php-7.0.7-curl.patch
+Patch10: php-8.2.0-curl.patch
# Functional changes
# Use system nikic/php-parser
-Patch41: php-8.1.0-parser.patch
+Patch41: php-8.2.0-parser.patch
# use system tzdata
Patch42: php-8.1.0-systzdata-v22.patch
# See http://bugs.php.net/53436
@@ -325,6 +325,7 @@ The php-dbg package contains the interactive PHP debugger.
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
BuildRequires: pkgconfig(libsystemd) >= 209
+BuildRequires: pkgconfig(libselinux)
Requires: php-common%{?_isa} = %{version}-%{release}
%{?systemd_requires}
# This is actually needed for the %%triggerun script but Requires(triggerun)
@@ -412,6 +413,7 @@ Provides: php-libxml, php-libxml%{?_isa}
Provides: php-openssl, php-openssl%{?_isa}
Provides: php-phar, php-phar%{?_isa}
Provides: php-pcre, php-pcre%{?_isa}
+Provides: php-random, php-random%{?_isa}
Provides: php-reflection, php-reflection%{?_isa}
Provides: php-session, php-session%{?_isa}
Provides: php-sockets, php-sockets%{?_isa}
@@ -483,7 +485,7 @@ Obsoletes: php74-devel, php74w-devel
Obsoletes: php80-devel
%endif
%if 0%{?fedora} || 0%{?rhel} >= 8
-Recommends: php-nikic-php-parser4 >= 4.13.0
+Recommends: php-nikic-php-parser4 >= 4.13.1
%endif
%description devel
@@ -1167,7 +1169,7 @@ in pure PHP.
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
%patch8 -p1 -b .libdb
-%if 0%{?rhel}
+%if 0%{?rhel} == 7
%patch10 -p1 -b .curltls
%endif
@@ -1536,6 +1538,7 @@ popd
pushd build-fpm
build --enable-fpm \
--with-fpm-systemd \
+ --with-fpm-selinux \
--with-fpm-acl \
--libdir=%{_libdir}/php \
--without-mysqli \
@@ -2177,6 +2180,12 @@ fi
%changelog
+* Fri Sep 2 2022 Remi Collet <remi@remirepo.net> - 8.2.0~RC1-1
+- update to 8.2.0RC1
+- bump API/ABI
+- new random extension
+- add dependency on libselinux
+
* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 8.1.10-1
- Update to 8.1.10 - http://www.php.net/releases/8_1_10.php