summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-10 08:20:58 +0200
committerRemi Collet <remi@php.net>2023-05-10 08:20:58 +0200
commitc65d89724ff80225aea719622491dd133f8c64b0 (patch)
tree50b36df271de5bef898f22d2b019f8ef768703fe
parent208686c52f4a72010388d90d4e031a1a5bacc6e4 (diff)
Update to 8.2.6 - http://www.php.net/releases/8_2_6.phpv8.2.6
-rw-r--r--failed.txt2
-rw-r--r--macros.php5
-rw-r--r--php82.spec100
3 files changed, 59 insertions, 48 deletions
diff --git a/failed.txt b/failed.txt
index 940738d..f5295a9 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 8.2.6RC1 (2023-04-27)
+===== 8.2.6 (2023-05-11)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
diff --git a/macros.php b/macros.php
index 0c750a7..989e8b3 100644
--- a/macros.php
+++ b/macros.php
@@ -18,4 +18,9 @@
%__php %{_bindir}/php
%__ztsphp %{_bindir}/zts-php
+%__phpize %{_bindir}/phpize
+%__ztsphpize %{_bindir}/zts-phpize
+
+%__phpconfig %{_bindir}/php-config
+%__ztsphpconfig %{_bindir}/zts-php-config
diff --git a/php82.spec b/php82.spec
index 4cada5c..f83b9be 100644
--- a/php82.spec
+++ b/php82.spec
@@ -110,7 +110,7 @@
%bcond_with zip
%global upver 8.2.6
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -123,7 +123,7 @@ Release: 1%{?dist}
# ext/date/lib is MIT
# Zend/zend_sort is NCSA
# Zend/asm is Boost
-License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and Boost
+License: PHP-3.01 AND Zend-2.0 AND BSD-2-Clause AND MIT AND Apache-1.0 AND NCSA AND BSL-1.0
URL: http://www.php.net/
Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
@@ -289,7 +289,7 @@ which adds support for the PHP language to Apache HTTP Server.
%package cli
Summary: Command-line interface for PHP
# sapi/cli/ps_title.c is PostgreSQL
-License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and PostgreSQL
+License: PHP-3.01 AND Zend-2.0 AND BSD-2-Clause AND MIT AND Apache-1.0 AND NCSA AND PostgreSQL
Requires: php-common%{?_isa} = %{version}-%{release}
Provides: php-cgi = %{version}-%{release}, php-cgi%{?_isa} = %{version}-%{release}
Provides: php-pcntl, php-pcntl%{?_isa}
@@ -382,7 +382,7 @@ Summary: Common files for PHP
# All files licensed under PHP version 3.01, except
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
-License: PHP and BSD
+License: PHP-3.01 AND BSD-2-Clause
%if %{with libpcre}
%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
@@ -499,7 +499,7 @@ need to install this package.
%package opcache
Summary: The Zend OPcache
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
Obsoletes: php-pecl-zendopcache < 7.0.6
Provides: php-pecl-zendopcache = %{version}
@@ -525,7 +525,7 @@ bytecode optimization patterns that make code execution faster.
%package imap
Summary: A module for PHP applications that use IMAP
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(krb5)
BuildRequires: pkgconfig(krb5-gssapi)
@@ -548,7 +548,7 @@ messages on mail servers. PHP is an HTML-embedded scripting language.
%package ldap
Summary: A module for PHP applications that use LDAP
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(libsasl2)
BuildRequires: openldap-devel
@@ -570,7 +570,7 @@ language.
%package pdo
Summary: A database access abstraction module for PHP applications
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
# ABI/API check - Arch specific
Provides: php-pdo-abi = %{pdover}-%{__isa_bits}
@@ -594,7 +594,7 @@ databases.
%package mysqlnd
Summary: A module for PHP applications that use MySQL databases
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-mysqli = %{version}-%{release}
@@ -623,7 +623,7 @@ This package use the MySQL Native Driver
%package pgsql
Summary: A PostgreSQL database module for PHP
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_pgsql, php-pdo_pgsql%{?_isa}
@@ -649,7 +649,7 @@ php package.
%package process
Summary: Modules for PHP script using system process interfaces
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
Provides: php-posix, php-posix%{?_isa}
Provides: php-shmop, php-shmop%{?_isa}
@@ -673,7 +673,7 @@ communication.
Summary: A module for PHP applications that use ODBC databases
# All files licensed under PHP version 3.01, except
# pdo_odbc is licensed under PHP version 3.0
-License: PHP
+License: PHP-3.01
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_odbc, php-pdo_odbc%{?_isa}
@@ -699,7 +699,7 @@ package.
%package soap
Summary: A module for PHP applications that use the SOAP protocol
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(libxml-2.0)
%if 0%{?rhel} == 7
@@ -718,7 +718,7 @@ support to PHP for using the SOAP web services protocol.
%package pdo-firebird
Summary: PDO driver for Interbase/Firebird databases
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
BuildRequires: firebird-devel
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
@@ -740,7 +740,7 @@ Interbase/Firebird databases.
%package oci8
Summary: A module for PHP applications that use OCI8 databases
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
BuildRequires: oracle-instantclient-devel >= %{oraclever}
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
@@ -782,7 +782,7 @@ Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
%package snmp
Summary: A module for PHP applications that query SNMP-managed devices
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}, net-snmp
BuildRequires: net-snmp-devel
%if 0%{?rhel} == 7
@@ -802,7 +802,7 @@ will need to install this package and the php package.
%package xml
Summary: A module for PHP applications which use XML
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
Provides: php-dom, php-dom%{?_isa}
Provides: php-domxml, php-domxml%{?_isa}
@@ -832,7 +832,7 @@ Summary: A module for PHP applications which need multi-byte string handling
# libmbfl is licensed under LGPLv2
# onigurama is licensed under BSD
# ucgendat is licensed under OpenLDAP
-License: PHP and LGPLv2 and BSD and OpenLDAP
+License: PHP-3.01 AND LGPL-2.1-only AND OLDAP-2.8
%if 0%{?rhel}
BuildRequires: oniguruma5php-devel
%else
@@ -856,10 +856,10 @@ support for multi-byte string handling to PHP.
Summary: A module for PHP applications for using the gd graphics library
# All files licensed under PHP version 3.01
%if %{with libgd}
-License: PHP
+License: PHP-3.01
%else
-# bundled libgd is licensed under BSD
-License: PHP and BSD
+# bundled libgd is licensed under MIT
+License: PHP-3.01 and MIT
%endif
Requires: php-common%{?_isa} = %{version}-%{release}
%if %{with libgd}
@@ -891,7 +891,7 @@ support for using the gd graphics library to PHP.
Summary: A module for PHP applications for using the bcmath library
# All files licensed under PHP version 3.01, except
# libbcmath is licensed under LGPLv2+
-License: PHP and LGPLv2+
+License: PHP-3.01 AND LGPL-2.1-or-later
Requires: php-common%{?_isa} = %{version}-%{release}
%if 0%{?rhel} == 7
Obsoletes: php53-bcmath, php53u-bcmath, php54-bcmath, php54w-bcmath, php55u-bcmath, php55w-bcmath, php56u-bcmath, php56w-bcmath
@@ -909,7 +909,7 @@ support for using the bcmath library to PHP.
%package gmp
Summary: A module for PHP applications for using the GNU MP library
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
BuildRequires: gmp-devel
Requires: php-common%{?_isa} = %{version}-%{release}
%if 0%{?rhel} == 7
@@ -927,7 +927,7 @@ using the GNU MP library.
%package dba
Summary: A database abstraction layer module for PHP applications
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
BuildRequires: libdb-devel
BuildRequires: tokyocabinet-devel
BuildRequires: lmdb-devel
@@ -950,7 +950,7 @@ support for using the DBA database abstraction layer to PHP.
%package tidy
Summary: Standard PHP module provides tidy library support
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: libtidy-devel
%if 0%{?rhel} == 7
@@ -968,7 +968,7 @@ support for using the tidy library to PHP.
%package pdo-dblib
Summary: PDO driver for Microsoft SQL Server and Sybase databases
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-pdo%{?_isa} = %{version}-%{release}
BuildRequires: freetds-devel >= 0.91
Provides: php-pdo_dblib, php-pdo_dblib%{?_isa}
@@ -1007,7 +1007,7 @@ into applications to provide PHP scripting language support.
%package pspell
Summary: A module for PHP applications for using pspell interfaces
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: aspell-devel >= 0.50.0
%if 0%{?rhel} == 7
@@ -1025,7 +1025,7 @@ support for using the pspell library to PHP.
%package intl
Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(icu-i18n) >= 72
BuildRequires: pkgconfig(icu-io) >= 72
@@ -1045,7 +1045,7 @@ support for using the ICU library to PHP.
%package enchant
Summary: Enchant spelling extension for PHP applications
# All files licensed under PHP version 3.0
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(enchant-2)
%if 0%{?rhel} == 7
@@ -1064,7 +1064,7 @@ support for using the enchant library to PHP.
%package zip
Summary: ZIP archive management extension for PHP
# All files licensed under PHP version 3.0.1
-License: PHP
+License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
Obsoletes: php-pecl-zip < %{zipver}
Provides: php-pecl(zip) = %{zipver}
@@ -1088,7 +1088,7 @@ support for ZIP archive management to PHP.
%package sodium
Summary: Wrapper for the Sodium cryptographic library
# All files licensed under PHP version 3.0.1
-License: PHP
+License: PHP-3.01
# Minimal is 1.0.8, 1.0.14 is needed for argon2 password
BuildRequires: pkgconfig(libsodium) >= 1.0.14
@@ -1111,7 +1111,7 @@ low-level PHP extension for the libsodium cryptographic library.
%package ffi
Summary: Foreign Function Interface
# All files licensed under PHP version 3.0.1
-License: PHP
+License: PHP-3.01
BuildRequires: pkgconfig(libffi)
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -1170,24 +1170,24 @@ in pure PHP.
%setup -q -n php-%{upver}%{?rcver}
-%patch1 -p1 -b .mpmcheck
-%patch5 -p1 -b .includedir
-%patch6 -p1 -b .embed
-%patch8 -p1 -b .libdb
-%if 0%{?rhel}
-%patch10 -p1 -b .curltls
+%patch -P1 -p1 -b .mpmcheck
+%patch -P5 -p1 -b .includedir
+%patch -P6 -p1 -b .embed
+%patch -P8 -p1 -b .libdb
+%if 0%{?rhel} == 7
+%patch -P10 -p1 -b .curltls
%endif
-%patch41 -p1 -b .syslib
+%patch -P41 -p1 -b .syslib
%if %{with tzdata}
-%patch42 -p1 -b .systzdata
+%patch -P42 -p1 -b .systzdata
%endif
-%patch43 -p1 -b .headers
-%patch45 -p1 -b .ldap_r
-%patch46 -p1 -b .argon2
-%patch47 -p1 -b .phpinfo
+%patch -P43 -p1 -b .headers
+%patch -P45 -p1 -b .ldap_r
+%patch -P46 -p1 -b .argon2
+%patch -P47 -p1 -b .phpinfo
-%patch91 -p1 -b .remi-oci8
+%patch -P91 -p1 -b .remi-oci8
# upstream patches
@@ -1195,7 +1195,7 @@ in pure PHP.
# Fixes for tests related to tzdata
%if %{with tzdata}
-%patch300 -p1 -b .datetests
+%patch -P300 -p1 -b .datetests
%endif
# WIP patch
@@ -1953,7 +1953,7 @@ sed -e "s/@PHP_APIVER@/%{apiver}-%{__isa_bits}/" \
%endif
< %{SOURCE3} > macros.php
%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
-echo '%%pecl_xmldir %{_localstatedir}/lib/php/peclxml' >>macros.php
+echo '%%pecl_xmldir %%{_localstatedir}/lib/php/peclxml' >>macros.php
%endif
install -m 644 -D macros.php \
$RPM_BUILD_ROOT%{macrosdir}/macros.php
@@ -2195,6 +2195,12 @@ fi
%changelog
+* Wed May 10 2023 Remi Collet <remi@remirepo.net> - 8.2.6-1
+- Update to 8.2.6 - http://www.php.net/releases/8_2_6.php
+
+* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.2.6~RC1-2
+- define %%__phpize and %%__phpconfig
+
* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.2.6~RC1-1
- update to 8.2.6RC1
- use oracle client library version 21.10