summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-10 11:11:25 +0100
committerRemi Collet <remi@php.net>2023-02-10 11:11:25 +0100
commit5c35af7e7aa9b892264c2d43ae8333046d770c24 (patch)
tree62f28ea6b6bdbb39a380f5abe1999e18e4138d6e
parent5fafa29b593f4dcc46a1a41c1755eaf64efb7db7 (diff)
F38: disable imap extension
-rw-r--r--php82.spec25
1 files changed, 23 insertions, 2 deletions
diff --git a/php82.spec b/php82.spec
index f57c5f9..914c2f0 100644
--- a/php82.spec
+++ b/php82.spec
@@ -40,6 +40,13 @@
# Optional Oracle extensions; pass "--with oci8" etc to rpmbuild.
%bcond_with oci8
+%if 0%{?fedora} >= 38
+# uw-imap is not available
+%bcond_with imap
+%else
+%bcond_without imap
+%endif
+
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# switch to bundled library using --without libpcre
%bcond_without libpcre
@@ -113,7 +120,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -519,6 +526,7 @@ bytecode in the shared memory. This eliminates the stages of reading code from
the disk and compiling it on future access. In addition, it applies a few
bytecode optimization patterns that make code execution faster.
+%if %{with imap}
%package imap
Summary: A module for PHP applications that use IMAP
# All files licensed under PHP version 3.01
@@ -540,6 +548,7 @@ Obsoletes: php80-imap
The php-imap module will add IMAP (Internet Message Access Protocol)
support to PHP. IMAP is a protocol for retrieving and uploading e-mail
messages on mail servers. PHP is an HTML-embedded scripting language.
+%endif
%package ldap
Summary: A module for PHP applications that use LDAP
@@ -1429,7 +1438,9 @@ build --libdir=%{_libdir}/php \
--enable-opcache \
--enable-opcache-file \
--enable-phpdbg \
+%if %{with imap}
--with-imap=shared --with-imap-ssl \
+%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1570,7 +1581,9 @@ build --includedir=%{_includedir}/php-zts \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+%if %{with imap}
--with-imap=shared --with-imap-ssl \
+%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1825,7 +1838,10 @@ done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
# Generate files lists and stub .ini files for each subpackage
-for mod in pgsql odbc ldap snmp imap \
+for mod in pgsql odbc ldap snmp \
+%if %{with imap}
+ imap \
+%endif
mysqlnd mysqli \
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
@@ -2142,7 +2158,9 @@ fi
%files pgsql -f files.pgsql
%files odbc -f files.odbc
+%if %{with imap}
%files imap -f files.imap
+%endif
%files ldap -f files.ldap
%files snmp -f files.snmp
%files xml -f files.xml
@@ -2182,6 +2200,9 @@ fi
%changelog
+* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 8.2.2-2
+- F38: disable imap extension
+
* Wed Feb 1 2023 Remi Collet <remi@remirepo.net> - 8.2.2-1
- Update to 8.2.2 - http://www.php.net/releases/8_2_2.php
- add dependency on pcre2 minimal version