summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-25 08:39:15 +0100
committerRemi Collet <remi@php.net>2022-11-25 08:39:15 +0100
commit04288e1b3e906cf487eb538087476013615bfc2b (patch)
treeade37d64667e90deeeb93a7973ed61c32a69d42d
parent8e0a03bfa2f745cb0bdb20829256d6ea70f40eca (diff)
test build for GH-9997 with new upstream patch
-rw-r--r--php82.spec7
-rw-r--r--upstream.patch31
2 files changed, 37 insertions, 1 deletions
diff --git a/php82.spec b/php82.spec
index b780ba6..9d8595d 100644
--- a/php82.spec
+++ b/php82.spec
@@ -113,7 +113,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 8%{?dist}
+Release: 9%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -174,6 +174,7 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: upstream.patch
# Security fixes (200+)
@@ -1180,6 +1181,7 @@ in pure PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1
# security patches
@@ -2176,6 +2178,9 @@ fi
%changelog
+* Fri Nov 25 2022 Remi Collet <remi@remirepo.net> - 8.2.0~RC7-9
+- test build for GH-9997 with new upstream patch
+
* Wed Nov 23 2022 Remi Collet <remi@remirepo.net> - 8.2.0~RC7-8
- update to 8.2.0RC7
diff --git a/upstream.patch b/upstream.patch
new file mode 100644
index 0000000..be72054
--- /dev/null
+++ b/upstream.patch
@@ -0,0 +1,31 @@
+From 3d90a24e9349ea17e5467de7b1d7bfa17ec2c650 Mon Sep 17 00:00:00 2001
+From: Jakub Zelenka <bukka@php.net>
+Date: Thu, 24 Nov 2022 18:29:44 +0000
+Subject: [PATCH] Fix GH-9997: OpenSSL engine clean up segfault
+
+---
+ NEWS | 3 +++
+ ext/openssl/openssl.c | 5 +++--
+ 2 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
+index cb5e6260b4ab..da555c843c15 100644
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -1324,13 +1324,14 @@ PHP_MSHUTDOWN_FUNCTION(openssl)
+ #if OPENSSL_VERSION_NUMBER < 0x10100000L || defined (LIBRESSL_VERSION_NUMBER)
+ EVP_cleanup();
+
++ /* prevent accessing locking callback from unloaded extension */
++ CRYPTO_set_locking_callback(NULL);
++
+ #ifndef OPENSSL_NO_ENGINE
+ /* Free engine list initialized by OPENSSL_config */
+ ENGINE_cleanup();
+ #endif
+
+- /* prevent accessing locking callback from unloaded extension */
+- CRYPTO_set_locking_callback(NULL);
+ /* free allocated error strings */
+ ERR_free_strings();
+ CONF_modules_free();