summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt2
-rw-r--r--php-mbstring.patch33
-rw-r--r--php81.spec19
3 files changed, 16 insertions, 38 deletions
diff --git a/failed.txt b/failed.txt
index a6ac64d..77ea564 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 8.1.7 (2022-06-09)
+===== 8.1.9 (2022-08-04)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
diff --git a/php-mbstring.patch b/php-mbstring.patch
deleted file mode 100644
index 7da512b..0000000
--- a/php-mbstring.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 2eb2f9d74f22bf35a4915ec95afc53a47ebf1af9 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 2 Jun 2022 08:05:22 +0200
-Subject: [PATCH] Fix GH-8685 mbstring requires pcre
-
----
- ext/mbstring/mbstring.c | 11 ++++++++++-
- 1 file changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/ext/mbstring/mbstring.c b/ext/mbstring/mbstring.c
-index 48f22a682a19..4a4088aed3fb 100644
---- a/ext/mbstring/mbstring.c
-+++ b/ext/mbstring/mbstring.c
-@@ -161,9 +161,18 @@ static const php_mb_nls_ident_list php_mb_default_identify_list[] = {
-
- /* }}} */
-
-+/* {{{ mbstring_deps[] */
-+static const zend_module_dep mbstring_deps[] = {
-+ ZEND_MOD_REQUIRED("pcre")
-+ ZEND_MOD_END
-+};
-+/* }}} */
-+
- /* {{{ zend_module_entry mbstring_module_entry */
- zend_module_entry mbstring_module_entry = {
-- STANDARD_MODULE_HEADER,
-+ STANDARD_MODULE_HEADER_EX,
-+ NULL,
-+ mbstring_deps,
- "mbstring",
- ext_functions,
- PHP_MINIT(mbstring),
diff --git a/php81.spec b/php81.spec
index c4492b2..b7a89a9 100644
--- a/php81.spec
+++ b/php81.spec
@@ -107,7 +107,7 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.1.7
+%global upver 8.1.9
#global rcver RC1
#global lower RC1
@@ -175,7 +175,6 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-mbstring.patch
# Security fixes (200+)
@@ -327,7 +326,6 @@ Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
BuildRequires: pkgconfig(libsystemd) >= 209
Requires: php-common%{?_isa} = %{version}-%{release}
-Requires(pre): /usr/sbin/useradd
%{?systemd_requires}
# This is actually needed for the %%triggerun script but Requires(triggerun)
# is not valid. We can use %%post because this particular %%triggerun script
@@ -341,6 +339,8 @@ Requires(pre): httpd-filesystem
Requires: httpd-filesystem >= 2.4.10
# php engine for Apache httpd webserver
Provides: php(httpd)
+%else
+Requires(pre): /usr/sbin/useradd
%endif
%if %{with_nginx}
# for /etc/nginx ownership
@@ -1183,7 +1183,6 @@ in pure PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .up
# security patches
@@ -2174,6 +2173,18 @@ fi
%changelog
+* Tue Aug 2 2022 Remi Collet <remi@remirepo.net> - 8.1.9-1
+- Update to 8.1.9 - http://www.php.net/releases/8_1_9.php
+
+* Wed Jul 20 2022 Remi Collet <remi@remirepo.net> - 8.1.9~RC1-1
+- update to 8.1.9RC1
+
+* Wed Jul 6 2022 Remi Collet <remi@remirepo.net> - 8.1.8-1
+- Update to 8.1.8 - http://www.php.net/releases/8_1_8.php
+
+* Tue Jun 21 2022 Remi Collet <remi@remirepo.net> - 8.1.8~RC1-1
+- update to 8.1.8RC1
+
* Wed Jun 8 2022 Remi Collet <remi@remirepo.net> - 8.1.7-1
- Update to 8.1.7 - http://www.php.net/releases/8_1_7.php