summaryrefslogtreecommitdiffstats
path: root/php81.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-02 09:35:47 +0200
committerRemi Collet <remi@remirepo.net>2021-09-02 09:35:47 +0200
commit329a894341b196feda4dce9db40401614faf7947 (patch)
tree3dbd9b61e7215332df55c4b38d15ccae4ad6e02e /php81.spec
parentf847f63e240f9b94ffae9895b21f6da3804afd82 (diff)
update to 8.1.0RC1
bump API version
Diffstat (limited to 'php81.spec')
-rw-r--r--php81.spec75
1 files changed, 39 insertions, 36 deletions
diff --git a/php81.spec b/php81.spec
index 76a487f..188ace0 100644
--- a/php81.spec
+++ b/php81.spec
@@ -8,19 +8,19 @@
# Please preserve changelog entries
#
# API/ABI check
-%global apiver 20200930
-%global zendver 20200930
+%global apiver 20210902
+%global zendver 20210902
%global pdover 20170320
# Extension version
%global fileinfover 1.0.5
-%global oci8ver 3.0.1
+%global oci8ver 3.1.0
%global zipver 1.19.3
# Adds -z now to the linker flags
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 8.0
+%global embed_version 8.1
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
@@ -57,6 +57,13 @@
# Debug build, using --with debug
%bcond_with debug
+# build with system tzdata (2021 required)
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 7
+%bcond_without tzdata
+%else
+%bcond_with tzdata
+%endif
+
# /usr/sbin/apsx with httpd < 2.4 and defined as /usr/bin/apxs with httpd >= 2.4
%{!?_httpd_apxs: %{expand: %%global _httpd_apxs %%{_sbindir}/apxs}}
%{!?_httpd_mmn: %{expand: %%global _httpd_mmn %%(cat %{_includedir}/httpd/.mmn 2>/dev/null || echo 0-0)}}
@@ -85,21 +92,22 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.0.10
-#global rcver RC1
-#global lower RC1
+%global upver 8.1.0
+%global rcver RC1
+%global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
# main/snprintf.c, main/spprintf.c and main/rfc1867.c are ASL 1.0
# ext/date/lib is MIT
# Zend/zend_sort is NCSA
-License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA
+# Zend/asm is Boost
+License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and Boost
URL: http://www.php.net/
Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
@@ -129,9 +137,7 @@ Source53: 20-ffi.ini
Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
Patch6: php-8.0.0-embed.patch
-Patch8: php-7.4.0-libdb.patch
-# get rid of deprecated functions from 8.1
-Patch9: php-8.0.6-deprecated.patch
+Patch8: php-8.1.0-libdb.patch
# RHEL backports
Patch10: php-7.0.7-curl.patch
@@ -139,7 +145,7 @@ Patch10: php-7.0.7-curl.patch
# Use system nikic/php-parser
Patch41: php-8.0.0-parser.patch
# use system tzdata
-Patch42: php-8.0.10-systzdata-v20.patch
+Patch42: php-8.1.0-systzdata-v21.patch
# See http://bugs.php.net/53436
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -148,12 +154,7 @@ Patch45: php-7.4.0-ldap_r.patch
Patch46: php-8.0.7-argon2.patch
# drop "Configure command" from phpinfo output
# and only use gcc (instead of full version)
-Patch47: php-8.0.0-phpinfo.patch
-# add sha256 / sha512 security protocol, from 8.1
-Patch48: php-8.0.10-snmp-sha.patch
-# switch phar to use sha256 signature by default, from 8.1
-# implement openssl_256 and openssl_512 for phar signatures, from 8.1
-Patch49: php-8.0.10-phar-sha.patch
+Patch47: php-8.1.0-phpinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -183,7 +184,7 @@ BuildRequires: nginx-filesystem
%endif
BuildRequires: %{?dtsprefix}libstdc++-devel
# no pkgconfig to avoid compat-openssl10
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
BuildRequires: pkgconfig(sqlite3) >= 3.7.4
BuildRequires: pkgconfig(zlib) >= 1.2.0.4
BuildRequires: smtpdaemon
@@ -209,6 +210,9 @@ BuildRequires: %{?dtsprefix}systemtap-sdt-devel
#BuildRequires: re2c
# used for tests
BuildRequires: /bin/ps
+%if %{with tzdata}
+BuildRequires: tzdata
+%endif
%if 0%{?rhel}
Obsoletes: php53, php53u, php54w, php55u, php55w, php56u, php56w, mod_php70u, php70w, mod_php71u, mod_php71w, mod_php72u, mod_php72w
@@ -439,7 +443,7 @@ Requires: libtool
# see "php-config --libs"
Requires: krb5-devel%{?_isa}
Requires: libxml2-devel%{?_isa}
-Requires: openssl-devel%{?_isa} >= 1.0.1
+Requires: openssl-devel%{?_isa} >= 1.0.2
%if %{with libpcre}
Requires: pcre2-devel%{?_isa}
%endif
@@ -500,7 +504,7 @@ Requires: php-common%{?_isa} = %{version}-%{release}
Obsoletes: mod_php3-imap, stronghold-php-imap
BuildRequires: pkgconfig(krb5)
BuildRequires: pkgconfig(krb5-gssapi)
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
BuildRequires: libc-client-devel
%if 0%{?rhel}
Obsoletes: php53-imap, php53u-imap, php54-imap, php54w-imap, php55u-imap, php55w-imap, php56u-imap, php56w-imap
@@ -522,7 +526,7 @@ License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(libsasl2)
BuildRequires: openldap-devel
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
%if 0%{?rhel}
Obsoletes: php53-ldap, php53u-ldap, php54-ldap, php54w-ldap, php55u-ldap, php55w-ldap, php56u-ldap, php56w-ldap
Obsoletes: php70u-ldap, php70w-ldap, php71u-ldap, php71w-ldap, php72u-ldap, php72w-ldap
@@ -598,7 +602,7 @@ Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_pgsql, php-pdo_pgsql%{?_isa}
BuildRequires: krb5-devel
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
BuildRequires: postgresql-devel
%if 0%{?rhel}
Obsoletes: php53-pgsql, php53u-pgsql, php54-pgsql, php54w-pgsql, php55u-pgsql, php55w-pgsql, php56u-pgsql, php56w-pgsql
@@ -847,6 +851,7 @@ BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(freetype2)
BuildRequires: pkgconfig(xpm)
BuildRequires: pkgconfig(libwebp)
+BuildRequires: pkgconfig(libavif)
Provides: bundled(gd) = 2.0.35
%endif
%if 0%{?rhel}
@@ -1146,21 +1151,18 @@ in pure PHP.
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
%patch8 -p1 -b .libdb
-%patch9 -p1 -b .deprecated
%if 0%{?rhel}
%patch10 -p1 -b .curltls
%endif
%patch41 -p1 -b .syslib
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 6
+%if %{with tzdata}
%patch42 -p1 -b .systzdata
%endif
%patch43 -p1 -b .headers
%patch45 -p1 -b .ldap_r
%patch46 -p1 -b .argon2
%patch47 -p1 -b .phpinfo
-%patch48 -p1 -b .sha
-%patch49 -p1 -b .pharsha
%patch91 -p1 -b .remi-oci8
@@ -1169,7 +1171,7 @@ in pure PHP.
# security patches
# Fixes for tests related to tzdata
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 6
+%if %{with tzdata}
%patch300 -p1 -b .datetests
%endif
@@ -1177,6 +1179,7 @@ in pure PHP.
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE ZEND_LICENSE
+cp Zend/asm/LICENSE BOOST_LICENSE
cp TSRM/LICENSE TSRM_LICENSE
cp sapi/fpm/LICENSE fpm_LICENSE
cp ext/mbstring/libmbfl/LICENSE libmbfl_LICENSE
@@ -1193,14 +1196,10 @@ mkdir build-cgi build-apache build-embedded \
# ----- Manage known as failed test -------
# affected by systzdata patch
+%if %{with tzdata}
rm ext/date/tests/timezone_location_get.phpt
rm ext/date/tests/timezone_version_get.phpt
rm ext/date/tests/timezone_version_get_basic1.phpt
-%if 0%{?fedora} < 29
-# need tzdata 2018i
-rm ext/date/tests/bug33414-1.phpt
-rm ext/date/tests/bug33415-2.phpt
-rm ext/date/tests/date_modify-1.phpt
%endif
# too fast builder
rm ext/date/tests/bug73837.phpt
@@ -1375,7 +1374,7 @@ ln -sf ../configure
--with-layout=GNU \
--with-kerberos \
--with-libxml \
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 6
+%if %{with tzdata}
--with-system-tzdata \
%endif
--with-mhash \
@@ -2002,7 +2001,7 @@ fi
%files common -f files.common
%doc EXTENSIONS NEWS UPGRADING* README.REDIST.BINS *md docs
-%license LICENSE TSRM_LICENSE ZEND_LICENSE
+%license LICENSE TSRM_LICENSE ZEND_LICENSE BOOST_LICENSE
%license libmagic_LICENSE
%license timelib_LICENSE
%doc php.ini-*
@@ -2152,6 +2151,10 @@ fi
%changelog
+* Thu Sep 2 2021 Remi Collet <remi@remirepo.net> - 8.1.0~RC1-1
+- update to 8.1.0RC1
+- bump API version
+
* Tue Aug 24 2021 Remi Collet <remi@remirepo.net> - 8.0.10-1
- Update to 8.0.10 - http://www.php.net/releases/8_0_10.php