summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-26 10:29:24 +0200
committerRemi Collet <remi@php.net>2021-10-26 10:29:24 +0200
commitfcd5bd1b273c7aa7d18866967219351b82874111 (patch)
tree47b13662107e0f3afbf06e4ea7fdda8a643de3d8
parent31bdac94f08c7e32577585e5ddd9b29e9c888473 (diff)
dba: enable qdbm backend
dba: drop gdbm backend
-rw-r--r--php81.spec24
1 files changed, 20 insertions, 4 deletions
diff --git a/php81.spec b/php81.spec
index f61b3c6..93b83d8 100644
--- a/php81.spec
+++ b/php81.spec
@@ -48,6 +48,12 @@
%bcond_with libpcre
%endif
+%if 0%{?fedora} >= 33
+%bcond_without qdbm
+%else
+%bcond_with qdbm
+%endif
+
# Build firebird extensions, you can disable using --without firebird
%bcond_without firebird
@@ -99,7 +105,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -909,8 +915,10 @@ Summary: A database abstraction layer module for PHP applications
License: PHP
BuildRequires: libdb-devel
BuildRequires: tokyocabinet-devel
-BuildRequires: gdbm-devel
BuildRequires: lmdb-devel
+%if %{with qdbm}
+BuildRequires: qdbm-devel
+%endif
Requires: php-common%{?_isa} = %{version}-%{release}
%if 0%{?rhel}
Obsoletes: php53-dba, php53u-dba, php54-dba, php54w-dba, php55u-dba, php55w-dba, php56u-dba, php56w-dba
@@ -1421,9 +1429,11 @@ build --libdir=%{_libdir}/php \
--with-bz2=shared \
--enable-ctype=shared \
--enable-dba=shared --with-db4=%{_prefix} \
- --with-gdbm=%{_prefix} \
--with-tcadb=%{_prefix} \
--with-lmdb=%{_prefix} \
+%if %{with qdbm}
+ --with-qdbm=%{_root_prefix} \
+%endif
--enable-exif=shared \
--enable-ftp=shared \
--with-gettext=shared \
@@ -1559,9 +1569,11 @@ build --includedir=%{_includedir}/php-zts \
--with-bz2=shared \
--enable-ctype=shared \
--enable-dba=shared --with-db4=%{_prefix} \
- --with-gdbm=%{_prefix} \
--with-tcadb=%{_prefix} \
--with-lmdb=%{_prefix} \
+%if %{with qdbm}
+ --with-qdbm=%{_root_prefix} \
+%endif
--with-gettext=shared \
--with-iconv=shared \
--enable-sockets=shared \
@@ -2151,6 +2163,10 @@ fi
%changelog
+* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.1.0~RC4-2
+- dba: enable qdbm backend
+- dba: drop gdbm backend
+
* Wed Oct 13 2021 Remi Collet <remi@remirepo.net> - 8.1.0~RC4-1
- update to 8.1.0RC4