summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-10 12:10:57 +0100
committerRemi Collet <remi@php.net>2023-02-10 12:10:57 +0100
commit2804bbe93e93966f1a1118c17fb87d2e2535537f (patch)
tree11d48f0ac50f3761d7d8e0f74b0edbda32867f33
parentb2bcea3018fafd70489baeeb80b323f15bd6d9d9 (diff)
F38: disable imap extension
-rw-r--r--php81.spec25
1 files changed, 23 insertions, 2 deletions
diff --git a/php81.spec b/php81.spec
index e74b64c..a53ff9a 100644
--- a/php81.spec
+++ b/php81.spec
@@ -40,6 +40,13 @@
# Optional Oracle extensions; pass "--with oci8" etc to rpmbuild.
%bcond_with oci8
+%if 0%{?fedora} >= 38
+# uw-imap is not available
+%bcond_with imap
+%else
+%bcond_without imap
+%endif
+
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# switch to bundled library using --without libpcre
%bcond_without libpcre
@@ -113,7 +120,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -517,6 +524,7 @@ bytecode in the shared memory. This eliminates the stages of reading code from
the disk and compiling it on future access. In addition, it applies a few
bytecode optimization patterns that make code execution faster.
+%if %{with imap}
%package imap
Summary: A module for PHP applications that use IMAP
# All files licensed under PHP version 3.01
@@ -538,6 +546,7 @@ Obsoletes: php80-imap
The php-imap module will add IMAP (Internet Message Access Protocol)
support to PHP. IMAP is a protocol for retrieving and uploading e-mail
messages on mail servers. PHP is an HTML-embedded scripting language.
+%endif
%package ldap
Summary: A module for PHP applications that use LDAP
@@ -1429,7 +1438,9 @@ build --libdir=%{_libdir}/php \
--enable-opcache \
--enable-opcache-file \
--enable-phpdbg \
+%if %{with imap}
--with-imap=shared --with-imap-ssl \
+%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1569,7 +1580,9 @@ build --includedir=%{_includedir}/php-zts \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+%if %{with imap}
--with-imap=shared --with-imap-ssl \
+%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1824,7 +1837,10 @@ done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
# Generate files lists and stub .ini files for each subpackage
-for mod in pgsql odbc ldap snmp imap \
+for mod in pgsql odbc ldap snmp \
+%if %{with imap}
+ imap \
+%endif
mysqlnd mysqli \
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
@@ -2141,7 +2157,9 @@ fi
%files pgsql -f files.pgsql
%files odbc -f files.odbc
+%if %{with imap}
%files imap -f files.imap
+%endif
%files ldap -f files.ldap
%files snmp -f files.snmp
%files xml -f files.xml
@@ -2181,6 +2199,9 @@ fi
%changelog
+* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 8.1.15-2
+- F38: disable imap extension
+
* Wed Feb 1 2023 Remi Collet <remi@remirepo.net> - 8.1.15-1
- Update to 8.1.15 - http://www.php.net/releases/8_1_15.php
- add dependency on pcre2 minimal version