summaryrefslogtreecommitdiffstats
path: root/php80.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php80.spec')
-rw-r--r--php80.spec8
1 files changed, 7 insertions, 1 deletions
diff --git a/php80.spec b/php80.spec
index 604cbc3..36547ff 100644
--- a/php80.spec
+++ b/php80.spec
@@ -208,7 +208,7 @@ BuildRequires: pkgconfig(libedit)
%if %{with libpcre}
BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
-Provides: bundled(pcre2) = 10.32
+Provides: bundled(pcre2) = 10.35
%endif
%if %{with libxcrypt}
BuildRequires: pkgconfig(libxcrypt)
@@ -379,6 +379,12 @@ Summary: Common files for PHP
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
License: PHP and BSD
+
+%if %{with libpcre}
+%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
+Requires: pcre2%{?_isa} >= %{pcre2_buildver}
+%endif
+
# ABI/API check - Arch specific
Provides: php(api) = %{apiver}-%{__isa_bits}
Provides: php(zend-abi) = %{zendver}-%{__isa_bits}