summaryrefslogtreecommitdiffstats
path: root/php80.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-18 09:26:46 +0200
committerRemi Collet <remi@php.net>2021-10-18 09:26:46 +0200
commit577585ee65a5f939083c0579c1d708a1f733f4f2 (patch)
tree2c646bdb5eae398e79be2c87f1653853c8022e4a /php80.spec
parent5be6a93b21c918a3dc73b50ca4e012e205389290 (diff)
build using system libxcrypt
Diffstat (limited to 'php80.spec')
-rw-r--r--php80.spec22
1 files changed, 21 insertions, 1 deletions
diff --git a/php80.spec b/php80.spec
index 03821cb..52e4b11 100644
--- a/php80.spec
+++ b/php80.spec
@@ -48,6 +48,14 @@
%bcond_with libpcre
%endif
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
+# switch to bundled library using --without libxcrypt
+%bcond_without libxcrypt
+%else
+# switch to system library using --with libxcrypt
+%bcond_with libxcrypt
+%endif
+
# Build firebird extensions, you can disable using --without firebird
%bcond_without firebird
@@ -91,7 +99,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -153,6 +161,8 @@ Patch48: php-8.0.10-snmp-sha.patch
# switch phar to use sha256 signature by default, from 8.1
# implement openssl_256 and openssl_512 for phar signatures, from 8.1
Patch49: php-8.0.10-phar-sha.patch
+# use system libxcrypt
+Patch50: php-8.0.12-crypt.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -192,6 +202,9 @@ BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
Provides: bundled(pcre2) = 10.32
%endif
+%if %{with libxcrypt}
+BuildRequires: pkgconfig(libxcrypt)
+%endif
BuildRequires: bzip2
BuildRequires: perl
BuildRequires: autoconf
@@ -1160,6 +1173,7 @@ in pure PHP.
%patch47 -p1 -b .phpinfo
%patch48 -p1 -b .sha
%patch49 -p1 -b .pharsha
+%patch50 -p1 -b .libxcrypt
%patch91 -p1 -b .remi-oci8
@@ -1370,6 +1384,9 @@ ln -sf ../configure
%if %{with libpcre}
--with-external-pcre \
%endif
+%if %{with libxcrypt}
+ --with-external-libcrypt \
+%endif
--with-zlib \
--with-layout=GNU \
--with-kerberos \
@@ -2151,6 +2168,9 @@ fi
%changelog
+* Mon Oct 18 2021 Remi Collet <remi@remirepo.net> - 8.0.12~RC1-2
+- build using system libxcrypt
+
* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 8.0.12~RC1-1
- update to 8.0.12RC1
- use libicu version 69