summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-11 12:15:35 +0200
committerRemi Collet <remi@remirepo.net>2020-09-11 12:15:35 +0200
commitf252207863961c2e1431b6d0079fdbdd73b67f7f (patch)
tree45f74f5776ea50b1c8767a36cf2e5ea5ce59a0aa /Makefile
duplicate php74 => php80
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..78ac8ed
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,11 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBE := -lphp7
+LIBS := -lphp7 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBE) -o tembed