summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-03 08:16:44 +0200
committerRemi Collet <remi@php.net>2022-06-03 08:16:44 +0200
commitdc1050eaca7694dd86ea3e033ceeee0de01bd98d (patch)
tree1c3637474f872ae8e0466e1747ae5612bba4d2a5
parentf2729845bee03d782877fa8dd3afd1c0eb9b519d (diff)
add upstream patch to initialize pcre before mbstring
-rw-r--r--php-mbstring.patch33
-rw-r--r--php80.spec7
2 files changed, 39 insertions, 1 deletions
diff --git a/php-mbstring.patch b/php-mbstring.patch
new file mode 100644
index 0000000..7da512b
--- /dev/null
+++ b/php-mbstring.patch
@@ -0,0 +1,33 @@
+From 2eb2f9d74f22bf35a4915ec95afc53a47ebf1af9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 2 Jun 2022 08:05:22 +0200
+Subject: [PATCH] Fix GH-8685 mbstring requires pcre
+
+---
+ ext/mbstring/mbstring.c | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/ext/mbstring/mbstring.c b/ext/mbstring/mbstring.c
+index 48f22a682a19..4a4088aed3fb 100644
+--- a/ext/mbstring/mbstring.c
++++ b/ext/mbstring/mbstring.c
+@@ -161,9 +161,18 @@ static const php_mb_nls_ident_list php_mb_default_identify_list[] = {
+
+ /* }}} */
+
++/* {{{ mbstring_deps[] */
++static const zend_module_dep mbstring_deps[] = {
++ ZEND_MOD_REQUIRED("pcre")
++ ZEND_MOD_END
++};
++/* }}} */
++
+ /* {{{ zend_module_entry mbstring_module_entry */
+ zend_module_entry mbstring_module_entry = {
+- STANDARD_MODULE_HEADER,
++ STANDARD_MODULE_HEADER_EX,
++ NULL,
++ mbstring_deps,
+ "mbstring",
+ ext_functions,
+ PHP_MINIT(mbstring),
diff --git a/php80.spec b/php80.spec
index 1e07d51..462a59f 100644
--- a/php80.spec
+++ b/php80.spec
@@ -106,7 +106,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -177,6 +177,7 @@ Patch51: php-8.0.13-crypt.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-mbstring.patch
# Security fixes (200+)
@@ -1188,6 +1189,7 @@ rm ext/openssl/tests/p12_with_extra_certs.p12
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up
# security patches
@@ -2180,6 +2182,9 @@ fi
%changelog
+* Fri Jun 3 2022 Remi Collet <remi@remirepo.net> - 8.0.20~RC1-2
+- add upstream patch to initialize pcre before mbstring
+
* Wed May 25 2022 Remi Collet <remi@remirepo.net> - 8.0.20~RC1-1
- update to 8.0.20RC1