summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-15 17:03:39 +0200
committerRemi Collet <remi@remirepo.net>2021-06-15 17:03:39 +0200
commitce3d53d54117a5799ac7e673fe5449daafbea682 (patch)
tree0337576fd1f2f1d36a70d4afd7de594b47039739
parent0ac8d0e2f130b1f0de28c608caad78f2c22a2243 (diff)
update to 8.0.8RC1
ignore unsupported "threads" option on password_hash
-rw-r--r--failed.txt8
-rw-r--r--php-8.0.7-argon2.patch15
-rw-r--r--php80.spec15
3 files changed, 29 insertions, 9 deletions
diff --git a/failed.txt b/failed.txt
index 0f34d01..15184de 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,16 +1,14 @@
-===== 8.0.7 (2021-06-03)
+===== 8.0.8RC1 (2021-06-17)
$ grep -ar 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el7x/build.log:Tests failed : 0
-/var/lib/mock/el8x80/build.log:Tests failed : 1
+/var/lib/mock/el8x80/build.log:Tests failed : 0
/var/lib/mock/fc32x/build.log:Tests failed : 0
-/var/lib/mock/fc33x/build.log:Tests failed : 1
+/var/lib/mock/fc33x/build.log:Tests failed : 0
/var/lib/mock/fc34x/build.log:Tests failed : 0
-el8x, fc33x:
- 3 php://input is empty when enable_post_data_reading=Off [tests/basic/bug67198.phpt]
1 proc_open give erratic test results :(
diff --git a/php-8.0.7-argon2.patch b/php-8.0.7-argon2.patch
new file mode 100644
index 0000000..88018de
--- /dev/null
+++ b/php-8.0.7-argon2.patch
@@ -0,0 +1,15 @@
+diff --git a/ext/sodium/sodium_pwhash.c b/ext/sodium/sodium_pwhash.c
+index e58a9514cc..86cc06cd91 100644
+--- a/ext/sodium/sodium_pwhash.c
++++ b/ext/sodium/sodium_pwhash.c
+@@ -62,10 +62,6 @@ static inline int get_options(zend_array *options, size_t *memlimit, size_t *ops
+ return FAILURE;
+ }
+ }
+- if ((opt = zend_hash_str_find(options, "threads", strlen("threads"))) && (zval_get_long(opt) != 1)) {
+- zend_value_error("A thread value other than 1 is not supported by this implementation");
+- return FAILURE;
+- }
+ return SUCCESS;
+ }
+
diff --git a/php80.spec b/php80.spec
index 17e8e76..db23eb0 100644
--- a/php80.spec
+++ b/php80.spec
@@ -14,7 +14,7 @@
# Extension version
%global fileinfover 1.0.5
%global oci8ver 3.0.1
-%global zipver 1.19.2
+%global zipver 1.19.3
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -85,9 +85,9 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.0.7
-#global rcver RC1
-#global lower RC1
+%global upver 8.0.8
+%global rcver RC1
+%global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -144,6 +144,8 @@ Patch42: php-8.0.0-systzdata-v19.patch
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.4.0-ldap_r.patch
+# Ignore unsupported "threads" option on password_hash
+Patch46: php-8.0.7-argon2.patch
# drop "Configure command" from phpinfo output
# and only use gcc (instead of full version)
Patch47: php-8.0.0-phpinfo.patch
@@ -1150,6 +1152,7 @@ in pure PHP.
%endif
%patch43 -p1 -b .headers
%patch45 -p1 -b .ldap_r
+%patch46 -p1 -b .argon2
%patch47 -p1 -b .phpinfo
%patch91 -p1 -b .remi-oci8
@@ -2142,6 +2145,10 @@ fi
%changelog
+* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 8.0.8~RC1-1
+- update to 8.0.8RC1
+- ignore unsupported "threads" option on password_hash
+
* Wed Jun 2 2021 Remi Collet <remi@remirepo.net> - 8.0.7-1
- Update to 8.0.7 - http://www.php.net/releases/8_0_7.php