summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-10 14:21:54 +0100
committerRemi Collet <remi@php.net>2023-02-10 14:21:54 +0100
commit601fb84181dbd140078d12d321d31e17c43e8ad6 (patch)
tree67eff9324872b6dc4e0187308e48a315fec3269b
parent4852755785852b5179eaa1457d92195ee820440c (diff)
F38: disable imap extension
-rw-r--r--php80.spec25
1 files changed, 23 insertions, 2 deletions
diff --git a/php80.spec b/php80.spec
index 36547ff..cf17477 100644
--- a/php80.spec
+++ b/php80.spec
@@ -40,6 +40,13 @@
# Optional Oracle extensions; pass "--with oci8" etc to rpmbuild.
%bcond_with oci8
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+# uw-imap is not available
+%bcond_with imap
+%else
+%bcond_without imap
+%endif
+
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# switch to bundled library using --without libpcre
%bcond_without libpcre
@@ -105,7 +112,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -516,6 +523,7 @@ bytecode in the shared memory. This eliminates the stages of reading code from
the disk and compiling it on future access. In addition, it applies a few
bytecode optimization patterns that make code execution faster.
+%if %{with imap}
%package imap
Summary: A module for PHP applications that use IMAP
# All files licensed under PHP version 3.01
@@ -537,6 +545,7 @@ Obsoletes: php80-imap
The php-imap module will add IMAP (Internet Message Access Protocol)
support to PHP. IMAP is a protocol for retrieving and uploading e-mail
messages on mail servers. PHP is an HTML-embedded scripting language.
+%endif
%package ldap
Summary: A module for PHP applications that use LDAP
@@ -1434,7 +1443,9 @@ build --libdir=%{_libdir}/php \
--enable-opcache \
--enable-opcache-file \
--enable-phpdbg \
+%if %{with imap}
--with-imap=shared --with-imap-ssl \
+%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1574,7 +1585,9 @@ build --includedir=%{_includedir}/php-zts \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+%if %{with imap}
--with-imap=shared --with-imap-ssl \
+%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1829,7 +1842,10 @@ done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
# Generate files lists and stub .ini files for each subpackage
-for mod in pgsql odbc ldap snmp imap \
+for mod in pgsql odbc ldap snmp \
+%if %{with imap}
+ imap \
+%endif
mysqlnd mysqli \
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
@@ -2146,7 +2162,9 @@ fi
%files pgsql -f files.pgsql
%files odbc -f files.odbc
+%if %{with imap}
%files imap -f files.imap
+%endif
%files ldap -f files.ldap
%files snmp -f files.snmp
%files xml -f files.xml
@@ -2186,6 +2204,9 @@ fi
%changelog
+* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 8.0.27-2
+- F38: disable imap extension
+
* Tue Jan 3 2023 Remi Collet <remi@remirepo.net> - 8.0.27-1
- Update to 8.0.27 - http://www.php.net/releases/8_0_27.php
- use oracle client library version 21.8