summaryrefslogtreecommitdiffstats
path: root/php74.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php74.spec')
-rw-r--r--php74.spec24
1 files changed, 18 insertions, 6 deletions
diff --git a/php74.spec b/php74.spec
index 540d67f..9d942ba 100644
--- a/php74.spec
+++ b/php74.spec
@@ -97,13 +97,13 @@
%global with_zip 0
%global upver 7.4.0
-%global rcver RC1
-%global lower RC1
+%global rcver RC2
+%global lower RC2
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -150,7 +150,7 @@ Patch42: php-7.3.3-systzdata-v18.patch
# See http://bugs.php.net/53436
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
-Patch45: php-7.2.3-ldap_r.patch
+Patch45: php-7.4.0-ldap_r.patch
# Make php_config.h constant across builds
Patch46: php-7.2.4-fixheader.patch
# drop "Configure command" from phpinfo output
@@ -168,6 +168,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.0.10-datetests.patch
# WIP
+Patch100: https://github.com/php/php-src/commit/56e880af9f90c9d313292c75eb6df58cc9e7e208.patch
BuildRequires: gnupg2
BuildRequires: bzip2-devel
@@ -447,6 +448,7 @@ Provides: php-zts-devel%{?_isa} = %{version}-%{release}
%endif
%if 0%{?rhel}
Obsoletes: php53-devel, php53u-devel, php54-devel, php54w-devel, php55u-devel, php55w-devel, php56u-devel, php56w-devel
+Obsoletes: php55u-pecl-jsonc-devel, php56u-pecl-jsonc-devel
Obsoletes: php70u-devel, php70w-devel, php71u-devel, php71w-devel, php72u-devel, php72w-devel
Obsoletes: php73-devel, php73w-devel
Obsoletes: php74-devel, php74w-devel
@@ -1172,6 +1174,7 @@ in pure PHP.
%endif
# WIP patch
+%patch100 -p1 -R
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -1204,6 +1207,8 @@ rm ext/date/tests/bug33414-1.phpt
rm ext/date/tests/bug33415-2.phpt
rm ext/date/tests/date_modify-1.phpt
%endif
+# too fast builder
+rm ext/date/tests/bug73837.phpt
# Should be skipped but fails sometime
rm ext/standard/tests/file/file_get_contents_error001.phpt
# fails sometime
@@ -1215,9 +1220,11 @@ rm Zend/tests/bug68412.phpt
rm sapi/cli/tests/upload_2G.phpt
# tar issue
rm ext/zlib/tests/004-mb.phpt
-# avoid issue when 2 builds run simultaneously
+# avoid issue when 2 builds run simultaneously (keep 64321 for the SCL)
%ifarch x86_64
sed -e 's/64321/64322/' -i ext/openssl/tests/*.phpt
+%else
+sed -e 's/64321/64323/' -i ext/openssl/tests/*.phpt
%endif
# Safety check for API version change.
@@ -1640,7 +1647,7 @@ export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
export SKIP_ONLINE_TESTS=1
export SKIP_IO_CAPTURE_TESTS=1
unset TZ LANG LC_ALL
-if ! make test TESTS=%{?_smp_mflags}; then
+if ! make test TESTS=-j4; then
set +x
for f in $(find .. -name \*.diff -type f -print); do
if ! grep -q XFAIL "${f/.diff/.phpt}"
@@ -2140,6 +2147,11 @@ fi
%changelog
+* Tue Sep 17 2019 Remi Collet <remi@remirepo.net> - 7.4.0~rc2-2
+- update to 7.4.0RC2
+- add tarball signature check
+- reduce to 4 concurrent test workers
+
* Thu Sep 5 2019 Remi Collet <remi@remirepo.net> - 7.4.0~RC1-1
- update to 7.4.0RC1