summaryrefslogtreecommitdiffstats
path: root/php74.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-11 14:49:55 +0200
committerRemi Collet <remi@php.net>2023-05-11 14:49:55 +0200
commit2d6b71ed808d03365eab55bfc10245a266e513ba (patch)
treef8c3ce1bcd5d5b81a128b5deea7662cda0c64825 /php74.spec
parentbd296896979157a128df27cff4d9da10699adef0 (diff)
use ICU 72.1
use oracle client library version 21.10 fix possible buffer overflow in date define %__phpize and %__phpconfig
Diffstat (limited to 'php74.spec')
-rw-r--r--php74.spec60
1 files changed, 31 insertions, 29 deletions
diff --git a/php74.spec b/php74.spec
index a0ee8e6..75561b4 100644
--- a/php74.spec
+++ b/php74.spec
@@ -24,7 +24,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.8
+%global oraclever 21.10
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -98,7 +98,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 5%{?dist}
+Release: 6%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -1007,9 +1007,9 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 71
-BuildRequires: pkgconfig(icu-io) >= 71
-BuildRequires: pkgconfig(icu-uc) >= 71
+BuildRequires: pkgconfig(icu-i18n) >= 72
+BuildRequires: pkgconfig(icu-io) >= 72
+BuildRequires: pkgconfig(icu-uc) >= 72
%if 0%{?rhel} == 7
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1142,41 +1142,37 @@ in pure PHP.
%setup -q -n php-%{upver}%{?rcver}
-%patch1 -p1 -b .mpmcheck
-%patch5 -p1 -b .includedir
-%patch6 -p1 -b .embed
-%patch8 -p1 -b .libdb
-%if 0%{?rhel}
-%patch9 -p1 -b .curltls
+%patch -P1 -p1 -b .mpmcheck
+%patch -P5 -p1 -b .includedir
+%patch -P6 -p1 -b .embed
+%patch -P8 -p1 -b .libdb
+%if 0%{?rhel} == 7
+%patch -P9 -p1 -b .curltls
%endif
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 6
-%patch42 -p1 -b .systzdata
-%endif
-%patch43 -p1 -b .headers
-%patch45 -p1 -b .ldap_r
-%patch46 -p1 -b .argon2
-%patch47 -p1 -b .phpinfo
-%patch48 -p1 -b .snmp
+%patch -P42 -p1 -b .systzdata
+%patch -P43 -p1 -b .headers
+%patch -P45 -p1 -b .ldap_r
+%patch -P46 -p1 -b .argon2
+%patch -P47 -p1 -b .phpinfo
+%patch -P48 -p1 -b .snmp
%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9
-%patch50 -p1 -b .openssl3
+%patch -P50 -p1 -b .openssl3
rm ext/openssl/tests/p12_with_extra_certs.p12
%endif
-%patch91 -p1 -b .remi-oci8
+%patch -P91 -p1 -b .remi-oci8
# upstream patches
# security patches
-%patch200 -p1 -b .bug81740
-%patch201 -p1 -b .bug81744
-%patch202 -p1 -b .bug81746
-%patch203 -p1 -b .cve0662
+%patch -P200 -p1 -b .bug81740
+%patch -P201 -p1 -b .bug81744
+%patch -P202 -p1 -b .bug81746
+%patch -P203 -p1 -b .cve0662
# Fixes for tests related to tzdata
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 6
-%patch300 -p1 -b .datetests
-%endif
+%patch -P300 -p1 -b .datetests
# WIP patch
@@ -1941,7 +1937,7 @@ sed -e "s/@PHP_APIVER@/%{apiver}-%{__isa_bits}/" \
%endif
< %{SOURCE3} > macros.php
%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
-echo '%%pecl_xmldir %{_localstatedir}/lib/php/peclxml' >>macros.php
+echo '%%pecl_xmldir %%{_localstatedir}/lib/php/peclxml' >>macros.php
%endif
install -m 644 -D macros.php \
$RPM_BUILD_ROOT%{macrosdir}/macros.php
@@ -2201,6 +2197,12 @@ EOF
%changelog
+* Fri Apr 14 2023 Remi Collet <remi@remirepo.net> - 7.4.33-6
+- use ICU 72.1
+- use oracle client library version 21.10
+- fix possible buffer overflow in date
+- define %%__phpize and %%__phpconfig
+
* Tue Feb 21 2023 Remi Collet <remi@remirepo.net> - 7.4.33-5
- F38: enable imap extension