summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-10 14:24:35 +0100
committerRemi Collet <remi@php.net>2023-02-10 14:24:35 +0100
commitd1c46074db2886d8fd0a6d2c41617a845058e9d5 (patch)
tree3077cf884ccf30bde44d5c90cd09ed2b3b85f7e7
parentf9f72bd4cb74e3f817f206cb51ad4a41e4a8278e (diff)
F38: disable imap extension
-rw-r--r--php74.spec37
1 files changed, 32 insertions, 5 deletions
diff --git a/php74.spec b/php74.spec
index 702fe8f..2db807c 100644
--- a/php74.spec
+++ b/php74.spec
@@ -39,7 +39,14 @@
%global mysql_config %{_libdir}/mysql/mysql_config
# Optional components; pass "--with mssql" etc to rpmbuild.
-%global with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
+%global with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
+
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+# uw-imap is not available
+%bcond_with imap
+%else
+%bcond_without imap
+%endif
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global with_libpcre 1
@@ -96,7 +103,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -360,6 +367,12 @@ Summary: Common files for PHP
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
License: PHP and BSD
+
+%if %{with_libpcre}
+%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
+Requires: pcre2%{?_isa} >= %{pcre2_buildver}
+%endif
+
# ABI/API check - Arch specific
Provides: php(api) = %{apiver}-%{__isa_bits}
Provides: php(zend-abi) = %{zendver}-%{__isa_bits}
@@ -475,6 +488,7 @@ bytecode in the shared memory. This eliminates the stages of reading code from
the disk and compiling it on future access. In addition, it applies a few
bytecode optimization patterns that make code execution faster.
+%if %{with imap}
%package imap
Summary: A module for PHP applications that use IMAP
Group: Development/Languages
@@ -496,6 +510,7 @@ Obsoletes: php74-imap, php74w-imap
The php-imap module will add IMAP (Internet Message Access Protocol)
support to PHP. IMAP is a protocol for retrieving and uploading e-mail
messages on mail servers. PHP is an HTML-embedded scripting language.
+%endif
%package ldap
Summary: A module for PHP applications that use LDAP
@@ -1391,7 +1406,9 @@ build --libdir=%{_libdir}/php \
--enable-opcache \
--enable-opcache-file \
--enable-phpdbg \
+%if %{with imap}
--with-imap=shared --with-imap-ssl \
+%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1532,7 +1549,9 @@ build --includedir=%{_includedir}/php-zts \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+%if %{with imap}
--with-imap=shared --with-imap-ssl \
+%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1801,7 +1820,10 @@ done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
# Generate files lists and stub .ini files for each subpackage
-for mod in pgsql odbc ldap snmp imap json \
+for mod in pgsql odbc ldap snmp json \
+%if %{with imap}
+ imap \
+%endif
mysqlnd mysqli \
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
@@ -2002,7 +2024,7 @@ cat << EOF
WARNING : PHP 7.4 have reached its "End of Life" in
November 2022. Even, if this package includes some of
- the important security fix, backported from 8.0, the
+ the important security fixes, backported from 8.0, the
UPGRADE to a maintained version is very strongly RECOMMENDED.
=====================================================================
@@ -2134,7 +2156,9 @@ EOF
%files pgsql -f files.pgsql
%files odbc -f files.odbc
+%if %{with imap}
%files imap -f files.imap
+%endif
%files ldap -f files.ldap
%files snmp -f files.snmp
%files xml -f files.xml
@@ -2176,7 +2200,10 @@ EOF
%changelog
-* Mon Dec 19 2022 Remi Collet <remi@remirepo.net> - 7.4.33-1
+* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 7.4.33-3
+- F38: disable imap extension
+
+* Mon Dec 19 2022 Remi Collet <remi@remirepo.net> - 7.4.33-2
- pdo: fix #81740: PDO::quote() may return unquoted string
CVE-2022-31631
- use oracle client library version 21.8