summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-22 08:25:46 +0200
committerRemi Collet <remi@php.net>2023-09-22 08:25:46 +0200
commit7aac0b618907230bc78d5262f5b2bb4dd97286ae (patch)
tree1106abcfc01971a74aa96789a97ba0ed3a2da3ce
parentbeda64cede638963f4ded9e129d4c0b2f11606c2 (diff)
use oracle client library version 21.11 on x86_64, 19.19 on aarch64
use official Oracle Instant Client RPM
-rw-r--r--failed.txt4
-rw-r--r--php74.spec57
2 files changed, 34 insertions, 27 deletions
diff --git a/failed.txt b/failed.txt
index e8e18ca..d30fdda 100644
--- a/failed.txt
+++ b/failed.txt
@@ -5,12 +5,12 @@ $ grep -ar 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el7x74/build.log:Tests failed : 0
/var/lib/mock/el8x74/build.log:Tests failed : 0
/var/lib/mock/el9x74/build.log:Tests failed : 0
-/var/lib/mock/fc36x74/build.log:Tests failed : 0
/var/lib/mock/fc37x74/build.log:Tests failed : 0
/var/lib/mock/fc38x74/build.log:Tests failed : 1
+/var/lib/mock/fc39x74/build.log:Tests failed : 1
-fc38x:
+fc38x, fc39x:
3 openssl_private_decrypt() tests [ext/openssl/tests/openssl_private_decrypt_basic.phpt]
diff --git a/php74.spec b/php74.spec
index 5b5da77..3bdd59a 100644
--- a/php74.spec
+++ b/php74.spec
@@ -24,8 +24,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.10
+%ifarch aarch64
+%global oraclever 19.19
+%global oraclelib 19.1
+%global oracledir 19.19
+%else
+%global oraclever 21.11
%global oraclelib 21.1
+%global oracledir 21
+%endif
# Build for LiteSpeed Web Server (LSAPI)
%global with_lsws 1
@@ -52,7 +59,11 @@
%global with_firebird 1
# Build ZTS extension or only NTS
+%ifarch x86_64
%bcond_without zts
+%else
+%bcond_with zts
+%endif
# Debuild build
%bcond_with debug
@@ -98,7 +109,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 8%{?dist}
+Release: 9%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -369,6 +380,7 @@ Summary: Common files for PHP
# regex, libmagic are licensed under BSD
License: PHP and BSD
+Requires: tzdata
%if %{with_libpcre}
%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
Requires: pcre2%{?_isa} >= %{pcre2_buildver}
@@ -710,7 +722,14 @@ Summary: A module for PHP applications that use OCI8 databases
Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
+%ifarch aarch64
+BuildRequires: oracle-instantclient%{oraclever}-devel
+# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
+Requires: libclntsh.so.%{oraclelib}
+AutoReq: 0
+%else
BuildRequires: oracle-instantclient-devel >= %{oraclever}
+%endif
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_oci
@@ -719,8 +738,6 @@ Obsoletes: php-pecl-oci8 <= %{oci8ver}
Conflicts: php-pecl-oci8 > %{oci8ver}
Provides: php-pecl(oci8) = %{oci8ver}
Provides: php-pecl(oci8)%{?_isa} = %{oci8ver}
-# Should requires libclntsh.so.18.3, but it's not provided by Oracle RPM.
-AutoReq: 0
%if 0%{?rhel} == 7
Obsoletes: php53-oci8, php53u-oci8, php54-oci8, php54w-oci8, php55u-oci8, php55w-oci8, php56u-oci8, php56w-oci8
Obsoletes: php70u-oci8, php70w-oci8, php71u-oci8, php71w-oci8, php72u-oci8, php72w-oci8
@@ -736,13 +753,9 @@ The extension is linked with Oracle client libraries %{oraclever}
(Oracle Instant Client). For details, see Oracle's note
"Oracle Client / Server Interoperability Support" (ID 207303.1).
-You must install libclntsh.so.%{oraclelib} to use this package, provided
-in the database installation, or in the free Oracle Instant Client
-available from Oracle.
-
-Notice:
-- php-oci8 provides oci8 and pdo_oci extensions from php sources.
-- php-pecl-oci8 only provides oci8 extension.
+You must install libclntsh.so.%{oraclelib} to use this package,
+provided by Oracle Instant Client RPM available from Oracle on:
+https://www.oracle.com/database/technologies/instant-client/downloads.html
Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
%endif
@@ -1444,13 +1457,8 @@ build --libdir=%{_libdir}/php \
--with-mysqli=shared,mysqlnd \
--with-mysql-sock=%{mysql_sock} \
%if %{with_oci8}
-%ifarch x86_64
- --with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
- --with-pdo-oci=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
-%else
- --with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
- --with-pdo-oci=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
-%endif
+ --with-oci8=shared,instantclient,%{_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
+ --with-pdo-oci=shared,instantclient,%{_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
%endif
%if %{with_firebird}
--with-pdo-firebird=shared \
@@ -1588,13 +1596,8 @@ build --includedir=%{_includedir}/php-zts \
--with-mysql-sock=%{mysql_sock} \
--enable-mysqlnd-threading \
%if %{with_oci8}
-%ifarch x86_64
- --with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
- --with-pdo-oci=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
-%else
- --with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
- --with-pdo-oci=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
-%endif
+ --with-oci8=shared,instantclient,%{_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
+ --with-pdo-oci=shared,instantclient,%{_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
%endif
%if %{with_firebird}
--with-pdo-firebird=shared \
@@ -2203,6 +2206,10 @@ EOF
%changelog
+* Thu Sep 21 2023 Remi Collet <remi@remirepo.net> - 7.4.33-9
+- use oracle client library version 21.11 on x86_64, 19.19 on aarch64
+- use official Oracle Instant Client RPM
+
* Tue Aug 1 2023 Remi Collet <remi@remirepo.net> - 7.4.33-8
- Fix Security issue with external entity loading in XML without enabling it
GHSA-3qrf-m4j2-pcrr CVE-2023-3823