summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-12 15:55:28 +0100
committerRemi Collet <remi@php.net>2023-12-12 15:55:28 +0100
commit500c6565444c4b51a679812d4285257acb660f75 (patch)
treee7bdebda281ff291e8d03e5480525320eda551a2
parent609aeee3a33f595986316f911829a58733cc9bda (diff)
use ICU 73.2
use oracle client library version 21.12 on x86_64, 19.19 on aarch64 add fixes for libxml 2.11 and 2.12 from 8.1
-rw-r--r--failed.txt9
-rw-r--r--php-7.4.33-tests.patch26
-rw-r--r--php74.spec21
3 files changed, 48 insertions, 8 deletions
diff --git a/failed.txt b/failed.txt
index d30fdda..6b90e4f 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,16 +1,19 @@
-===== 7.4.33-8 (2023-08-03)
+===== 7.4.33-10 (2023-12-12)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el7x74/build.log:Tests failed : 0
+/var/lib/mock/el8a74/build.log:Tests failed : 0
/var/lib/mock/el8x74/build.log:Tests failed : 0
-/var/lib/mock/el9x74/build.log:Tests failed : 0
+/var/lib/mock/el9a74/build.log:Tests failed : 1
+/var/lib/mock/el9x74/build.log:Tests failed : 1
/var/lib/mock/fc37x74/build.log:Tests failed : 0
/var/lib/mock/fc38x74/build.log:Tests failed : 1
+/var/lib/mock/fc39a74/build.log:Tests failed : 1
/var/lib/mock/fc39x74/build.log:Tests failed : 1
-fc38x, fc39x:
+fc38, fc39, el9:
3 openssl_private_decrypt() tests [ext/openssl/tests/openssl_private_decrypt_basic.phpt]
diff --git a/php-7.4.33-tests.patch b/php-7.4.33-tests.patch
new file mode 100644
index 0000000..aa8f1d9
--- /dev/null
+++ b/php-7.4.33-tests.patch
@@ -0,0 +1,26 @@
+From 6974372fbbea4279e1e4f5c24425581208f5553a Mon Sep 17 00:00:00 2001
+From: Nikita Popov <nikita.ppv@gmail.com>
+Date: Mon, 18 Oct 2021 12:45:26 +0200
+Subject: [PATCH] Fix bug #81510
+
+Make the used arrays larger, because the previous sizes were not
+slow enough on some hardware.
+---
+ Zend/tests/bug74093.phpt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Zend/tests/bug74093.phpt b/Zend/tests/bug74093.phpt
+index 7f20285805bf..c5fc9da8cbbf 100644
+--- a/Zend/tests/bug74093.phpt
++++ b/Zend/tests/bug74093.phpt
+@@ -12,8 +12,8 @@ max_execution_time=1
+ hard_timeout=1
+ --FILE--
+ <?php
+-$a1 = range(1, 1000000);
+-$a2 = range(100000, 1999999);
++$a1 = range(1, 2000000);
++$a2 = range(100000, 2999999);
+ array_intersect($a1, $a2);
+ ?>
+ --EXPECTF--
diff --git a/php74.spec b/php74.spec
index 3bdd59a..d21f745 100644
--- a/php74.spec
+++ b/php74.spec
@@ -29,7 +29,7 @@
%global oraclelib 19.1
%global oracledir 19.19
%else
-%global oraclever 21.11
+%global oraclever 21.12
%global oraclelib 21.1
%global oracledir 21
%endif
@@ -109,7 +109,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 9%{?dist}
+Release: 10%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -148,6 +148,8 @@ Source53: 20-ffi.ini
Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
Patch6: php-7.4.0-embed.patch
+# For libxml 2.12 from 8.1
+Patch7: php-7.4.33-libxml212.patch
Patch8: php-7.2.0-libdb.patch
Patch9: php-7.0.7-curl.patch
@@ -184,6 +186,8 @@ Patch206: php-cve-2023-3824.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
Patch300: php-7.0.10-datetests.patch
+# Make test slower
+Patch301: php-7.4.33-tests.patch
# WIP
@@ -1023,9 +1027,9 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 72
-BuildRequires: pkgconfig(icu-io) >= 72
-BuildRequires: pkgconfig(icu-uc) >= 72
+BuildRequires: pkgconfig(icu-i18n) >= 73
+BuildRequires: pkgconfig(icu-io) >= 73
+BuildRequires: pkgconfig(icu-uc) >= 73
%if 0%{?rhel} == 7
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1161,6 +1165,7 @@ in pure PHP.
%patch -P1 -p1 -b .mpmcheck
%patch -P5 -p1 -b .includedir
%patch -P6 -p1 -b .embed
+%patch -P7 -p1 -b .libxml212
%patch -P8 -p1 -b .libdb
%if 0%{?rhel} == 7
%patch -P9 -p1 -b .curltls
@@ -1192,6 +1197,7 @@ rm ext/openssl/tests/p12_with_extra_certs.p12
# Fixes for tests related to tzdata
%patch -P300 -p1 -b .datetests
+%patch -P301 -p1 -b .tests
# WIP patch
@@ -2206,6 +2212,11 @@ EOF
%changelog
+* Tue Dec 12 2023 Remi Collet <remi@remirepo.net> - 7.4.33-10
+- use ICU 73.2
+- use oracle client library version 21.12 on x86_64, 19.19 on aarch64
+- add fixes for libxml 2.11 and 2.12 from 8.1
+
* Thu Sep 21 2023 Remi Collet <remi@remirepo.net> - 7.4.33-9
- use oracle client library version 21.11 on x86_64, 19.19 on aarch64
- use official Oracle Instant Client RPM