summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Reidenbach <mark@everytruckjob.com>2020-04-20 00:18:27 +0000
committerRemi Collet <remi@remirepo.net>2020-04-20 06:43:24 +0200
commit3bff79cc4063043ad9f170cfa28f275eaf983a13 (patch)
tree39ee149c3490d1d19a1d86a889038d7c4b66709a
parent14dc5f5088e711a3622d65261869175f208d3d69 (diff)
Add zts conditionals for files when building without zts.
-rw-r--r--php74.spec8
1 files changed, 6 insertions, 2 deletions
diff --git a/php74.spec b/php74.spec
index 1cbe467..186b7e4 100644
--- a/php74.spec
+++ b/php74.spec
@@ -2027,19 +2027,21 @@ fi
%files cli
%{_bindir}/php
-%{_bindir}/zts-php
%{_bindir}/php-cgi
%{_bindir}/phar.phar
%{_bindir}/phar
# provides phpize here (not in -devel) for pecl command
%{_bindir}/phpize
%{_mandir}/man1/php.1*
-%{_mandir}/man1/zts-php.1*
%{_mandir}/man1/php-cgi.1*
%{_mandir}/man1/phar.1*
%{_mandir}/man1/phar.phar.1*
%{_mandir}/man1/phpize.1*
+%if %{with_zts}
+%{_bindir}/zts-php
+%{_mandir}/man1/zts-php.1*
%{_mandir}/man1/zts-phpize.1*
+%endif
%files dbg
%{_bindir}/phpdbg
@@ -2141,7 +2143,9 @@ fi
%files mysqlnd -f files.mysqlnd
%files opcache -f files.opcache
%config(noreplace) %{_sysconfdir}/php.d/opcache-default.blacklist
+%if %{with_zts}
%config(noreplace) %{_sysconfdir}/php-zts.d/opcache-default.blacklist
+%endif
%if %{with_oci8}
%files oci8 -f files.oci8
%endif