summaryrefslogtreecommitdiffstats
path: root/php73.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php73.spec')
-rw-r--r--php73.spec20
1 files changed, 18 insertions, 2 deletions
diff --git a/php73.spec b/php73.spec
index 3d68a07..9313f9d 100644
--- a/php73.spec
+++ b/php73.spec
@@ -176,6 +176,8 @@ Patch45: php-7.2.3-ldap_r.patch
Patch46: php-7.2.4-fixheader.patch
# drop "Configure command" from phpinfo output
Patch47: php-5.6.3-phpinfo.patch
+# backport PDOStatement::getColumnMeta from 7.4
+Patch48: php-7.3.3-pdooci.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -440,6 +442,11 @@ Requires: libtool
%if %{with_libpcre}
Requires: pcre2-devel%{?_isa}
%endif
+%if 0%{?rhel} == 6
+Requires: libicu-last-devel%{?_isa}
+%else
+Requires: libicu-devel%{?_isa} > 62
+%endif
Obsoletes: php-pecl-pdo-devel
Obsoletes: php-pecl-json-devel < %{jsonver}
Obsoletes: php-pecl-jsonc-devel < %{jsonver}
@@ -1004,8 +1011,11 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-# Upstream requires 4.0, we require 50 to ensure use of libicu-last
-BuildRequires: libicu-devel >= 50
+%if 0%{?rhel} == 6
+BuildRequires: libicu-last-devel
+%else
+BuildRequires: libicu-devel > 62
+%endif
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1129,6 +1139,7 @@ low-level PHP extension for the libsodium cryptographic library.
%endif
%patch46 -p1 -b .fixheader
%patch47 -p1 -b .phpinfo
+%patch48 -p1 -b .pdooci
%patch91 -p1 -b .remi-oci8
@@ -2204,6 +2215,11 @@ fi
%changelog
+* Mon Feb 18 2019 Remi Collet <remi@remirepo.net> - 7.3.2-2
+- pdo_oci: backport PDOStatement::getColumnMeta from 7.4
+- rebuild using libicu62
+- drop configuration for ZTS mod_php (Fedora >= 27)
+
* Wed Feb 6 2019 Remi Collet <remi@remirepo.net> - 7.3.2-1
- Update to 7.3.2 - http://www.php.net/releases/7_3_2.php