summaryrefslogtreecommitdiffstats
path: root/php73.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php73.spec')
-rw-r--r--php73.spec19
1 files changed, 16 insertions, 3 deletions
diff --git a/php73.spec b/php73.spec
index 492f095..9e5b328 100644
--- a/php73.spec
+++ b/php73.spec
@@ -25,7 +25,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.5
+%global oraclever 21.6
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -111,7 +111,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -180,8 +180,12 @@ Patch91: php-7.2.0-oci8conf.patch
Patch100: php-bug80682.patch
# Backported from 7.4.18 - pdo_odbc
Patch101: php-bug80783.patch
+# Backported from 7.4.26 for pcre >= 10.38
+Patch102: php-pcre1038.patch
# Security fixes (200+)
+Patch200: php-bug81719.patch
+Patch201: php-bug81720.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -853,7 +857,7 @@ License: PHP and BSD
%endif
Requires: php-common%{?_isa} = %{version}-%{release}
%if %{with_libgd}
-BuildRequires: gd-devel >= 2.3
+BuildRequires: gd-devel >= 2.3.3
%else
# Required to build the bundled GD library
BuildRequires: libjpeg-devel
@@ -1157,8 +1161,11 @@ low-level PHP extension for the libsodium cryptographic library.
# upstream patches
%patch100 -p1 -b .bug80682
%patch101 -p1 -b .bug80783
+%patch102 -p1 -b .pcre1038
# security patches
+%patch200 -p1 -b .bug81719
+%patch201 -p1 -b .bug81720
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -2246,6 +2253,12 @@ fi
%changelog
+* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.3.33-3
+- use oracle client library version 21.6
+- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626
+- pgsql: fix #81720: Uninitialized array in pg_query_params(). CVE-2022-31625
+- pcre: fix default options for pcre >= 10.38
+
* Wed Feb 23 2022 Remi Collet <remi@remirepo.net> - 7.3.33-2
- retrieve tzdata version
- use oracle client library version 21.5