summaryrefslogtreecommitdiffstats
path: root/php73.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-14 15:55:24 +0100
committerRemi Collet <remi@php.net>2023-02-14 15:55:24 +0100
commite07150a69c1a42bc70fd4a5063ce6f43f6859d94 (patch)
tree4ce097fdec38d4b19e84a4c1727c6357949c4895 /php73.spec
parent6ba79031047494fc2e5b2082e1ef36cf59b892dd (diff)
fix #81744: Password_verify() always return true with some hash
CVE-2023-0567 fix #81746: 1-byte array overrun in common path resolve code CVE-2023-0568 fix DOS vulnerability when parsing multipart request body CVE-2023-0662 add dependency on pcre2 minimal version
Diffstat (limited to 'php73.spec')
-rw-r--r--php73.spec23
1 files changed, 22 insertions, 1 deletions
diff --git a/php73.spec b/php73.spec
index 3d0e082..3e6b6d6 100644
--- a/php73.spec
+++ b/php73.spec
@@ -111,7 +111,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 7%{?dist}
+Release: 8%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -190,6 +190,9 @@ Patch202: php-bug81727.patch
Patch203: php-bug81726.patch
Patch204: php-bug81738.patch
Patch205: php-bug81740.patch
+Patch206: php-bug81744.patch
+Patch207: php-bug81746.patch
+Patch208: php-cve-2023-0662.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -393,6 +396,12 @@ Summary: Common files for PHP
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
License: PHP and BSD
+
+%if %{with_libpcre}
+%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
+Requires: pcre2%{?_isa} >= %{pcre2_buildver}
+%endif
+
# ABI/API check - Arch specific
Provides: php(api) = %{apiver}%{isasuffix}
Provides: php(zend-abi) = %{zendver}%{isasuffix}
@@ -1175,6 +1184,9 @@ low-level PHP extension for the libsodium cryptographic library.
%patch203 -p1 -b .bug81726
%patch204 -p1 -b .bug81738
%patch205 -p1 -b .bug81740
+%patch206 -p1 -b .bug81744
+%patch207 -p1 -b .bug81746
+%patch208 -p1 -b .cve0662
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -2275,6 +2287,15 @@ EOF
%changelog
+* Tue Feb 14 2023 Remi Collet <remi@remirepo.net> - 7.3.33-8
+- fix #81744: Password_verify() always return true with some hash
+ CVE-2023-0567
+- fix #81746: 1-byte array overrun in common path resolve code
+ CVE-2023-0568
+- fix DOS vulnerability when parsing multipart request body
+ CVE-2023-0662
+- add dependency on pcre2 minimal version
+
* Mon Dec 19 2022 Remi Collet <remi@remirepo.net> - 7.3.33-7
- pdo: fix #81740: PDO::quote() may return unquoted string
CVE-2022-31631