summaryrefslogtreecommitdiffstats
path: root/php73.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-27 16:01:36 +0200
committerRemi Collet <remi@php.net>2022-09-27 16:01:36 +0200
commit0664f00420bd66bd93a6c9e8e48e5d0d22e93285 (patch)
tree1ef4d2d0e2b2f6d93c604e3bd350f82e1a33ff40 /php73.spec
parent059ba460fd4e1aad290ade3dd38d6a4aa06247d8 (diff)
phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
core: fix #81727 Don't mangle HTTP variable names that clash with ones that have a specific semantic meaning. CVE-2022-31629 use oracle client library version 21.7
Diffstat (limited to 'php73.spec')
-rw-r--r--php73.spec34
1 files changed, 29 insertions, 5 deletions
diff --git a/php73.spec b/php73.spec
index 9e5b328..2e1c296 100644
--- a/php73.spec
+++ b/php73.spec
@@ -25,7 +25,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.6
+%global oraclever 21.7
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -111,7 +111,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 3%{?dist}
+Release: 4%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -186,6 +186,8 @@ Patch102: php-pcre1038.patch
# Security fixes (200+)
Patch200: php-bug81719.patch
Patch201: php-bug81720.patch
+Patch202: php-bug81727.patch
+Patch203: php-bug81726.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -327,7 +329,6 @@ Group: Development/Languages
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
Requires: php-common%{?_isa} = %{version}-%{release}
-Requires(pre): /usr/sbin/useradd
%if %{with_systemd}
BuildRequires: systemd-devel
%{?systemd_requires}
@@ -348,6 +349,8 @@ Requires(pre): httpd-filesystem
Requires: httpd-filesystem >= 2.4.10
# php engine for Apache httpd webserver
Provides: php(httpd)
+%else
+Requires(pre): /usr/sbin/useradd
%endif
%if %{with_nginx}
# for /etc/nginx ownership
@@ -1025,8 +1028,8 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-# Upstream requires 4.0, we require 50 to ensure use of libicu-last / libicu65
-BuildRequires: libicu-devel >= 69
+# Upstream requires 4.0, we require 69.1 to ensure use of libicu69
+BuildRequires: libicu-devel = 69.1
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1166,6 +1169,8 @@ low-level PHP extension for the libsodium cryptographic library.
# security patches
%patch200 -p1 -b .bug81719
%patch201 -p1 -b .bug81720
+%patch202 -p1 -b .bug81727
+%patch203 -p1 -b .bug81726
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -2076,6 +2081,19 @@ fi
%endif
+%posttrans common
+cat << EOF
+=====================================================================
+
+ WARNING : PHP 7.3 have reached its "End of Life" in
+ December 2021. Even, if this package includes some of
+ the important security fix, backported from 7.4, the
+ UPGRADE to a maintained version is very strongly RECOMMENDED.
+
+=====================================================================
+EOF
+
+
%{!?_licensedir:%global license %%doc}
%files
@@ -2253,6 +2271,12 @@ fi
%changelog
+* Tue Sep 27 2022 Remi Collet <remi@remirepo.net> - 7.3.33-4
+- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
+- core: fix #81727 Don't mangle HTTP variable names that clash with ones
+ that have a specific semantic meaning. CVE-2022-31629
+- use oracle client library version 21.7
+
* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.3.33-3
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626