summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-03-05 19:19:08 +0100
committerRemi Collet <remi@remirepo.net>2019-03-05 19:19:08 +0100
commit9055369c12c9c571db369cc8ffa344043b11fdf2 (patch)
tree86daf902231743e1df0d8694139f55cf579cf84d
parent52bc7e266ac373fd5eff67d31691f058d550b863 (diff)
Update to 7.3.3 - http://www.php.net/releases/7_3_3.php
add upstream patch for OpenSSL 1.1.1b
-rw-r--r--failed.txt4
-rw-r--r--php-openssl111.patch29
-rw-r--r--php73.spec12
3 files changed, 41 insertions, 4 deletions
diff --git a/failed.txt b/failed.txt
index 1268e18..4190b86 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.3.3RC1 (2019-02-21)
+===== 7.3.3 (2019-03-07)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
@@ -12,6 +12,8 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/fc28x/build.log:Tests failed : 0
/var/lib/mock/fc29i/build.log:Tests failed : 0
/var/lib/mock/fc29x/build.log:Tests failed : 0
+/var/lib/mock/fc30i/build.log:Tests failed : 0
+/var/lib/mock/fc30x/build.log:Tests failed : 0
el6i
diff --git a/php-openssl111.patch b/php-openssl111.patch
new file mode 100644
index 0000000..ea43711
--- /dev/null
+++ b/php-openssl111.patch
@@ -0,0 +1,29 @@
+From 19a44ffb7be91344550fa700830b8e62a73031ba Mon Sep 17 00:00:00 2001
+From: Anatol Belski <ab@php.net>
+Date: Thu, 28 Feb 2019 12:48:47 +0100
+Subject: [PATCH] Sync with behavior change in OpenSSL 1.1.1b
+
+A behavior change in revealed by some openssl_decrypt() based test,
+where an encrypt API is used with a decrypt context. The EVP_Cipher*
+functions will automatically choose the right operation depending on the
+context passed.
+---
+ ext/openssl/openssl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
+index 871a30c..7df5072 100644
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -6494,7 +6494,7 @@ static int php_openssl_cipher_update(const EVP_CIPHER *cipher_type,
+ {
+ int i = 0;
+
+- if (mode->is_single_run_aead && !EVP_EncryptUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
++ if (mode->is_single_run_aead && !EVP_CipherUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
+ php_openssl_store_errors();
+ php_error_docref(NULL, E_WARNING, "Setting of data length failed");
+ return FAILURE;
+--
+2.1.4
+
diff --git a/php73.spec b/php73.spec
index 592a0a4..f7f9abc 100644
--- a/php73.spec
+++ b/php73.spec
@@ -119,13 +119,13 @@
%endif
%global upver 7.3.3
-%global rcver RC1
-%global lower RC1
+#global rcver RC1
+#global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -183,6 +183,7 @@ Patch48: php-7.3.3-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-openssl111.patch
# Security fixes (200+)
@@ -1137,6 +1138,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up
# security patches
@@ -2208,6 +2210,10 @@ fi
%changelog
+* Tue Mar 5 2019 Remi Collet <remi@remirepo.net> - 7.3.3-1
+- Update to 7.3.3 - http://www.php.net/releases/7_3_3.php
+- add upstream patch for OpenSSL 1.1.1b
+
* Fri Feb 22 2019 Remi Collet <remi@remirepo.net> - 7.3.3~RC1-2
- php-devel: drop dependency on libicu-devel