summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-16 14:18:11 +0200
committerRemi Collet <remi@remirepo.net>2019-05-16 14:18:11 +0200
commit62547fac6578f941b46463db5c0ac09396e825a5 (patch)
tree1ca7cc97e57e1fb2a7b9ea9f43fe0094d7b79e27
parent1658f9f5b44cfd861da45aa02bd8e9843a06e5c5 (diff)
add httpd and nginx configuration files for FPM in documentation
-rw-r--r--php73.spec21
1 files changed, 20 insertions, 1 deletions
diff --git a/php73.spec b/php73.spec
index d9f5983..1ddbd99 100644
--- a/php73.spec
+++ b/php73.spec
@@ -121,7 +121,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -1745,6 +1745,17 @@ install -D -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_httpd_confdir}/php.conf
%endif
%if %{with_httpd2410}
cat %{SOURCE11} >>$RPM_BUILD_ROOT%{_httpd_confdir}/php.conf
+%else
+mkdir _fpmdoc
+cat %{SOURCE1} %{SOURCE11} >_fpmdoc/httpd-php.conf
+cat << 'EOF' >_fpmdoc/README
+To use FPM with Apache HTTP server:
+- copy the httpd-php.conf to %{_httpd_confdir}
+
+Tu use FPM with NGINX web server:
+- copy the nginx-fpm.conf to %{_sysconfdir}/nginx/conf.d
+- copy the nginx-php.conf to %{_sysconfdir}/nginx/default.d
+EOF
%endif
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php.d
@@ -1824,6 +1835,9 @@ sed -e 's@127.0.0.1:9000@unix:/run/php-fpm/www.sock@' \
# Apache
sed -e 's@proxy:fcgi://127.0.0.1:9000@proxy:unix:/run/php-fpm/www.sock|fcgi://localhost@' \
-i $RPM_BUILD_ROOT%{_httpd_confdir}/php.conf
+%else
+install -D -m 644 %{SOURCE13} _fpmdoc/nginx-fpm.conf
+install -D -m 644 %{SOURCE14} _fpmdoc/nginx-php.conf
%endif
# Generate files lists and stub .ini files for each subpackage
@@ -2112,6 +2126,8 @@ fi
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/opcache
%if %{with_httpd2410}
%config(noreplace) %{_httpd_confdir}/php.conf
+%else
+%doc _fpmdoc/*
%endif
%config(noreplace) %{_sysconfdir}/php-fpm.conf
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
@@ -2213,6 +2229,9 @@ fi
%changelog
+* Thu May 16 2019 Remi Collet <remi@remirepo.net> - 7.3.6~RC1-3
+- add httpd and nginx configuration files for FPM in documentation
+
* Wed May 15 2019 Remi Collet <remi@remirepo.net> - 7.3.6~RC1-2
- update to 7.3.6RC1 (new tag)