summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-22 16:40:58 +0100
committerRemi Collet <remi@remirepo.net>2019-01-22 16:40:58 +0100
commit46060665ed6d9e236555dd78a905c4dfb8bfbe06 (patch)
tree27cc49619b6d86edc50112f6dd2a189781ece2fb
parent0d168ec8059fe4d4bc4f21501ad9cb57c9aaab6a (diff)
update to 7.3.2RC1
update system tzdata patch for timelib 2018.01
-rw-r--r--failed.txt4
-rw-r--r--php-7.3.2-systzdata-v17.patch (renamed from php-7.2.3-systzdata-v16.patch)38
-rw-r--r--php-bug77287.patch38
-rw-r--r--php73.spec26
4 files changed, 77 insertions, 29 deletions
diff --git a/failed.txt b/failed.txt
index 51ffa00..b6a622b 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.3.1 (2019-01-10)
+===== 7.3.2RC1 (2019-01-24)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
@@ -15,7 +15,7 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
el8x:
- buildroot issue with openssl under investigation
+ 5 buildroot issue with openssl under investigation
1 proc_open give erratic test results :(
diff --git a/php-7.2.3-systzdata-v16.patch b/php-7.3.2-systzdata-v17.patch
index e488beb..2ae754f 100644
--- a/php-7.2.3-systzdata-v16.patch
+++ b/php-7.3.2-systzdata-v17.patch
@@ -5,6 +5,7 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
+r17: adapt for timelib 2018.01 (in 7.3.2RC1)
r16: adapt for timelib 2017.06 (in 7.2.3RC1)
r15: adapt for timelib 2017.05beta7 (in 7.2.0RC1)
r14: improve check for valid tz file
@@ -27,9 +28,9 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
r2: add filesystem trawl to set up name alias index
r1: initial revision
-diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/lib/parse_tz.c
---- php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata 2018-02-13 20:18:34.000000000 +0100
-+++ php-7.2.3RC1/ext/date/lib/parse_tz.c 2018-02-14 06:14:23.484804852 +0100
+diff -up php-7.3.2RC1/ext/date/lib/parse_tz.c.systzdata php-7.3.2RC1/ext/date/lib/parse_tz.c
+--- php-7.3.2RC1/ext/date/lib/parse_tz.c.systzdata 2019-01-22 13:20:08.000000000 +0100
++++ php-7.3.2RC1/ext/date/lib/parse_tz.c 2019-01-22 14:30:46.655691222 +0100
@@ -25,8 +25,21 @@
#include "timelib.h"
#include "timelib_private.h"
@@ -52,7 +53,7 @@ diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/li
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
# if defined(__LITTLE_ENDIAN__)
-@@ -67,6 +80,11 @@ static int read_php_preamble(const unsig
+@@ -87,6 +100,11 @@ static int read_php_preamble(const unsig
{
uint32_t version;
@@ -64,7 +65,7 @@ diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/li
/* read ID */
version = (*tzf)[3] - '0';
*tzf += 4;
-@@ -374,7 +392,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
+@@ -411,7 +429,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
}
}
@@ -495,7 +496,7 @@ diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/li
{
int left = 0, right = tzdb->index_size - 1;
-@@ -400,9 +840,48 @@ static int seek_to_tz_position(const uns
+@@ -437,9 +877,48 @@ static int seek_to_tz_position(const uns
return 0;
}
@@ -544,7 +545,7 @@ diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/li
}
const timelib_tzdb_index_entry *timelib_timezone_identifiers_list(const timelib_tzdb *tzdb, int *count)
-@@ -414,7 +893,30 @@ const timelib_tzdb_index_entry *timelib_
+@@ -451,7 +930,30 @@ const timelib_tzdb_index_entry *timelib_
int timelib_timezone_id_is_valid(char *timezone, const timelib_tzdb *tzdb)
{
const unsigned char *tzf;
@@ -576,7 +577,7 @@ diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/li
}
static int skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
-@@ -456,12 +958,14 @@ static timelib_tzinfo* timelib_tzinfo_ct
+@@ -493,12 +995,14 @@ static timelib_tzinfo* timelib_tzinfo_ct
timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb, int *error_code)
{
const unsigned char *tzf;
@@ -592,11 +593,10 @@ diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/li
tmp = timelib_tzinfo_ctor(timezone);
version = read_preamble(&tzf, tmp, &type);
-@@ -484,6 +988,29 @@ timelib_tzinfo *timelib_parse_tzfile(cha
- timelib_tzinfo_dtor(tmp);
- return NULL;
+@@ -537,11 +1041,36 @@ timelib_tzinfo *timelib_parse_tzfile(cha
}
-+
+ skip_posix_string(&tzf, tmp);
+
+#ifdef HAVE_SYSTEM_TZDATA
+ if (memmap) {
+ const struct location_info *li;
@@ -619,10 +619,8 @@ diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/li
+ munmap(memmap, maplen);
+ } else {
+#endif
- if (version == 2 || version == 3) {
- if (!skip_64bit_preamble(&tzf, tmp)) {
- /* 64 bit preamble is not in place */
-@@ -501,6 +1028,9 @@ timelib_tzinfo *timelib_parse_tzfile(cha
+ if (type == TIMELIB_TZINFO_PHP) {
+ read_location(&tzf, tmp);
} else {
set_default_location_and_comments(&tzf, tmp);
}
@@ -632,10 +630,10 @@ diff -up php-7.2.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.2.3RC1/ext/date/li
} else {
*error_code = TIMELIB_ERROR_NO_SUCH_TIMEZONE;
tmp = NULL;
-diff -up php-7.2.3RC1/ext/date/lib/timelib.m4.systzdata php-7.2.3RC1/ext/date/lib/timelib.m4
---- php-7.2.3RC1/ext/date/lib/timelib.m4.systzdata 2018-02-13 20:18:34.000000000 +0100
-+++ php-7.2.3RC1/ext/date/lib/timelib.m4 2018-02-14 06:11:54.273089963 +0100
-@@ -81,3 +81,16 @@ io.h
+diff -up php-7.3.2RC1/ext/date/lib/timelib.m4.systzdata php-7.3.2RC1/ext/date/lib/timelib.m4
+--- php-7.3.2RC1/ext/date/lib/timelib.m4.systzdata 2019-01-22 13:20:08.000000000 +0100
++++ php-7.3.2RC1/ext/date/lib/timelib.m4 2019-01-22 13:47:07.807374084 +0100
+@@ -78,3 +78,16 @@ io.h
dnl Check for strtoll, atoll
AC_CHECK_FUNCS(strtoll atoll strftime gettimeofday)
diff --git a/php-bug77287.patch b/php-bug77287.patch
new file mode 100644
index 0000000..4df20d6
--- /dev/null
+++ b/php-bug77287.patch
@@ -0,0 +1,38 @@
+From 76760901fabf8ff53c8dfb4ddf7ca703c5a12b79 Mon Sep 17 00:00:00 2001
+From: Nikita Popov <nikita.ppv@gmail.com>
+Date: Tue, 22 Jan 2019 12:15:06 +0100
+Subject: [PATCH] Fixed bug #77287
+
+There may be an EXT_NOP opcode before the parameter list, we should
+skip over it.
+---
+ NEWS | 2 ++
+ ext/opcache/Optimizer/compact_literals.c | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/NEWS b/NEWS
+index 6265b1736c6d..656e4ab70eaa 100644
+--- a/NEWS
++++ b/NEWS
+@@ -61,6 +61,8 @@ PHP NEWS
+ (Nikita)
+ . Fixed bug #77361 (configure fails on 64-bit AIX when opcache enabled).
+ (Kevin Adler)
++ . Fixed bug #77287 (Opcache literal compaction is incompatible with EXT
++ opcodes). (Nikita)
+
+ - PCRE:
+ . Fixed bug #77338 (get_browser with empty string). (Nikita)
+diff --git a/ext/opcache/Optimizer/compact_literals.c b/ext/opcache/Optimizer/compact_literals.c
+index 10bdf540118e..fdab0068a4d5 100644
+--- a/ext/opcache/Optimizer/compact_literals.c
++++ b/ext/opcache/Optimizer/compact_literals.c
+@@ -810,7 +810,7 @@ void zend_optimizer_compact_literals(zend_op_array *op_array, zend_optimizer_ctx
+ Z_CACHE_SLOT_P(val) = op_array->cache_size;
+ op_array->cache_size += sizeof(zval);
+ }
+- } else if (opline->opcode != ZEND_RECV) {
++ } else if (opline->opcode != ZEND_RECV && opline->opcode != ZEND_EXT_NOP) {
+ break;
+ }
+ opline++;
diff --git a/php73.spec b/php73.spec
index 6c84a9a..27f7909 100644
--- a/php73.spec
+++ b/php73.spec
@@ -118,9 +118,9 @@
%global db_devel libdb-devel
%endif
-%global upver 7.3.1
-#global rcver RC1
-#global lower RC1
+%global upver 7.3.2
+%global rcver RC1
+%global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -167,7 +167,7 @@ Patch9: php-7.0.7-curl.patch
# Functional changes
Patch40: php-7.2.4-dlopen.patch
-Patch42: php-7.2.3-systzdata-v16.patch
+Patch42: php-7.3.2-systzdata-v17.patch
# See http://bugs.php.net/53436
Patch43: php-7.3.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -189,6 +189,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.0.10-datetests.patch
# WIP
+Patch400: php-bug77287.patch
BuildRequires: bzip2-devel, curl-devel >= 7.9
BuildRequires: httpd-devel >= 2.0.46-1, pam-devel
@@ -1120,7 +1121,7 @@ low-level PHP extension for the libsodium cryptographic library.
%endif
%patch40 -p1 -b .dlopen
-%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 6
%patch42 -p1 -b .systzdata
%endif
%patch43 -p1 -b .headers
@@ -1142,6 +1143,7 @@ low-level PHP extension for the libsodium cryptographic library.
%endif
# WIP patch
+%patch400 -p1 -b .bug77287
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -1170,6 +1172,12 @@ mkdir build-cgi build-apache build-embedded \
rm ext/date/tests/timezone_location_get.phpt
rm ext/date/tests/timezone_version_get.phpt
rm ext/date/tests/timezone_version_get_basic1.phpt
+%if 0%{?fedora} < 28
+# need tzdata 2018i
+rm ext/date/tests/bug33414-1.phpt
+rm ext/date/tests/bug33415-2.phpt
+rm ext/date/tests/date_modify-1.phpt
+%endif
# Should be skipped but fails sometime
rm ext/standard/tests/file/file_get_contents_error001.phpt
# fails sometime
@@ -1353,7 +1361,7 @@ ln -sf ../configure
--with-layout=GNU \
--with-kerberos \
--with-libxml-dir=%{_prefix} \
-%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 6
--with-system-tzdata \
%endif
--with-mhash \
@@ -1944,7 +1952,7 @@ rm -f README.{Zeus,QNX,CVS-RULES}
%pre common
-%if %{?fedora}%{!?fedora:99} < 25
+%if %{?fedora}%{!?fedora:99} < 28
echo -e "WARNING : Fedora %{fedora} is now EOL :"
echo -e "You should consider upgrading to a supported release.\n"
%endif
@@ -2198,6 +2206,10 @@ fi
%changelog
+* Tue Jan 22 2019 Remi Collet <remi@remirepo.net> - 7.3.2~RC1-1
+- update to 7.3.2RC1
+- update system tzdata patch for timelib 2018.01
+
* Tue Jan 8 2019 Remi Collet <remi@remirepo.net> - 7.3.1-1
- Update to 7.3.1 - http://www.php.net/releases/7_3_1.php