summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt9
-rw-r--r--php72.spec8
2 files changed, 15 insertions, 2 deletions
diff --git a/failed.txt b/failed.txt
index 404658e..8c0e3db 100644
--- a/failed.txt
+++ b/failed.txt
@@ -13,8 +13,17 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/fc27x/build.log:Tests failed : 0
/var/lib/mock/fc28i/build.log:Tests failed : 0
/var/lib/mock/fc28x/build.log:Tests failed : 0
+/var/lib/mock/fc29i/build.log:Tests failed : 4
+/var/lib/mock/fc29x/build.log:Tests failed : 2
+fc29i:
+ 5 zend_dval_to_lval preserves low bits (32 bit long) [Zend/tests/dval_to_lval_32.phpt]
+ 5 testing integer underflow (32bit) [Zend/tests/int_underflow_32bit.phpt]
+
+fc29i, fc29x:
+ 5 security_level setting to prohibit cert [ext/openssl/tests/stream_security_level.phpt]
+ 5 TLS server rate-limits client-initiated renegotiation [ext/openssl/tests/stream_server_reneg_limit.phpt]
1 proc_open give erratic test results :(
diff --git a/php72.spec b/php72.spec
index 92b93f5..9414471 100644
--- a/php72.spec
+++ b/php72.spec
@@ -117,7 +117,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -1253,9 +1253,10 @@ touch configure.ac
%if %{with_debug}
LDFLAGS="-fsanitize=address"
export LDFLAGS
-CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign -fsanitize=address -ggdb"
+CFLAGS=$(echo $RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign -fsanitize=address -ggdb | sed 's/-mstackrealign//')
%else
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign"
+CFLAGS=$(echo $RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign | sed 's/-mstackrealign//')
%endif
export CFLAGS
@@ -2142,6 +2143,9 @@ fi
%changelog
+* Wed Aug 22 2018 Remi Collet <remi@remirepo.net> - 7.2.9-2
+- drop -mstackrealign option, workaround to #1593144
+
* Wed Aug 15 2018 Remi Collet <remi@remirepo.net> - 7.2.9-1
- Update to 7.2.9 - http://www.php.net/releases/7_2_9.php