summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt6
-rw-r--r--php-bug78297.patch49
-rw-r--r--php72.spec7
3 files changed, 8 insertions, 54 deletions
diff --git a/failed.txt b/failed.txt
index 01c7d45..1599cc8 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.2.21RC1 (2019-07-18)
+===== 7.2.21 (2019-08-01)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
@@ -8,10 +8,12 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el8x73/build.logTests failed : 16
/var/lib/mock/fc28i/build.log:Tests failed : 0
/var/lib/mock/fc28x/build.log:Tests failed : 0
-/var/lib/mock/fc29i/build.log:Tests failed : 1
+/var/lib/mock/fc29i/build.log:Tests failed : 2
/var/lib/mock/fc29x/build.log:Tests failed : 1
+fc29i
+ 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
fc29i, fc29x:
5 TLS server rate-limits client-initiated renegotiation [ext/openssl/tests/stream_server_reneg_limit.phpt]
el8x:
diff --git a/php-bug78297.patch b/php-bug78297.patch
deleted file mode 100644
index facf639..0000000
--- a/php-bug78297.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 8a19fe29de77d7477d59db472dd6aadabd5ac249 Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikita.ppv@gmail.com>
-Date: Tue, 16 Jul 2019 11:08:27 +0200
-Subject: [PATCH] Fixed bug #78297
-
----
- NEWS | 2 ++
- sapi/phpdbg/phpdbg_list.c | 1 +
- sapi/phpdbg/tests/bug78297.phpt | 16 ++++++++++++++++
- 3 files changed, 19 insertions(+)
- create mode 100644 sapi/phpdbg/tests/bug78297.phpt
-
-diff --git a/sapi/phpdbg/phpdbg_list.c b/sapi/phpdbg/phpdbg_list.c
-index aab641c..a9b0f4b 100644
---- a/sapi/phpdbg/phpdbg_list.c
-+++ b/sapi/phpdbg/phpdbg_list.c
-@@ -248,6 +248,7 @@ zend_op_array *phpdbg_compile_file(zend_file_handle *file, int type) {
- } else {
- zend_message_dispatcher(ZMSG_FAILED_INCLUDE_FOPEN, file->filename);
- }
-+ return NULL;
- }
-
- data.buf = estrndup(bufptr, len);
-diff --git a/sapi/phpdbg/tests/bug78297.phpt b/sapi/phpdbg/tests/bug78297.phpt
-new file mode 100644
-index 0000000..47b13ad
---- /dev/null
-+++ b/sapi/phpdbg/tests/bug78297.phpt
-@@ -0,0 +1,16 @@
-+--TEST--
-+Bug #78297: Include unexistent file memory leak
-+--PHPDBG--
-+r
-+q
-+--FILE--
-+<?php
-+include "does_not_exist.php";
-+--EXPECTF--
-+[Successful compilation of %s]
-+prompt>
-+Warning: include(%s): failed to open stream: No such file or directory in %s on line %d
-+
-+Warning: include(): Failed opening 'does_not_exist.php' for inclusion (include_path=%s) in %s on line %d
-+[Script ended normally]
-+prompt>
---
-2.1.4
-
diff --git a/php72.spec b/php72.spec
index 1b618ba..3f894cd 100644
--- a/php72.spec
+++ b/php72.spec
@@ -117,7 +117,7 @@
%endif
%global upver 7.2.21
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -182,7 +182,6 @@ Patch49: php-7.2.16-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-bug78297.patch
# Security fixes (200+)
@@ -1108,7 +1107,6 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .78297
# security patches
@@ -2200,6 +2198,9 @@ fi
%changelog
+* Tue Jul 30 2019 Remi Collet <remi@remirepo.net> - 7.2.21-1
+- Update to 7.2.21 - http://www.php.net/releases/7_2_21.php
+
* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 7.2.21~RC1-1
- update to 7.2.21RC1
- add upstream patch for #78297