summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt4
-rw-r--r--php-bug78297.patch49
-rw-r--r--php72.spec10
3 files changed, 58 insertions, 5 deletions
diff --git a/failed.txt b/failed.txt
index 89002cf..01c7d45 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.2.20 (2019-07-04)
+===== 7.2.21RC1 (2019-07-18)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
@@ -6,8 +6,6 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/el8x73/build.logTests failed : 16
-/var/lib/mock/fc27i/build.log:Tests failed : 0
-/var/lib/mock/fc27x/build.log:Tests failed : 0
/var/lib/mock/fc28i/build.log:Tests failed : 0
/var/lib/mock/fc28x/build.log:Tests failed : 0
/var/lib/mock/fc29i/build.log:Tests failed : 1
diff --git a/php-bug78297.patch b/php-bug78297.patch
new file mode 100644
index 0000000..facf639
--- /dev/null
+++ b/php-bug78297.patch
@@ -0,0 +1,49 @@
+From 8a19fe29de77d7477d59db472dd6aadabd5ac249 Mon Sep 17 00:00:00 2001
+From: Nikita Popov <nikita.ppv@gmail.com>
+Date: Tue, 16 Jul 2019 11:08:27 +0200
+Subject: [PATCH] Fixed bug #78297
+
+---
+ NEWS | 2 ++
+ sapi/phpdbg/phpdbg_list.c | 1 +
+ sapi/phpdbg/tests/bug78297.phpt | 16 ++++++++++++++++
+ 3 files changed, 19 insertions(+)
+ create mode 100644 sapi/phpdbg/tests/bug78297.phpt
+
+diff --git a/sapi/phpdbg/phpdbg_list.c b/sapi/phpdbg/phpdbg_list.c
+index aab641c..a9b0f4b 100644
+--- a/sapi/phpdbg/phpdbg_list.c
++++ b/sapi/phpdbg/phpdbg_list.c
+@@ -248,6 +248,7 @@ zend_op_array *phpdbg_compile_file(zend_file_handle *file, int type) {
+ } else {
+ zend_message_dispatcher(ZMSG_FAILED_INCLUDE_FOPEN, file->filename);
+ }
++ return NULL;
+ }
+
+ data.buf = estrndup(bufptr, len);
+diff --git a/sapi/phpdbg/tests/bug78297.phpt b/sapi/phpdbg/tests/bug78297.phpt
+new file mode 100644
+index 0000000..47b13ad
+--- /dev/null
++++ b/sapi/phpdbg/tests/bug78297.phpt
+@@ -0,0 +1,16 @@
++--TEST--
++Bug #78297: Include unexistent file memory leak
++--PHPDBG--
++r
++q
++--FILE--
++<?php
++include "does_not_exist.php";
++--EXPECTF--
++[Successful compilation of %s]
++prompt>
++Warning: include(%s): failed to open stream: No such file or directory in %s on line %d
++
++Warning: include(): Failed opening 'does_not_exist.php' for inclusion (include_path=%s) in %s on line %d
++[Script ended normally]
++prompt>
+--
+2.1.4
+
diff --git a/php72.spec b/php72.spec
index 2244ae5..1b618ba 100644
--- a/php72.spec
+++ b/php72.spec
@@ -116,8 +116,8 @@
%global db_devel libdb-devel
%endif
-%global upver 7.2.20
-#global rcver RC3
+%global upver 7.2.21
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -182,6 +182,7 @@ Patch49: php-7.2.16-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-bug78297.patch
# Security fixes (200+)
@@ -1107,6 +1108,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .78297
# security patches
@@ -2198,6 +2200,10 @@ fi
%changelog
+* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 7.2.21~RC1-1
+- update to 7.2.21RC1
+- add upstream patch for #78297
+
* Tue Jul 2 2019 Remi Collet <remi@remirepo.net> - 7.2.20-1
- Update to 7.2.20 - http://www.php.net/releases/7_2_20.php
- disable opcache.huge_code_pages in default configuration