summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt2
-rw-r--r--php-7.2.3-fixheader.patch12
-rw-r--r--php-7.2.4-dlopen.patch (renamed from php-7.1.3-dlopen.patch)18
-rw-r--r--php-7.2.4-fixheader.patch12
-rw-r--r--php72.spec15
5 files changed, 31 insertions, 28 deletions
diff --git a/failed.txt b/failed.txt
index 9e031ff..4a0bb32 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.2.3 (2018-03-01)
+===== 7.2.4RC1 (2018-03-15)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
diff --git a/php-7.2.3-fixheader.patch b/php-7.2.3-fixheader.patch
deleted file mode 100644
index 076eead..0000000
--- a/php-7.2.3-fixheader.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up php-7.2.3RC1/configure.ac.fixheader php-7.2.3RC1/configure.ac
---- php-7.2.3RC1/configure.ac.fixheader 2018-02-14 06:09:37.792429866 +0100
-+++ php-7.2.3RC1/configure.ac 2018-02-14 06:10:33.755701362 +0100
-@@ -1272,7 +1272,7 @@ EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PR
- PHP_BUILD_DATE=`date --utc --date="@${SOURCE_DATE_EPOCH:-$(date +%s)}" +%Y-%m-%d`
- AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
-
--PHP_UNAME=`uname -a | xargs`
-+PHP_UNAME=`uname | xargs`
- AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
- PHP_OS=`uname | xargs`
- AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])
diff --git a/php-7.1.3-dlopen.patch b/php-7.2.4-dlopen.patch
index cd35dc0..3c76474 100644
--- a/php-7.1.3-dlopen.patch
+++ b/php-7.2.4-dlopen.patch
@@ -1,19 +1,19 @@
-diff -up php-7.1.3RC1/sapi/litespeed/lsapilib.c.dlopen php-7.1.3RC1/sapi/litespeed/lsapilib.c
---- php-7.1.3RC1/sapi/litespeed/lsapilib.c.dlopen 2017-02-28 10:12:34.000000000 +0100
-+++ php-7.1.3RC1/sapi/litespeed/lsapilib.c 2017-02-28 10:23:11.384521740 +0100
-@@ -616,7 +616,7 @@ static int (*fp_lve_leave)(struct liblve
+diff -up php-7.2.4RC1/sapi/litespeed/lsapilib.c.dlopen php-7.2.4RC1/sapi/litespeed/lsapilib.c
+--- php-7.2.4RC1/sapi/litespeed/lsapilib.c.dlopen 2018-03-13 12:40:25.330885880 +0100
++++ php-7.2.4RC1/sapi/litespeed/lsapilib.c 2018-03-13 12:41:35.797251042 +0100
+@@ -755,7 +755,7 @@ static int (*fp_lve_leave)(struct liblve
static int (*fp_lve_jail)( struct passwd *, char *) = NULL;
- static int lsapi_load_lve_lib()
+ static int lsapi_load_lve_lib(void)
{
- s_liblve = dlopen("liblve.so.0", RTLD_LAZY);
+ s_liblve = dlopen("liblve.so.0", RTLD_NOW);
if (s_liblve)
{
fp_lve_is_available = dlsym(s_liblve, "lve_is_available");
-diff -up php-7.1.3RC1/Zend/zend_portability.h.dlopen php-7.1.3RC1/Zend/zend_portability.h
---- php-7.1.3RC1/Zend/zend_portability.h.dlopen 2017-02-28 10:23:11.384521740 +0100
-+++ php-7.1.3RC1/Zend/zend_portability.h 2017-02-28 10:26:08.960308560 +0100
-@@ -146,11 +146,11 @@
+diff -up php-7.2.4RC1/Zend/zend_portability.h.dlopen php-7.2.4RC1/Zend/zend_portability.h
+--- php-7.2.4RC1/Zend/zend_portability.h.dlopen 2018-03-13 12:33:38.000000000 +0100
++++ php-7.2.4RC1/Zend/zend_portability.h 2018-03-13 12:40:25.330885880 +0100
+@@ -144,11 +144,11 @@
# endif
# if defined(RTLD_GROUP) && defined(RTLD_WORLD) && defined(RTLD_PARENT)
diff --git a/php-7.2.4-fixheader.patch b/php-7.2.4-fixheader.patch
new file mode 100644
index 0000000..52a4121
--- /dev/null
+++ b/php-7.2.4-fixheader.patch
@@ -0,0 +1,12 @@
+diff -up php-7.2.4RC1/configure.ac.fixheader php-7.2.4RC1/configure.ac
+--- php-7.2.4RC1/configure.ac.fixheader 2018-03-13 12:42:47.594623100 +0100
++++ php-7.2.4RC1/configure.ac 2018-03-13 12:43:35.591871825 +0100
+@@ -1275,7 +1275,7 @@ PHP_BUILD_DATE=`date -u +%Y-%m-%d`
+ fi
+ AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
+
+-PHP_UNAME=`uname -a | xargs`
++PHP_UNAME=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
+ PHP_OS=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])
diff --git a/php72.spec b/php72.spec
index 60a1544..d6ff511 100644
--- a/php72.spec
+++ b/php72.spec
@@ -111,13 +111,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.2.3
-#global rcver RC1
+%global upver 7.2.4
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -157,14 +157,14 @@ Patch8: php-7.2.0-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
-Patch40: php-7.1.3-dlopen.patch
+Patch40: php-7.2.4-dlopen.patch
Patch42: php-7.2.3-systzdata-v16.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.2.3-ldap_r.patch
# Make php_config.h constant across builds
-Patch46: php-7.2.3-fixheader.patch
+Patch46: php-7.2.4-fixheader.patch
# drop "Configure command" from phpinfo output
Patch47: php-5.6.3-phpinfo.patch
@@ -1041,7 +1041,7 @@ Group: System Environment/Libraries
BuildRequires: pkgconfig(libsodium) >= 1.0.13
Requires: php-common%{?_isa} = %{version}-%{release}
-Obsoletes: php-pecl-libsodium2 < 7
+Obsoletes: php-pecl-libsodium2 < 3
Provides: php-pecl(libsodium) = %{version}
Provides: php-pecl(libsodium)%{?_isa} = %{version}
%if 0%{?rhel}
@@ -2135,6 +2135,9 @@ fi
%changelog
+* Tue Mar 13 2018 Remi Collet <remi@remirepo.net> - 7.2.4~RC1-1
+- update to 7.2.4RC1
+
* Fri Mar 2 2018 Remi Collet <remi@remirepo.net> - 7.2.3-2
- devel: drop dependency on devtoolset