summaryrefslogtreecommitdiffstats
path: root/php72.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-27 16:30:09 +0200
committerRemi Collet <remi@php.net>2022-09-27 16:30:09 +0200
commit585ac93a1d4b6b85ed5e3712aba635e687ce0589 (patch)
tree5d5057f74385b6989303eda875159e9593386857 /php72.spec
parenteb855c9f47558a4511ef09864858aa3d5a6c6244 (diff)
phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
core: fix #81727 Don't mangle HTTP variable names that clash with ones that have a specific semantic meaning. CVE-2022-31629 use oracle client library version 21.7
Diffstat (limited to 'php72.spec')
-rw-r--r--php72.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php72.spec b/php72.spec
index 1b2e3a8..53f067d 100644
--- a/php72.spec
+++ b/php72.spec
@@ -25,7 +25,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.6
+%global oraclever 21.7
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -110,7 +110,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 11%{?dist}
+Release: 12%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -187,6 +187,8 @@ Patch206: php-bug81026.patch
Patch207: php-bug79971.patch
Patch208: php-bug81719.patch
Patch209: php-bug81720.patch
+Patch210: php-bug81727.patch
+Patch211: php-bug81726.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -318,7 +320,6 @@ Group: Development/Languages
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
Requires: php-common%{?_isa} = %{version}-%{release}
-Requires(pre): /usr/sbin/useradd
%if %{with_systemd}
BuildRequires: systemd-devel
%{?systemd_requires}
@@ -339,6 +340,8 @@ Requires(pre): httpd-filesystem
Requires: httpd-filesystem >= 2.4.10
# php engine for Apache httpd webserver
Provides: php(httpd)
+%else
+Requires(pre): /usr/sbin/useradd
%endif
%if %{with_nginx}
# for /etc/nginx ownership
@@ -986,8 +989,8 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-# Upstream requires 4.0, we require 50 to ensure use of libicu-last / libicu62
-BuildRequires: libicu-devel >= 69
+# Upstream requires 4.0, we require 69.1 to ensure use of libicu69
+BuildRequires: libicu-devel = 69.1
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1128,6 +1131,8 @@ low-level PHP extension for the libsodium cryptographic library.
%patch207 -p1 -b .bug79971
%patch208 -p1 -b .bug81719
%patch209 -p1 -b .bug81720
+%patch210 -p1 -b .bug81727
+%patch211 -p1 -b .bug81726
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -2241,6 +2246,12 @@ EOF
%changelog
+* Tue Sep 27 2022 Remi Collet <remi@remirepo.net> - 7.2.34-12
+- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
+- core: fix #81727 Don't mangle HTTP variable names that clash with ones
+ that have a specific semantic meaning. CVE-2022-31629
+- use oracle client library version 21.7
+
* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.2.34-11
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626