summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-16 13:37:25 +0100
committerRemi Collet <remi@remirepo.net>2018-01-16 13:37:25 +0100
commit7c2c18a4ee1ef2175d50fe299a3a97ccf9f89f62 (patch)
treeb3b5a0187c865aad283fecd4038c44e84d156f84
parentddc1347ec42e881716aa4be8c49f35bd5028b56a (diff)
v7.2.2RC1
-rw-r--r--failed.txt10
-rw-r--r--php-7.2.0-fixheader.patch15
-rw-r--r--php-7.2.2-fixheader.patch12
-rw-r--r--php72.spec19
4 files changed, 31 insertions, 25 deletions
diff --git a/failed.txt b/failed.txt
index 63e7994..b483e59 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,18 +1,22 @@
-===== 7.2.1 (2018-01-04)
+===== 7.2.2RC1 (2018-01-18)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el6i/build.log:Tests failed : 0
/var/lib/mock/el6x/build.log:Tests failed : 0
-/var/lib/mock/el7x/build.log:Tests failed : 0
+/var/lib/mock/el7x/build.log:Tests failed : 1
/var/lib/mock/fc25i/build.log:Tests failed : 0
/var/lib/mock/fc25x/build.log:Tests failed : 0
/var/lib/mock/fc26i/build.log:Tests failed : 0
/var/lib/mock/fc26x/build.log:Tests failed : 0
-/var/lib/mock/fc27i/build.log:Tests failed : 0
+/var/lib/mock/fc27i/build.log:Tests failed : 1
/var/lib/mock/fc27x/build.log:Tests failed : 0
+el7x:
+ 1 php://input is empty when enable_post_data_reading=Off [tests/basic/bug67198.phpt]
+fc27i:
+ 1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
1 proc_open give erratic test results :(
diff --git a/php-7.2.0-fixheader.patch b/php-7.2.0-fixheader.patch
deleted file mode 100644
index bc822fd..0000000
--- a/php-7.2.0-fixheader.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- php-7.2.0/configure.ac.fixheader 2017-04-12 09:42:21.510812285 +0200
-+++ php-7.2.0/configure.ac 2017-04-12 09:43:45.055224385 +0200
-@@ -1263,10 +1263,10 @@
- EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
- EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"
-
--PHP_BUILD_DATE=`date '+%Y-%m-%d'`
-+PHP_BUILD_DATE=`date '+%Y-%m-%d' -r $srcdir/NEWS`
- AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
-
--PHP_UNAME=`uname -a | xargs`
-+PHP_UNAME=`uname | xargs`
- AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
- PHP_OS=`uname | xargs`
- AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])
diff --git a/php-7.2.2-fixheader.patch b/php-7.2.2-fixheader.patch
new file mode 100644
index 0000000..dc2a080
--- /dev/null
+++ b/php-7.2.2-fixheader.patch
@@ -0,0 +1,12 @@
+diff -up php-7.2.2RC1/configure.ac.fixheader php-7.2.2RC1/configure.ac
+--- php-7.2.2RC1/configure.ac.fixheader 2018-01-16 09:14:15.231218443 +0100
++++ php-7.2.2RC1/configure.ac 2018-01-16 09:17:21.740382942 +0100
+@@ -1272,7 +1272,7 @@ EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PR
+ PHP_BUILD_DATE=`date --date="@${SOURCE_DATE_EPOCH:-$(date +%s)}" +%Y-%m-%d`
+ AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
+
+-PHP_UNAME=`uname -a | xargs`
++PHP_UNAME=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
+ PHP_OS=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])
diff --git a/php72.spec b/php72.spec
index e0af4cb..1302dac 100644
--- a/php72.spec
+++ b/php72.spec
@@ -111,13 +111,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.2.1
-#global rcver RC1
+%global upver 7.2.2
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -164,7 +164,7 @@ Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-5.6.3-ldap_r.patch
# Make php_config.h constant across builds
-Patch46: php-7.2.0-fixheader.patch
+Patch46: php-7.2.2-fixheader.patch
# drop "Configure command" from phpinfo output
Patch47: php-5.6.3-phpinfo.patch
@@ -849,7 +849,6 @@ Group: Development/Languages
License: PHP
BuildRequires: %{db_devel}
BuildRequires: tokyocabinet-devel
-BuildRequires: gdbm-devel
BuildRequires: lmdb-devel
Requires: php-common%{?_isa} = %{version}-%{release}
%if 0%{?rhel}
@@ -1226,6 +1225,9 @@ fi
%build
%{?dtsenable}
+# Set build date from https://reproducible-builds.org/specs/source-date-epoch/
+export SOURCE_DATE_EPOCH=$(date +%s -r NEWS)
+
# aclocal workaround - to be improved
cat $(aclocal --print-ac-dir)/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 >>aclocal.m4
@@ -1346,7 +1348,6 @@ build --libdir=%{_libdir}/php \
--with-bz2=shared \
--enable-ctype=shared \
--enable-dba=shared --with-db4=%{_prefix} \
- --with-gdbm=%{_prefix} \
--with-tcadb=%{_prefix} \
--with-lmdb=%{_prefix} \
--enable-exif=shared \
@@ -1498,7 +1499,6 @@ build --includedir=%{_includedir}/php-zts \
--with-bz2=shared \
--enable-ctype=shared \
--enable-dba=shared --with-db4=%{_prefix} \
- --with-gdbm=%{_prefix} \
--with-tcadb=%{_prefix} \
--with-lmdb=%{_prefix} \
--with-gettext=shared \
@@ -2123,6 +2123,11 @@ fi
%changelog
+* Tue Jan 16 2018 Remi Collet <remi@remirepo.net> - 7.2.2~RC1-1
+- update to 7.2.2RC1
+- define SOURCE_DATE_EPOCH for reproducible build
+- dba: drop gdbm support
+
* Wed Jan 10 2018 Remi Collet <remi@remirepo.net> - 7.2.1-2
- rebuild for gdbm 1.14 BC break (see rhbz#1532997)