summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-28 20:47:38 +0100
committerRemi Collet <remi@remirepo.net>2017-11-28 20:47:38 +0100
commit1e4968469c2fa45d4fbaf4e4e379d3097e59d1e4 (patch)
treed53b0769aa017bf1c1073f0daab00903946bf511
parentcd71ce7970936ea0c2669c9102f5e610b30109be (diff)
refresh patch for https://bugs.php.net/75514
-rw-r--r--0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch34
-rw-r--r--php72.spec5
2 files changed, 38 insertions, 1 deletions
diff --git a/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch b/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
index 23743fe..c963933 100644
--- a/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
+++ b/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
@@ -53,3 +53,37 @@ index 0000000..af97b6d
--
2.9.5
+From 2b071028973782ed87e7038e56d47e9897be804a Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Tue, 28 Nov 2017 17:42:43 +0100
+Subject: [PATCH] better fix for #75514
+
+---
+ ext/standard/mt_rand.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext/standard/mt_rand.c b/ext/standard/mt_rand.c
+index 0a76ab8..46f52db 100644
+--- a/ext/standard/mt_rand.c
++++ b/ext/standard/mt_rand.c
+@@ -260,7 +260,7 @@ PHPAPI zend_long php_mt_rand_range(zend_long min, zend_long max)
+ * rand() allows min > max, mt_rand does not */
+ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
+ {
+- uint32_t n;
++ int64_t n;
+
+ if (BG(mt_rand_mode) == MT_RAND_MT19937) {
+ return php_mt_rand_range(min, max);
+@@ -268,7 +268,7 @@ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
+
+ /* Legacy mode deliberately not inside php_mt_rand_range()
+ * to prevent other functions being affected */
+- n = php_mt_rand() >> 1;
++ n = (int64_t)php_mt_rand() >> 1;
+ RAND_RANGE_BADSCALING(n, min, max, PHP_MT_RAND_MAX);
+
+ return n;
+--
+2.1.4
+
diff --git a/php72.spec b/php72.spec
index 3bf4682..d76a5be 100644
--- a/php72.spec
+++ b/php72.spec
@@ -117,7 +117,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -2125,6 +2125,9 @@ fi
%changelog
+* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 7.2.0-2
+- refresh patch for https://bugs.php.net/75514
+
* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 7.2.0-1
- update to 7.2.0 GA