summaryrefslogtreecommitdiffstats
path: root/php71.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php71.spec')
-rw-r--r--php71.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php71.spec b/php71.spec
index e9bf0e7..71fd34e 100644
--- a/php71.spec
+++ b/php71.spec
@@ -26,7 +26,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.6
+%global oraclever 21.7
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -109,7 +109,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 20%{?dist}
+Release: 21%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -201,6 +201,8 @@ Patch228: php-bug81026.patch
Patch229: php-bug79971.patch
Patch230: php-bug81719.patch
Patch231: php-bug81720.patch
+Patch232: php-bug81727.patch
+Patch233: php-bug81726.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -324,7 +326,6 @@ Group: Development/Languages
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
Requires: php-common%{?_isa} = %{version}-%{release}
-Requires(pre): /usr/sbin/useradd
%if %{with_systemd}
BuildRequires: systemd-devel
%{?systemd_requires}
@@ -345,6 +346,8 @@ Requires(pre): httpd-filesystem
Requires: httpd-filesystem >= 2.4.10
# php engine for Apache httpd webserver
Provides: php(httpd)
+%else
+Requires(pre): /usr/sbin/useradd
%endif
%if %{with_nginx}
# for /etc/nginx ownership
@@ -949,8 +952,8 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-# Upstream requires 4.0, we require 50 to ensure use of libicu-last
-BuildRequires: libicu-devel >= 69
+# Upstream requires 4.0, we require 69.1 to ensure use of libicu69
+BuildRequires: libicu-devel = 69.1
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl, php70u-intl, php70w-intl, php71u-intl, php71w-intl
%endif
@@ -1084,6 +1087,8 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch229 -p1 -b .bug79971
%patch230 -p1 -b .bug81719
%patch231 -p1 -b .bug81720
+%patch232 -p1 -b .bug81727
+%patch233 -p1 -b .bug81726
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -2158,6 +2163,12 @@ EOF
%changelog
+* Tue Sep 27 2022 Remi Collet <remi@remirepo.net> - 7.1.33-21
+- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
+- core: fix #81727 Don't mangle HTTP variable names that clash with ones
+ that have a specific semantic meaning. CVE-2022-31629
+- use oracle client library version 21.7
+
* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.1.33-20
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626