summaryrefslogtreecommitdiffstats
path: root/php71.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php71.spec')
-rw-r--r--php71.spec24
1 files changed, 14 insertions, 10 deletions
diff --git a/php71.spec b/php71.spec
index 0b9da3f..e9bf0e7 100644
--- a/php71.spec
+++ b/php71.spec
@@ -26,7 +26,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.3
+%global oraclever 21.6
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -109,7 +109,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 19%{?dist}
+Release: 20%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -199,6 +199,8 @@ Patch226: php-bug76450.patch
Patch227: php-bug81211.patch
Patch228: php-bug81026.patch
Patch229: php-bug79971.patch
+Patch230: php-bug81719.patch
+Patch231: php-bug81720.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -787,12 +789,7 @@ License: PHP and BSD
%endif
Requires: php-common%{?_isa} = %{version}-%{release}
%if %{with_libgd}
-BuildRequires: gd-devel >= 2.1.1
-%if 0%{?fedora} <= 19 && 0%{?rhel} <= 7
-Requires: gd-last%{?_isa} >= 2.1.1
-%else
-Requires: gd%{?_isa} >= 2.1.1
-%endif
+BuildRequires: gd-devel >= 2.3.3
%else
# Required to build the bundled GD library
BuildRequires: libjpeg-devel
@@ -1085,6 +1082,8 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch227 -p1 -b .bug81211
%patch228 -p1 -b .bug81026
%patch229 -p1 -b .bug79971
+%patch230 -p1 -b .bug81719
+%patch231 -p1 -b .bug81720
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -1877,7 +1876,7 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
%endif
< %{SOURCE3} > macros.php
%if 0%{?fedora} >= 24
-echo '%pecl_xmldir %{_localstatedir}/lib/php/peclxml' >>macros.php
+echo '%%pecl_xmldir %{_localstatedir}/lib/php/peclxml' >>macros.php
%endif
install -m 644 -D macros.php \
$RPM_BUILD_ROOT%{macrosdir}/macros.php
@@ -1976,7 +1975,7 @@ cat << EOF
WARNING : PHP 7.1 have reached its "End of Life" in
December 2019. Even, if this package includes some of
- the important security fix, backported from 7.3, the
+ the important security fix, backported from 7.4, the
UPGRADE to a maintained version is very strongly RECOMMENDED.
=====================================================================
@@ -2159,6 +2158,11 @@ EOF
%changelog
+* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.1.33-20
+- use oracle client library version 21.6
+- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626
+- pgsql: fix #81720: Uninitialized array in pg_query_params(). CVE-2022-31625
+
* Mon Nov 15 2021 Remi Collet <remi@remirepo.net> - 7.1.33-19
- Fix #79971 special character is breaking the path in xml function
CVE-2021-21707