summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt6
-rw-r--r--php-imap.patch70
-rw-r--r--php71.spec9
3 files changed, 7 insertions, 78 deletions
diff --git a/failed.txt b/failed.txt
index eb9d047..9ceedfa 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.1.25 (2018-12-06)
+===== 7.1.26 (2019-01-10)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
@@ -7,12 +7,10 @@ $ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/fc26i/build.log:Tests failed : 0
/var/lib/mock/fc26x/build.log:Tests failed : 0
-/var/lib/mock/fc27i/build.log:Tests failed : 1
+/var/lib/mock/fc27i/build.log:Tests failed : 0
/var/lib/mock/fc27x/build.log:Tests failed : 0
-fc27i
- 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
1 proc_open give erratic test results :(
diff --git a/php-imap.patch b/php-imap.patch
deleted file mode 100644
index c726a3a..0000000
--- a/php-imap.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From d8765852e0400ee2ce8ae9e2177c42731d4539d8 Mon Sep 17 00:00:00 2001
-From: Stanislav Malyshev <stas@php.net>
-Date: Wed, 28 Nov 2018 15:45:51 -0800
-Subject: [PATCH] Add DISPLAY_INI_ENTRIES for imap
-
----
- ext/imap/php_imap.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/ext/imap/php_imap.c b/ext/imap/php_imap.c
-index f6feebe9f769..a23e84c08521 100644
---- a/ext/imap/php_imap.c
-+++ b/ext/imap/php_imap.c
-@@ -1153,6 +1153,8 @@ PHP_MINFO_FUNCTION(imap)
- php_info_print_table_row(2, "Kerberos Support", "enabled");
- #endif
- php_info_print_table_end();
-+
-+ DISPLAY_INI_ENTRIES();
- }
- /* }}} */
-
-From 7edc639b9ff1c3576773d79d016abbeed1f93846 Mon Sep 17 00:00:00 2001
-From: Stanislav Malyshev <stas@php.net>
-Date: Sun, 11 Nov 2018 10:04:01 -0800
-Subject: [PATCH] Fix #77020: null pointer dereference in imap_mail
-
-If an empty $message is passed to imap_mail(), we must not set message
-to NULL, since _php_imap_mail() is not supposed to handle NULL pointers
-(opposed to pointers to NUL).
----
- NEWS | 1 +
- ext/imap/php_imap.c | 1 -
- ext/imap/tests/bug77020.phpt | 15 +++++++++++++++
- 3 files changed, 16 insertions(+), 1 deletion(-)
- create mode 100644 ext/imap/tests/bug77020.phpt
-
-diff --git a/ext/imap/php_imap.c b/ext/imap/php_imap.c
-index a23e84c08521..b30440f000f3 100644
---- a/ext/imap/php_imap.c
-+++ b/ext/imap/php_imap.c
-@@ -4128,7 +4128,6 @@ PHP_FUNCTION(imap_mail)
- if (!ZSTR_LEN(message)) {
- /* this is not really an error, so it is allowed. */
- php_error_docref(NULL, E_WARNING, "No message string in mail command");
-- message = NULL;
- }
-
- if (_php_imap_mail(ZSTR_VAL(to), ZSTR_VAL(subject), ZSTR_VAL(message), headers?ZSTR_VAL(headers):NULL, cc?ZSTR_VAL(cc):NULL,
-diff --git a/ext/imap/tests/bug77020.phpt b/ext/imap/tests/bug77020.phpt
-new file mode 100644
-index 000000000000..8a65232eec6d
---- /dev/null
-+++ b/ext/imap/tests/bug77020.phpt
-@@ -0,0 +1,15 @@
-+--TEST--
-+Bug #77020 (null pointer dereference in imap_mail)
-+--SKIPIF--
-+<?php
-+if (!extension_loaded('imap')) die('skip imap extension not available');
-+?>
-+--FILE--
-+<?php
-+imap_mail('1', 1, NULL);
-+?>
-+===DONE===
-+--EXPECTF--
-+Warning: imap_mail(): No message string in mail command in %s on line %d
-+%s
-+===DONE===
diff --git a/php71.spec b/php71.spec
index a5aa6e9..91b09c8 100644
--- a/php71.spec
+++ b/php71.spec
@@ -107,13 +107,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.1.25
+%global upver 7.1.26
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -173,7 +173,6 @@ Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
# Security fixes (200+)
-Patch200: php-imap.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -1020,7 +1019,6 @@ support for JavaScript Object Notation (JSON) to PHP.
# upstream patches
# security patches
-%patch200 -p1 -b .imap
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -2063,6 +2061,9 @@ fi
%changelog
+* Wed Jan 9 2019 Remi Collet <remi@remirepo.net> - 7.1.26-1
+- Update to 7.1.26 - http://www.php.net/releases/7_1_26.php
+
* Sat Dec 8 2018 Remi Collet <remi@remirepo.net> - 7.1.25-2
- Fix null pointer dereference in imap_mail CVE-2018-19935