summaryrefslogtreecommitdiffstats
path: root/php71.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-20 14:36:32 +0200
committerRemi Collet <remi@php.net>2021-10-20 14:36:32 +0200
commit67718f21d240ce5878f863bf3b41b8ebceb32f32 (patch)
treef0c49df485f911863ee4fae20dd8cf14e0eb63a6 /php71.spec
parent58848d2a0001a7f71483c1756cd8a23f2c37455d (diff)
fix PHP-FPM oob R/W in root process leading to priv escalation
CVE-2021-21703 use libicu version 69 use oracle client library version 21.3
Diffstat (limited to 'php71.spec')
-rw-r--r--php71.spec18
1 files changed, 14 insertions, 4 deletions
diff --git a/php71.spec b/php71.spec
index bda5455..945813f 100644
--- a/php71.spec
+++ b/php71.spec
@@ -26,7 +26,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.1
+%global oraclever 21.3
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -109,7 +109,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 16%{?dist}
+Release: 18%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -143,6 +143,7 @@ Source99: php-fpm.init
# Build fixes
Patch1: php-7.1.7-httpd.patch
+Patch2: php-7.1.33-intl.patch
Patch5: php-7.0.0-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
@@ -196,6 +197,7 @@ Patch224: php-bug80710.patch
Patch225: php-bug81122.patch
Patch226: php-bug76450.patch
Patch227: php-bug81211.patch
+Patch228: php-bug81026.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -950,7 +952,7 @@ Group: System Environment/Libraries
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
# Upstream requires 4.0, we require 50 to ensure use of libicu-last
-BuildRequires: libicu-devel >= 50
+BuildRequires: libicu-devel >= 69
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl, php70u-intl, php70w-intl, php71u-intl, php71w-intl
%endif
@@ -1027,6 +1029,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%setup -q -n php-%{upver}%{?rcver}
%patch1 -p1 -b .mpmcheck
+%patch2 -p1 -b .true
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
@@ -1079,6 +1082,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch225 -p1 -b .bug81122
%patch226 -p1 -b .bug76450
%patch227 -p1 -b .bug81211
+%patch228 -p1 -b .bug81026
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -1588,7 +1592,7 @@ popd
%check
%if %runselftest
-cd build-apache
+cd build-fpm
# Run tests, using the CLI SAPI
export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
@@ -2153,6 +2157,12 @@ EOF
%changelog
+* Wed Oct 20 2021 Remi Collet <remi@remirepo.net> - 7.1.33-18
+- fix PHP-FPM oob R/W in root process leading to priv escalation
+ CVE-2021-21703
+- use libicu version 69
+- use oracle client library version 21.3
+
* Wed Aug 25 2021 Remi Collet <remi@remirepo.net> - 7.1.33-16
- Fix #81211 Symlinks are followed when creating PHAR archive