summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-28 19:20:31 +0100
committerRemi Collet <remi@remirepo.net>2017-11-28 19:20:31 +0100
commitf63ae0f9df31fc55882ade435115036564ae1e9a (patch)
tree18d87dc3009378c68b7aeba845cf70e7bbe92fa5
parent46e2a4d767d559fab04d348b41e4da8215bf6ccc (diff)
refresh patch for https://bugs.php.net/75514
-rw-r--r--0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch34
-rw-r--r--failed.txt14
-rw-r--r--php71.spec7
3 files changed, 46 insertions, 9 deletions
diff --git a/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch b/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
index 23743fe..c963933 100644
--- a/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
+++ b/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
@@ -53,3 +53,37 @@ index 0000000..af97b6d
--
2.9.5
+From 2b071028973782ed87e7038e56d47e9897be804a Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Tue, 28 Nov 2017 17:42:43 +0100
+Subject: [PATCH] better fix for #75514
+
+---
+ ext/standard/mt_rand.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext/standard/mt_rand.c b/ext/standard/mt_rand.c
+index 0a76ab8..46f52db 100644
+--- a/ext/standard/mt_rand.c
++++ b/ext/standard/mt_rand.c
+@@ -260,7 +260,7 @@ PHPAPI zend_long php_mt_rand_range(zend_long min, zend_long max)
+ * rand() allows min > max, mt_rand does not */
+ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
+ {
+- uint32_t n;
++ int64_t n;
+
+ if (BG(mt_rand_mode) == MT_RAND_MT19937) {
+ return php_mt_rand_range(min, max);
+@@ -268,7 +268,7 @@ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
+
+ /* Legacy mode deliberately not inside php_mt_rand_range()
+ * to prevent other functions being affected */
+- n = php_mt_rand() >> 1;
++ n = (int64_t)php_mt_rand() >> 1;
+ RAND_RANGE_BADSCALING(n, min, max, PHP_MT_RAND_MAX);
+
+ return n;
+--
+2.1.4
+
diff --git a/failed.txt b/failed.txt
index cc492d1..1591e3d 100644
--- a/failed.txt
+++ b/failed.txt
@@ -7,18 +7,18 @@ $ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/fc24i/build.log:Tests failed : 0
/var/lib/mock/fc24x/build.log:Tests failed : 0
-/var/lib/mock/fc25i/build.log:Tests failed : 0
-/var/lib/mock/fc25x/build.log:Tests failed : 0
+/var/lib/mock/fc25i/build.log:Tests failed : 1
+/var/lib/mock/fc25x/build.log:Tests failed : 1
/var/lib/mock/fc26i/build.log:Tests failed : 0
-/var/lib/mock/fc26x/build.log:Tests failed : 1
+/var/lib/mock/fc26x/build.log:Tests failed : 0
/var/lib/mock/fc27i/build.log:Tests failed : 1
-/var/lib/mock/fc27x/build.log:Tests failed : 1
+/var/lib/mock/fc27x/build.log:Tests failed : 0
-fc27i:
- 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
-fc26x, fc27x:
+fc25i:
1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
+fc25x, fc27i:
+ 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
1 proc_open give erratic test results :(
diff --git a/php71.spec b/php71.spec
index 6515aa3..3413ff1 100644
--- a/php71.spec
+++ b/php71.spec
@@ -113,7 +113,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -2057,7 +2057,10 @@ fi
%changelog
-* Wed Nov 22 2017 Remi Collet <remi@remirepo.net> - 7.1.12-1
+* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 7.1.12-3
+- refresh patch for https://bugs.php.net/75514
+
+* Wed Nov 22 2017 Remi Collet <remi@remirepo.net> - 7.1.12-2
- Update to 7.1.12 - http://www.php.net/releases/7_1_12.php
* Mon Nov 13 2017 Remi Collet <remi@remirepo.net> - 7.1.12~RC1-2