summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-03-06 09:21:42 +0100
committerRemi Collet <remi@remirepo.net>2019-03-06 09:21:42 +0100
commitdfb3d98285d273641d365e04c5d44d5c7a67cc05 (patch)
treee1e47200104f12c711bab1da349083c138ccae4c
parent61c259a92cc9450a06d3a62cf3d49b1325538159 (diff)
Update to 7.1.27 - http://www.php.net/releases/7_1_27.php
add upstream patch for OpenSSL 1.1.1b
-rw-r--r--failed.txt4
-rw-r--r--php-openssl111.patch29
-rw-r--r--php71.spec9
3 files changed, 37 insertions, 5 deletions
diff --git a/failed.txt b/failed.txt
index 9ceedfa..ce330e8 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,12 +1,10 @@
-===== 7.1.26 (2019-01-10)
+===== 7.1.27 (2019-03-07)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el6i/build.log:Tests failed : 0
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
-/var/lib/mock/fc26i/build.log:Tests failed : 0
-/var/lib/mock/fc26x/build.log:Tests failed : 0
/var/lib/mock/fc27i/build.log:Tests failed : 0
/var/lib/mock/fc27x/build.log:Tests failed : 0
diff --git a/php-openssl111.patch b/php-openssl111.patch
new file mode 100644
index 0000000..ea43711
--- /dev/null
+++ b/php-openssl111.patch
@@ -0,0 +1,29 @@
+From 19a44ffb7be91344550fa700830b8e62a73031ba Mon Sep 17 00:00:00 2001
+From: Anatol Belski <ab@php.net>
+Date: Thu, 28 Feb 2019 12:48:47 +0100
+Subject: [PATCH] Sync with behavior change in OpenSSL 1.1.1b
+
+A behavior change in revealed by some openssl_decrypt() based test,
+where an encrypt API is used with a decrypt context. The EVP_Cipher*
+functions will automatically choose the right operation depending on the
+context passed.
+---
+ ext/openssl/openssl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
+index 871a30c..7df5072 100644
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -6494,7 +6494,7 @@ static int php_openssl_cipher_update(const EVP_CIPHER *cipher_type,
+ {
+ int i = 0;
+
+- if (mode->is_single_run_aead && !EVP_EncryptUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
++ if (mode->is_single_run_aead && !EVP_CipherUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
+ php_openssl_store_errors();
+ php_error_docref(NULL, E_WARNING, "Setting of data length failed");
+ return FAILURE;
+--
+2.1.4
+
diff --git a/php71.spec b/php71.spec
index b007fae..6c79287 100644
--- a/php71.spec
+++ b/php71.spec
@@ -107,8 +107,7 @@
%global db_devel libdb-devel
%endif
-%global upver 7.1.26
-#global rcver RC1
+%global upver 7.1.27
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -171,6 +170,7 @@ Patch49: php-7.1.24-getallheaders.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-openssl111.patch
# Security fixes (200+)
@@ -1018,6 +1018,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up
# security patches
@@ -2062,6 +2063,10 @@ fi
%changelog
+* Wed Mar 6 2019 Remi Collet <remi@remirepo.net> - 7.1.27-1
+- Update to 7.1.27 - http://www.php.net/releases/7_1_27.php
+- add upstream patch for OpenSSL 1.1.1b
+
* Wed Jan 9 2019 Remi Collet <remi@remirepo.net> - 7.1.26-1
- Update to 7.1.26 - http://www.php.net/releases/7_1_26.php