summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-01 15:16:48 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-01 15:16:48 +0200
commitc506778b405fd2008ab19ac2b0cb71c7e8ffc821 (patch)
tree36608af520c350d6caa8936d3d7cf0727b5908bc
parentea25d2104e8cef4f67f70e307e74179c13ab2bae (diff)
PHP 7.1.0RC1
-rw-r--r--failed.txt25
-rw-r--r--php-upstream.patch386
-rw-r--r--php71.spec15
3 files changed, 407 insertions, 19 deletions
diff --git a/failed.txt b/failed.txt
index 4691696..b0f5944 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,24 +1,19 @@
-===== 7.1.0beta2 (2016-08-04)
+===== 7.1.0RC1 (2016-09-01)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/el6i/build.log:Tests failed : 4
-/var/lib/mock/el6x/build.log:Tests failed : 2
+/var/lib/mock/el6i/build.log:Tests failed : 0
+/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 1
-/var/lib/mock/fc23i/build.log:Tests failed : 3
-/var/lib/mock/fc23x/build.log:Tests failed : 1
-/var/lib/mock/fc24i/build.log:Tests failed : 3
-/var/lib/mock/fc24x/build.log:Tests failed : 1
+/var/lib/mock/fc23i/build.log:Tests failed : 1
+/var/lib/mock/fc23x/build.log:Tests failed : 0
+/var/lib/mock/fc24i/build.log:Tests failed : 0
+/var/lib/mock/fc24x/build.log:Tests failed : 0
-el6x,
+el7x
+ * php://input is empty when enable_post_data_reading=Off [tests/basic/bug67198.phpt]
+fc23i
* Bug #70198 Checking liveness does not work as expected [ext/standard/tests/streams/bug70198.phpt]
-el6i
- *** Test mt_rand() function : usage variations - different data types as $max argument [ext/standard/tests/math/mt_rand_variation2.phpt]
-el6x, el6x, el7x, fc23i, fc23x, fc24i, fc24x
- *** Test base64_decode() function : basic functionality - padding and whitespace [ext/standard/tests/url/base64_decode_basic_003.phpt]
-el6i, fc23i, fc24i
- *** Test rand() function : usage variations - different data types as $min argument [ext/standard/tests/math/rand_variation1.phpt]
- *** Test rand() function : usage variations - different data types as $max argument [ext/standard/tests/math/rand_variation2.phpt]
* proc_open give erratic test results :(
** date tests vary with tzdata available in system
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..c8b9406
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,386 @@
+From a70ca97c189e5ccf931a4fa6dd4186a0d6cd3e14 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Wed, 3 Aug 2016 14:24:35 +0200
+Subject: [PATCH] fix paths in tests
+
+---
+ ext/standard/tests/math/rand_variation1.phpt | 4 +--
+ ext/standard/tests/math/rand_variation2.phpt | 48 ++++++++++++++--------------
+ 2 files changed, 26 insertions(+), 26 deletions(-)
+
+diff --git a/ext/standard/tests/math/rand_variation1.phpt b/ext/standard/tests/math/rand_variation1.phpt
+index 7b38751..7019a99 100644
+--- a/ext/standard/tests/math/rand_variation1.phpt
++++ b/ext/standard/tests/math/rand_variation1.phpt
+@@ -98,7 +98,7 @@ int(%i)
+
+ -- Iteration 3 --
+
+-Warning: rand(): max(100) is smaller than min(12345) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation1.php on line 79
++Warning: rand(): max(100) is smaller than min(12345) in %s on line %d
+ bool(false)
+
+ -- Iteration 4 --
+@@ -106,7 +106,7 @@ int(%i)
+
+ -- Iteration 5 --
+
+-Warning: rand(): max(100) is smaller than min(2147483647) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation1.php on line 79
++Warning: rand(): max(100) is smaller than min(2147483647) in %s on line %d
+ bool(false)
+
+ -- Iteration 6 --
+diff --git a/ext/standard/tests/math/rand_variation2.phpt b/ext/standard/tests/math/rand_variation2.phpt
+index 379f883..04ee205 100644
+--- a/ext/standard/tests/math/rand_variation2.phpt
++++ b/ext/standard/tests/math/rand_variation2.phpt
+@@ -92,12 +92,12 @@ fclose($fp);
+
+ -- Iteration 1 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 2 --
+
+-Warning: rand(): max(1) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(1) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 3 --
+@@ -105,7 +105,7 @@ int(%i)
+
+ -- Iteration 4 --
+
+-Warning: rand(): max(-2345) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(-2345) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 5 --
+@@ -113,106 +113,106 @@ int(%i)
+
+ -- Iteration 6 --
+
+-Warning: rand(): max(10) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(10) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 7 --
+
+-Warning: rand(): max(-10) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(-10) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 8 --
+
+-Warning: rand() expects parameter 2 to be integer, float given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, float given in %s on line %d
+ NULL
+
+ -- Iteration 9 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 10 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 11 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 12 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 13 --
+
+-Warning: rand(): max(1) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(1) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 14 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 15 --
+
+-Warning: rand(): max(1) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(1) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 16 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 17 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
+ NULL
+
+ -- Iteration 18 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
+ NULL
+
+ -- Iteration 19 --
+
+-Warning: rand() expects parameter 2 to be integer, array given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, array given in %s on line %d
+ NULL
+
+ -- Iteration 20 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
+ NULL
+
+ -- Iteration 21 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
+ NULL
+
+ -- Iteration 22 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
+ NULL
+
+ -- Iteration 23 --
+
+-Warning: rand() expects parameter 2 to be integer, object given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, object given in %s on line %d
+ NULL
+
+ -- Iteration 24 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 25 --
+
+-Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand(): max(0) is smaller than min(100) in %s on line %d
+ bool(false)
+
+ -- Iteration 26 --
+
+-Warning: rand() expects parameter 2 to be integer, resource given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++Warning: rand() expects parameter 2 to be integer, resource given in %s on line %d
+ NULL
+ ===Done===
+--
+2.1.4
+
+From cff668f7a7a5891d29b69eda2a4a1ad58e3d1afc Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Wed, 3 Aug 2016 12:56:07 +0200
+Subject: [PATCH] Fix 32bits tests
+
+Notice: this warning is only raise since rand is an alias to mt_rand
+---
+ ext/standard/tests/math/rand_variation1.phpt | 8 ++-
+ ext/standard/tests/math/rand_variation2.phpt | 78 +++++++++++++++++++---------
+ 2 files changed, 60 insertions(+), 26 deletions(-)
+
+diff --git a/ext/standard/tests/math/rand_variation1.phpt b/ext/standard/tests/math/rand_variation1.phpt
+index f14ada8..7b38751 100644
+--- a/ext/standard/tests/math/rand_variation1.phpt
++++ b/ext/standard/tests/math/rand_variation1.phpt
+@@ -97,13 +97,17 @@ int(%i)
+ int(%i)
+
+ -- Iteration 3 --
+-int(%i)
++
++Warning: rand(): max(100) is smaller than min(12345) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation1.php on line 79
++bool(false)
+
+ -- Iteration 4 --
+ int(%i)
+
+ -- Iteration 5 --
+-int(%i)
++
++Warning: rand(): max(100) is smaller than min(2147483647) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation1.php on line 79
++bool(false)
+
+ -- Iteration 6 --
+ int(%i)
+diff --git a/ext/standard/tests/math/rand_variation2.phpt b/ext/standard/tests/math/rand_variation2.phpt
+index 824b47b..379f883 100644
+--- a/ext/standard/tests/math/rand_variation2.phpt
++++ b/ext/standard/tests/math/rand_variation2.phpt
+@@ -91,98 +91,128 @@ fclose($fp);
+ *** Testing rand) : usage variations ***
+
+ -- Iteration 1 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 2 --
+-int(%i)
++
++Warning: rand(): max(1) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 3 --
+ int(%i)
+
+ -- Iteration 4 --
+-int(%i)
++
++Warning: rand(): max(-2345) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 5 --
+ int(%i)
+
+ -- Iteration 6 --
+-int(%i)
++
++Warning: rand(): max(10) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 7 --
+-int(%i)
++
++Warning: rand(): max(-10) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 8 --
+
+-Warning: rand() expects parameter 2 to be integer, float given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, float given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+
+ -- Iteration 9 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 10 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 11 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 12 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 13 --
+-int(%i)
++
++Warning: rand(): max(1) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 14 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 15 --
+-int(%i)
++
++Warning: rand(): max(1) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 16 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 17 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+
+ -- Iteration 18 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+
+ -- Iteration 19 --
+
+-Warning: rand() expects parameter 2 to be integer, array given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, array given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+
+ -- Iteration 20 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+
+ -- Iteration 21 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+
+ -- Iteration 22 --
+
+-Warning: rand() expects parameter 2 to be integer, string given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, string given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+
+ -- Iteration 23 --
+
+-Warning: rand() expects parameter 2 to be integer, object given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, object given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+
+ -- Iteration 24 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 25 --
+-int(%i)
++
++Warning: rand(): max(0) is smaller than min(100) in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
++bool(false)
+
+ -- Iteration 26 --
+
+-Warning: rand() expects parameter 2 to be integer, resource given in %s on line %d
++Warning: rand() expects parameter 2 to be integer, resource given in /builddir/build/BUILD/php-7.1.0beta2/ext/standard/tests/math/rand_variation2.php on line 79
+ NULL
+ ===Done===
+--
+2.1.4
+
diff --git a/php71.spec b/php71.spec
index 90dcc81..3dc88dd 100644
--- a/php71.spec
+++ b/php71.spec
@@ -14,9 +14,9 @@
%global pdover 20150127
# Extension version
%global fileinfover 1.0.5
-%global oci8ver 2.1.1
+%global oci8ver 2.1.2
%global zipver 1.13.0
-%global jsonver 1.4.0
+%global jsonver 1.5.0
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -120,8 +120,8 @@
%global db_devel libdb-devel
%endif
-%global rcver beta2
-%global rpmrel 2
+%global rcver RC1
+%global rpmrel 3
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -177,6 +177,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -958,6 +959,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -R -b .upstream
# security patches
@@ -1994,6 +1996,11 @@ fi
%changelog
+* Thu Sep 1 2016 Remi Collet <remi@fedoraproject.org> 7.1.0-0.3.RC1
+- Update to 7.1.0RC1
+- oci8 version is now 2.1.2
+- json version is now 1.5.0
+
* Wed Aug 3 2016 Remi Collet <remi@fedoraproject.org> 7.1.0-0.2.beta2
- Update to 7.1.0beta2