summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-28 13:03:15 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-28 13:03:15 +0100
commitb9c8ca3b0b109e0e1c32ad47cc6ef2f3e200c54c (patch)
tree2478d11100e2a0b59989c576876e4fbe979ee9f8
parent1b50f87d488a5080797544ca6be22c47b0d58212 (diff)
PHP 7.1.3RC1
-rw-r--r--failed.txt2
-rw-r--r--php-7.1.3-dlopen.patch (renamed from php-7.0.0-dlopen.patch)18
-rw-r--r--php-upstream.patch57
-rw-r--r--php71.spec11
4 files changed, 75 insertions, 13 deletions
diff --git a/failed.txt b/failed.txt
index 738dfb2..782b457 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.1.2(2017-02-16)
+===== 7.1.3RC1 (2017-03-02)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
diff --git a/php-7.0.0-dlopen.patch b/php-7.1.3-dlopen.patch
index 4047460..cd35dc0 100644
--- a/php-7.0.0-dlopen.patch
+++ b/php-7.1.3-dlopen.patch
@@ -1,7 +1,7 @@
-diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespeed/lsapilib.c
---- php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen 2015-08-18 23:39:17.000000000 +0200
-+++ php-7.0.0RC1/sapi/litespeed/lsapilib.c 2015-08-22 07:46:31.729721983 +0200
-@@ -582,7 +582,7 @@ static int (*fp_lve_leave)(struct liblve
+diff -up php-7.1.3RC1/sapi/litespeed/lsapilib.c.dlopen php-7.1.3RC1/sapi/litespeed/lsapilib.c
+--- php-7.1.3RC1/sapi/litespeed/lsapilib.c.dlopen 2017-02-28 10:12:34.000000000 +0100
++++ php-7.1.3RC1/sapi/litespeed/lsapilib.c 2017-02-28 10:23:11.384521740 +0100
+@@ -616,7 +616,7 @@ static int (*fp_lve_leave)(struct liblve
static int (*fp_lve_jail)( struct passwd *, char *) = NULL;
static int lsapi_load_lve_lib()
{
@@ -10,16 +10,16 @@ diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespe
if (s_liblve)
{
fp_lve_is_available = dlsym(s_liblve, "lve_is_available");
-diff -up php-7.0.0RC1/Zend/zend_portability.h.dlopen php-7.0.0RC1/Zend/zend_portability.h
---- php-7.0.0RC1/Zend/zend_portability.h.dlopen 2015-08-18 23:39:16.000000000 +0200
-+++ php-7.0.0RC1/Zend/zend_portability.h 2015-08-22 07:46:31.729721983 +0200
-@@ -136,11 +136,11 @@
+diff -up php-7.1.3RC1/Zend/zend_portability.h.dlopen php-7.1.3RC1/Zend/zend_portability.h
+--- php-7.1.3RC1/Zend/zend_portability.h.dlopen 2017-02-28 10:23:11.384521740 +0100
++++ php-7.1.3RC1/Zend/zend_portability.h 2017-02-28 10:26:08.960308560 +0100
+@@ -146,11 +146,11 @@
# endif
# if defined(RTLD_GROUP) && defined(RTLD_WORLD) && defined(RTLD_PARENT)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
- # elif defined(RTLD_DEEPBIND)
+ # elif defined(RTLD_DEEPBIND) && !defined(__SANITIZE_ADDRESS__)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_DEEPBIND)
+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_DEEPBIND)
# else
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..c1e0abf
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,57 @@
+From 3006d1de5b1b2903af3ad1e8c72c3cfe6cd1af15 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Tue, 28 Feb 2017 11:36:24 +0100
+Subject: [PATCH] make test slower again
+
+---
+ Zend/tests/bug74093.phpt | 40 ++++++++++++++++++++--------------------
+ 1 file changed, 20 insertions(+), 20 deletions(-)
+
+diff --git a/Zend/tests/bug74093.phpt b/Zend/tests/bug74093.phpt
+index 22c78a6..7f20285 100644
+--- a/Zend/tests/bug74093.phpt
++++ b/Zend/tests/bug74093.phpt
+@@ -1,20 +1,20 @@
+---TEST--
+-Bug #74093 (Maximum execution time of n+2 seconds exceed not written in error_log)
+---SKIPIF--
+-<?php
+-if (getenv("SKIP_SLOW_TESTS")) die("skip slow test");
+-if (PHP_ZTS) die("skip only for no-zts build");
+-if (substr(PHP_OS, 0, 3) == 'WIN') die("skip not for Windows");
+-?>
+---INI--
+-memory_limit=1G
+-max_execution_time=1
+-hard_timeout=1
+---FILE--
+-<?php
+-$a1 = range(1, 1000000);
+-$a2 = range(100000, 999999);
+-array_intersect($a1, $a2);
+-?>
+---EXPECTF--
+-Fatal error: Maximum execution time of 1+1 seconds exceeded %s
++--TEST--
++Bug #74093 (Maximum execution time of n+2 seconds exceed not written in error_log)
++--SKIPIF--
++<?php
++if (getenv("SKIP_SLOW_TESTS")) die("skip slow test");
++if (PHP_ZTS) die("skip only for no-zts build");
++if (substr(PHP_OS, 0, 3) == 'WIN') die("skip not for Windows");
++?>
++--INI--
++memory_limit=1G
++max_execution_time=1
++hard_timeout=1
++--FILE--
++<?php
++$a1 = range(1, 1000000);
++$a2 = range(100000, 1999999);
++array_intersect($a1, $a2);
++?>
++--EXPECTF--
++Fatal error: Maximum execution time of 1+1 seconds exceeded %s
+--
+2.1.4
+
diff --git a/php71.spec b/php71.spec
index ac4febf..04aaf90 100644
--- a/php71.spec
+++ b/php71.spec
@@ -120,12 +120,12 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 7.1.2
+Version: 7.1.3
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -162,7 +162,7 @@ Patch8: php-7.0.2-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
-Patch40: php-7.0.0-dlopen.patch
+Patch40: php-7.1.3-dlopen.patch
Patch42: php-7.1.0-systzdata-v14.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
@@ -177,6 +177,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -1026,6 +1027,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .upstream
# security patches
@@ -2047,6 +2049,9 @@ fi
%changelog
+* Tue Feb 28 2017 Remi Collet <remi@fedoraproject.org> 7.1.3-0.1.RC1
+- Update to 7.1.3RC1
+
* Wed Feb 15 2017 Remi Collet <remi@fedoraproject.org> 7.1.2-1
- Update to 7.1.2 - http://www.php.net/releases/7_1_2.php