summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-06 09:11:11 +0100
committerRemi Collet <remi@remirepo.net>2017-12-06 09:11:11 +0100
commitb23d24e3c6bdc19f3bb0a038bf75dfacab31028f (patch)
tree15f63c009b3478d91c7f98999a1c62d235a25f4b
parent912a14cec72d394e150312bc746618005109a4f6 (diff)
v7.1.13RC1
-rw-r--r--failed.txt14
-rw-r--r--php-bug75514.patch89
-rw-r--r--php-bug75573.patch107
-rw-r--r--php71.spec18
4 files changed, 17 insertions, 211 deletions
diff --git a/failed.txt b/failed.txt
index 1591e3d..97a41f3 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,24 +1,24 @@
-===== 7.1.12 (2017-11-23)
+===== 7.1.13RC1 (2017-12-07)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el6i/build.log:Tests failed : 0
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
-/var/lib/mock/fc24i/build.log:Tests failed : 0
+/var/lib/mock/fc24i/build.log:Tests failed : 1
/var/lib/mock/fc24x/build.log:Tests failed : 0
-/var/lib/mock/fc25i/build.log:Tests failed : 1
+/var/lib/mock/fc25i/build.log:Tests failed : 0
/var/lib/mock/fc25x/build.log:Tests failed : 1
/var/lib/mock/fc26i/build.log:Tests failed : 0
/var/lib/mock/fc26x/build.log:Tests failed : 0
-/var/lib/mock/fc27i/build.log:Tests failed : 1
+/var/lib/mock/fc27i/build.log:Tests failed : 0
/var/lib/mock/fc27x/build.log:Tests failed : 0
-fc25i:
- 1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
-fc25x, fc27i:
+fc24i:
1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
+fc25x:
+ 1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
1 proc_open give erratic test results :(
diff --git a/php-bug75514.patch b/php-bug75514.patch
deleted file mode 100644
index c963933..0000000
--- a/php-bug75514.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From 00500c425ba895f1b3591ace3ccd5ee125307559 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 13 Nov 2017 09:55:10 +0100
-Subject: [PATCH] Fixed bug #75514 mt_rand returns value outside [$min,$max]+
- on 32-bit
-
----
- ext/standard/mt_rand.c | 4 ++--
- ext/standard/tests/math/bug75514.phpt | 12 ++++++++++++
- 2 files changed, 14 insertions(+), 2 deletions(-)
- create mode 100644 ext/standard/tests/math/bug75514.phpt
-
-diff --git a/ext/standard/mt_rand.c b/ext/standard/mt_rand.c
-index 2335a92..6669cbc 100644
---- a/ext/standard/mt_rand.c
-+++ b/ext/standard/mt_rand.c
-@@ -294,7 +294,7 @@ PHPAPI zend_long php_mt_rand_range(zend_long min, zend_long max)
- * rand() allows min > max, mt_rand does not */
- PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
- {
-- zend_long n;
-+ uint32_t n;
-
- if (BG(mt_rand_mode) == MT_RAND_MT19937) {
- return php_mt_rand_range(min, max);
-@@ -302,7 +302,7 @@ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
-
- /* Legacy mode deliberately not inside php_mt_rand_range()
- * to prevent other functions being affected */
-- n = (zend_long)php_mt_rand() >> 1;
-+ n = php_mt_rand() >> 1;
- RAND_RANGE_BADSCALING(n, min, max, PHP_MT_RAND_MAX);
-
- return n;
-diff --git a/ext/standard/tests/math/bug75514.phpt b/ext/standard/tests/math/bug75514.phpt
-new file mode 100644
-index 0000000..af97b6d
---- /dev/null
-+++ b/ext/standard/tests/math/bug75514.phpt
-@@ -0,0 +1,12 @@
-+--TEST--
-+Bug #75514 mt_rand returns value outside [$min,$max]
-+--FILE--
-+<?php
-+mt_srand(0, MT_RAND_PHP);
-+var_dump(mt_rand(0,999999999), mt_rand(0,999));
-+?>
-+===Done===
-+--EXPECT--
-+int(448865905)
-+int(592)
-+===Done===
---
-2.9.5
-
-From 2b071028973782ed87e7038e56d47e9897be804a Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Tue, 28 Nov 2017 17:42:43 +0100
-Subject: [PATCH] better fix for #75514
-
----
- ext/standard/mt_rand.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/ext/standard/mt_rand.c b/ext/standard/mt_rand.c
-index 0a76ab8..46f52db 100644
---- a/ext/standard/mt_rand.c
-+++ b/ext/standard/mt_rand.c
-@@ -260,7 +260,7 @@ PHPAPI zend_long php_mt_rand_range(zend_long min, zend_long max)
- * rand() allows min > max, mt_rand does not */
- PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
- {
-- uint32_t n;
-+ int64_t n;
-
- if (BG(mt_rand_mode) == MT_RAND_MT19937) {
- return php_mt_rand_range(min, max);
-@@ -268,7 +268,7 @@ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
-
- /* Legacy mode deliberately not inside php_mt_rand_range()
- * to prevent other functions being affected */
-- n = php_mt_rand() >> 1;
-+ n = (int64_t)php_mt_rand() >> 1;
- RAND_RANGE_BADSCALING(n, min, max, PHP_MT_RAND_MAX);
-
- return n;
---
-2.1.4
-
diff --git a/php-bug75573.patch b/php-bug75573.patch
deleted file mode 100644
index 46cf095..0000000
--- a/php-bug75573.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-From 3b9ba7b6bd9e24bdbeca8e8e3f24cee2fccc51d8 Mon Sep 17 00:00:00 2001
-From: Xinchen Hui <laruence@gmail.com>
-Date: Wed, 29 Nov 2017 14:46:21 +0800
-Subject: [PATCH] Fixed bug #75573 (Segmentation fault in 7.1.12 and 7.0.26)
-
----
- NEWS | 1 +
- Zend/tests/bug75573.phpt | 64 +++++++++++++++++++++++++++++++++++++++++++++
- Zend/zend_object_handlers.c | 10 +++----
- 3 files changed, 69 insertions(+), 6 deletions(-)
- create mode 100644 Zend/tests/bug75573.phpt
-
-diff --git a/Zend/tests/bug75573.phpt b/Zend/tests/bug75573.phpt
-new file mode 100644
-index 0000000..476ff6e
---- /dev/null
-+++ b/Zend/tests/bug75573.phpt
-@@ -0,0 +1,64 @@
-+--TEST--
-+Bug #75573 (Segmentation fault in 7.1.12 and 7.0.26)
-+--FILE--
-+<?php
-+
-+class A
-+{
-+ var $_stdObject;
-+ function initialize($properties = FALSE) {
-+ $this->_stdObject = $properties ? (object) $properties : new stdClass();
-+ parent::initialize();
-+ }
-+ function &__get($property)
-+ {
-+ if (isset($this->_stdObject->{$property})) {
-+ $retval =& $this->_stdObject->{$property};
-+ return $retval;
-+ } else {
-+ return NULL;
-+ }
-+ }
-+ function &__set($property, $value)
-+ {
-+ return $this->_stdObject->{$property} = $value;
-+ }
-+ function __isset($property_name)
-+ {
-+ return isset($this->_stdObject->{$property_name});
-+ }
-+}
-+
-+class B extends A
-+{
-+ function initialize($properties = array())
-+ {
-+ parent::initialize($properties);
-+ }
-+ function &__get($property)
-+ {
-+ if (isset($this->settings) && isset($this->settings[$property])) {
-+ $retval =& $this->settings[$property];
-+ return $retval;
-+ } else {
-+ return parent::__get($property);
-+ }
-+ }
-+}
-+
-+$b = new B();
-+$b->settings = [ "foo" => "bar", "name" => "abc" ];
-+var_dump($b->name);
-+var_dump($b->settings);
-+?>
-+--EXPECTF--
-+Warning: Creating default object from empty value in %sbug75573.php on line %d
-+
-+Notice: Only variable references should be returned by reference in %sbug75573.php on line %d
-+string(3) "abc"
-+array(2) {
-+ ["foo"]=>
-+ string(3) "bar"
-+ ["name"]=>
-+ string(3) "abc"
-+}
-diff --git a/Zend/zend_object_handlers.c b/Zend/zend_object_handlers.c
-index 10045b5..d9ebd84 100644
---- a/Zend/zend_object_handlers.c
-+++ b/Zend/zend_object_handlers.c
-@@ -668,13 +668,11 @@ zval *zend_std_read_property(zval *object, zval *member, int type, void **cache_
- }
- zval_ptr_dtor(&tmp_object);
- goto exit;
-- } else {
-+ } else if (Z_STRVAL_P(member)[0] == '\0' && Z_STRLEN_P(member) != 0) {
- zval_ptr_dtor(&tmp_object);
-- if (Z_STRVAL_P(member)[0] == '\0' && Z_STRLEN_P(member) != 0) {
-- zend_throw_error(NULL, "Cannot access property started with '\\0'");
-- retval = &EG(uninitialized_zval);
-- goto exit;
-- }
-+ zend_throw_error(NULL, "Cannot access property started with '\\0'");
-+ retval = &EG(uninitialized_zval);
-+ goto exit;
- }
- }
-
---
-2.1.4
-
diff --git a/php71.spec b/php71.spec
index e2d1106..442bf92 100644
--- a/php71.spec
+++ b/php71.spec
@@ -107,13 +107,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.1.12
-#global rcver RC1
+%global upver 7.1.13
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 4%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -170,8 +170,6 @@ Patch48: php-7.1.9-openssl-load-config.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-bug75573.patch
-Patch101: php-bug75514.patch
# Security fixes (200+)
@@ -1020,8 +1018,6 @@ support for JavaScript Object Notation (JSON) to PHP.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .bug75573
-%patch101 -p1 -b .bug75514
# security patches
@@ -1171,6 +1167,9 @@ if [ ! -f Zend/zend_language_parser.c ]; then
./genfiles
fi
+# For doc
+cat %{SOURCE1} %{SOURCE11} >httpd-php.conf
+
%build
%{?dtsenable}
@@ -1952,7 +1951,7 @@ fi
%doc sapi/phpdbg/{README.md,CREDITS}
%files fpm
-%doc php-fpm.conf.default www.conf.default
+%doc php-fpm.conf.default www.conf.default httpd-php.conf
%license fpm_LICENSE
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
@@ -2059,6 +2058,9 @@ fi
%changelog
+* Wed Dec 6 2017 Remi Collet <remi@remirepo.net> - 7.1.13~RC1-1
+- Update to 7.1.13RC1
+
* Fri Dec 1 2017 Remi Collet <remi@remirepo.net> - 7.1.12-4
- add upstream patch for https://bugs.php.net/75573