summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-16 20:56:40 +0200
committerRemi Collet <remi@remirepo.net>2017-08-16 20:56:40 +0200
commitb0cc2368433334140d8c656ce3ed75af723e4519 (patch)
treef5adf10a4ecacd8eb9ecca91698b977991177e6f
parent33083068bd6590d5d81d4d5b5bca0f38d2522436 (diff)
Update to 7.1.9RC1
oci8 version is now 2.1.7
-rw-r--r--failed.txt16
-rw-r--r--php-sqlite3.patch53
-rw-r--r--php71.spec14
3 files changed, 18 insertions, 65 deletions
diff --git a/failed.txt b/failed.txt
index 1f85d60..e6efe91 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.1.8 (2017-08-03)
+===== 7.1.9RC1 (2017-08-17)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
@@ -7,19 +7,23 @@ $ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/fc23i/build.log:Tests failed : 0
/var/lib/mock/fc23x/build.log:Tests failed : 0
-/var/lib/mock/fc24i/build.log:Tests failed : 1
+/var/lib/mock/fc24i/build.log:Tests failed : 0
/var/lib/mock/fc24x/build.log:Tests failed : 0
/var/lib/mock/fc25i/build.log:Tests failed : 0
/var/lib/mock/fc25x/build.log:Tests failed : 0
-/var/lib/mock/fc26i/build.log:Tests failed : 0
-/var/lib/mock/fc26x/build.log:Tests failed : 0
+/var/lib/mock/fc26i/build.log:Tests failed : 1
+/var/lib/mock/fc26x/build.log:Tests failed : 2
-fc24i
- 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
+fc26i
+ 1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
+fc26x
+ 5 proc_nice() basic behaviour [ext/standard/tests/general_functions/proc_nice_basic.phpt]
+ 5 Check cli_process_title support on Unix [sapi/cli/tests/cli_process_title_unix.phpt]
1 proc_open give erratic test results :(
2 test issue (fixed upstream)
3 known issue
4 bugs related to tzdata
+5 need investigation
diff --git a/php-sqlite3.patch b/php-sqlite3.patch
deleted file mode 100644
index cdb7d84..0000000
--- a/php-sqlite3.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 666cb6c80226467be262c088a26246c48cdef7e5 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 2 Aug 2017 14:01:56 +0200
-Subject: [PATCH] fix build with old system libsqlite (sqlite3_errstr may be
- missing)
-
----
- ext/sqlite3/config0.m4 | 5 ++++-
- ext/sqlite3/sqlite3.c | 4 ++++
- 2 files changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
-index 3aa4492..ba760e1 100644
---- a/ext/sqlite3/config0.m4
-+++ b/ext/sqlite3/config0.m4
-@@ -53,6 +53,9 @@ if test $PHP_SQLITE3 != "no"; then
- PHP_CHECK_LIBRARY(sqlite3,sqlite3_column_table_name,[
- AC_DEFINE(SQLITE_ENABLE_COLUMN_METADATA, 1, [have sqlite3 with column metadata enabled])
- ])
-+ PHP_CHECK_LIBRARY(sqlite3,sqlite3_errstr,[
-+ AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
-+ ])
-
- PHP_CHECK_LIBRARY(sqlite3,sqlite3_load_extension,
- [],
-@@ -75,7 +78,7 @@ if test $PHP_SQLITE3 != "no"; then
- debug_flags="-DSQLITE_DEBUG=1"
- fi
-
-- other_flags="-DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_FTS4=1 -DSQLITE_ENABLE_FTS5=1 -DSQLITE_CORE=1 -DSQLITE_ENABLE_COLUMN_METADATA=1"
-+ other_flags="-DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_FTS4=1 -DSQLITE_ENABLE_FTS5=1 -DSQLITE_CORE=1 -DSQLITE_ENABLE_COLUMN_METADATA=1 -DHAVE_SQLITE3_ERRSTR=1"
-
- dnl As long as intl is not shared we can have ICU support
- if test "$PHP_INTL" = "yes" && test "$PHP_INTL_SHARED" != "yes"; then
-diff --git a/ext/sqlite3/sqlite3.c b/ext/sqlite3/sqlite3.c
-index dcbc03c..a22f455 100644
---- a/ext/sqlite3/sqlite3.c
-+++ b/ext/sqlite3/sqlite3.c
-@@ -148,7 +148,11 @@ PHP_METHOD(sqlite3, open)
- #endif
- if (rc != SQLITE_OK) {
- zend_throw_exception_ex(zend_ce_exception, 0, "Unable to open database: %s",
-+#ifdef HAVE_SQLITE3_ERRSTR
- db_obj->db ? sqlite3_errmsg(db_obj->db) : sqlite3_errstr(rc));
-+#else
-+ db_obj->db ? sqlite3_errmsg(db_obj->db) : "");
-+#endif
- if (fullpath != filename) {
- efree(fullpath);
- }
---
-2.1.4
-
diff --git a/php71.spec b/php71.spec
index 86010c0..4a7a7b7 100644
--- a/php71.spec
+++ b/php71.spec
@@ -14,7 +14,7 @@
%global pdover 20150127
# Extension version
%global fileinfover 1.0.5
-%global oci8ver 2.1.6
+%global oci8ver 2.1.7
%global zipver 1.13.0
%global jsonver 1.5.0
@@ -120,13 +120,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.1.8
-#global rcver RC1
+%global upver 7.1.9
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -162,7 +162,6 @@ Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-7.0.2-libdb.patch
Patch9: php-7.0.7-curl.patch
-Patch10: php-sqlite3.patch
# Functional changes
Patch40: php-7.1.3-dlopen.patch
@@ -1009,7 +1008,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%if 0%{?rhel}
%patch9 -p1 -b .curltls
%endif
-%patch10 -p1 -b .errstr
%patch40 -p1 -b .dlopen
%if 0%{?fedora} >= 24 || 0%{?rhel} >= 5
@@ -2059,6 +2057,10 @@ fi
%changelog
+* Wed Aug 16 2017 Remi Collet <remi@fedoraproject.org> - 7.1.9~RC1-1
+- Update to 7.1.9RC1
+- oci8 version is now 2.1.7
+
* Wed Aug 2 2017 Remi Collet <remi@fedoraproject.org> - 7.1.8-2
- add patch for EL-6, fix undefined symbol: sqlite3_errstr